Bug 29663 - Document expected behavior of Prefill Item
Summary: Document expected behavior of Prefill Item
Status: RESOLVED DUPLICATE of bug 29662
Alias: None
Product: Koha
Classification: Unclassified
Component: Documentation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Bugs List
QA Contact: Testopia
URL:
Keywords:
Depends on: 29661 29662
Blocks:
  Show dependency treegraph
 
Reported: 2021-12-08 16:58 UTC by Andrew Fuerste-Henry
Modified: 2022-10-18 22:11 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Fuerste-Henry 2021-12-08 16:58:21 UTC
Bug 29661 and bug 29662 highlight a general confusion about how PrefillItem and SubfieldsToUseWhenPrefill are expected to behave, which makes it too easy to inadvertently change behavior. More detail in the manual could be helpful. The two bits in question are whether or not fields should be prefilled when duplicating an item and whether a blank SubfieldsToUseWhenPrefill should mean all subfields are prefilled or no subfields are prefilled.
Comment 1 Katrin Fischer 2022-10-18 22:11:07 UTC
I amended the system preference on bug 29662 and we can use the new Needs Documenting after to make sure this goes into the manual. Marking duplicate.

*** This bug has been marked as a duplicate of bug 29662 ***