Bug 30081 - Display item type in patron's holds table
Summary: Display item type in patron's holds table
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff interface (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Lari Taskula
QA Contact: Testopia
URL:
Keywords:
: 29982 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-02-11 12:53 UTC by Lari Taskula
Modified: 2022-02-19 13:25 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 30081: Add item type column to holds table (3.46 KB, patch)
2022-02-11 13:01 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 30081: Use itemtype description instead of itemtype code (1.65 KB, patch)
2022-02-11 13:08 UTC, Lari Taskula
Details | Diff | Splinter Review
Bug 30081: Add item type column to holds table (3.51 KB, patch)
2022-02-11 13:15 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 30081: Use itemtype description instead of itemtype code (1.70 KB, patch)
2022-02-11 13:15 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 30081: Add item type column to holds table (3.56 KB, patch)
2022-02-13 14:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 30081: Use itemtype description instead of itemtype code (1.76 KB, patch)
2022-02-13 14:20 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Lari Taskula 2022-02-11 12:53:35 UTC
Add new column item type to holds table in patron's details and check out views. Some libraries will find this information useful for distinguishing inter library holds from normal holds.
Comment 1 Lari Taskula 2022-02-11 13:01:03 UTC
Created attachment 130490 [details] [review]
Bug 30081: Add item type column to holds table

Add new column item type to holds table in patron's details and check
out views. Some libraries will find this information useful for
distinguishing inter library holds from normal holds.

To test:
1. Apply patch
2. Place a hold and confirm it
3. Go to cgi-bin/koha/circ/circulation.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
4. Click "1 Hold(s)" tab
5. Observe new column "Item type"
6. Confirm the item type is correct
7. Go to moremember.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
8. Repeat steps 4-6
Comment 2 Lari Taskula 2022-02-11 13:08:57 UTC
Created attachment 130492 [details] [review]
Bug 30081: Use itemtype description instead of itemtype code

To test:
1. Use same plan as previous patch, but observe full item type description
   instead of item type code
Comment 3 Owen Leonard 2022-02-11 13:15:03 UTC
Created attachment 130493 [details] [review]
Bug 30081: Add item type column to holds table

Add new column item type to holds table in patron's details and check
out views. Some libraries will find this information useful for
distinguishing inter library holds from normal holds.

To test:
1. Apply patch
2. Place a hold and confirm it
3. Go to cgi-bin/koha/circ/circulation.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
4. Click "1 Hold(s)" tab
5. Observe new column "Item type"
6. Confirm the item type is correct
7. Go to moremember.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
8. Repeat steps 4-6

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 4 Owen Leonard 2022-02-11 13:15:07 UTC
Created attachment 130494 [details] [review]
Bug 30081: Use itemtype description instead of itemtype code

To test:
1. Use same plan as previous patch, but observe full item type description
   instead of item type code

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 5 Lari Taskula 2022-02-11 13:20:08 UTC
That has to be the quickest sign-off I've seen in all these years :D
Comment 6 Katrin Fischer 2022-02-13 14:20:25 UTC
Created attachment 130539 [details] [review]
Bug 30081: Add item type column to holds table

Add new column item type to holds table in patron's details and check
out views. Some libraries will find this information useful for
distinguishing inter library holds from normal holds.

To test:
1. Apply patch
2. Place a hold and confirm it
3. Go to cgi-bin/koha/circ/circulation.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
4. Click "1 Hold(s)" tab
5. Observe new column "Item type"
6. Confirm the item type is correct
7. Go to moremember.pl?borrowernumber=1 with
   borrowernumber being the id of your patron
8. Repeat steps 4-6

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 7 Katrin Fischer 2022-02-13 14:20:28 UTC
Created attachment 130540 [details] [review]
Bug 30081: Use itemtype description instead of itemtype code

To test:
1. Use same plan as previous patch, but observe full item type description
   instead of item type code

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Katrin Fischer 2022-02-13 14:21:03 UTC
(In reply to Lari Taskula from comment #5)
> That has to be the quickest sign-off I've seen in all these years :D

Maybe fastest QA too? The wonder of small changes :)
Comment 9 Katrin Fischer 2022-02-13 14:36:38 UTC
*** Bug 29982 has been marked as a duplicate of this bug. ***
Comment 10 Fridolin Somers 2022-02-16 21:30:24 UTC
(In reply to Katrin Fischer from comment #8)
> (In reply to Lari Taskula from comment #5)
> > That has to be the quickest sign-off I've seen in all these years :D
> 
> Maybe fastest QA too? The wonder of small changes :)

Go for fastest master push ;)
Comment 11 Fridolin Somers 2022-02-16 21:52:39 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄
Comment 12 Fridolin Somers 2022-02-17 07:24:24 UTC
We really should add columns settings in this table.
Comment 13 Katrin Fischer 2022-02-19 13:25:39 UTC
(In reply to Fridolin Somers from comment #12)
> We really should add columns settings in this table.

I filed it: Bug 30138 - Add table configuration to holds table in patron account in staff