Bug 30237 - Rename/rephrase AutoEmailOpacUser/ACCTDETAILS feature to clarify intended use
Summary: Rename/rephrase AutoEmailOpacUser/ACCTDETAILS feature to clarify intended use
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Martin Renvoize
QA Contact: Marcel de Rooy
URL:
Keywords:
: 30442 (view as bug list)
Depends on: 30214 29005
Blocks: 30646 9097
  Show dependency treegraph
 
Reported: 2022-03-06 12:35 UTC by Katrin Fischer
Modified: 2022-09-23 19:43 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Documentation contact: Caroline Cyr La Rose
Documentation submission: https://gitlab.com/koha-community/koha-manual/-/merge_requests/589
Text to go in the release notes:
With the removal of patron plaintext passwords from the ACCTDETAILS notice in bug 27812 the feature effectively got repurposed to become a 'Welcome email'. This enhancement rephrases the system preference description and replaces the ACCTDETAILS notice with a new WELCOME notice. We keep the ACCTDETAILS notice for reference at upgrades, but it will not appear for new installations and it is not longer sent in any circumstances.
Version(s) released in:
22.05.00


Attachments
Bug 30237: Replace ACCDETAILS notice with WELCOME notice (4.09 KB, patch)
2022-03-08 16:16 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Reference new WELCOME notice (4.80 KB, patch)
2022-03-08 16:16 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser (9.13 KB, patch)
2022-03-08 16:16 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Replace ACCDETAILS notice with WELCOME notice (4.15 KB, patch)
2022-03-31 14:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 30237: Reference new WELCOME notice (4.85 KB, patch)
2022-03-31 14:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser (9.18 KB, patch)
2022-03-31 14:57 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 30237: Replace ACCDETAILS notice with WELCOME notice (4.15 KB, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Reference new WELCOME notice (4.85 KB, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser (9.33 KB, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: (follow-up) Update Notice (3.31 KB, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: (follow-up) Add french sample notice (3.51 KB, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Add a note about WELCOME notice to system preference (981 bytes, patch)
2022-04-11 14:02 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: (follow-up) Make LibraryName conditional (3.63 KB, patch)
2022-04-11 14:14 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 30237: Replace ACCDETAILS notice with WELCOME notice (4.24 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: Reference new WELCOME notice (4.95 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser (9.42 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: (follow-up) Update Notice (3.41 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: (follow-up) Add french sample notice (3.60 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: Add a note about WELCOME notice to system preference (1.05 KB, patch)
2022-04-15 09:30 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: (follow-up) Make LibraryName conditional (3.73 KB, patch)
2022-04-15 09:31 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30237: (QA follow-up) Spelling (1.33 KB, patch)
2022-04-15 09:31 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2022-03-06 12:35:53 UTC
With the changes from bugs 27812, bug 29005, and bug 30214 we will have a much cleaner and secure feature than before that will work in a much more predictable way. So I think this would then be a good moment to add documentation to the pref:

IS:
AutoEmailOpacUser
[Send|Don't send] an email to newly created patrons with their account details. 

COULD BE:
AutoEmailNewUser (switch Opac with New)

[Send|Don't send] an email to newly created patrons, including verified self registrations.
Comment 1 Martin Renvoize 2022-03-08 13:32:43 UTC
I'd also take the opportunity to replace the ACCDETAILS notice with a new reworded default called 'WELCOME' or something along those lines
Comment 2 Martin Renvoize 2022-03-08 16:16:43 UTC
Created attachment 131489 [details] [review]
Bug 30237: Replace ACCDETAILS notice with WELCOME notice

This patch drops the ACCDETAILS notice in preference to a new WELCOME
notice.
Comment 3 Martin Renvoize 2022-03-08 16:16:46 UTC
Created attachment 131490 [details] [review]
Bug 30237: Reference new WELCOME notice

This patch updates all references to the former ACCTDETAILS notice to
use the new WELCOME email notice instead.
Comment 4 Martin Renvoize 2022-03-08 16:16:50 UTC
Created attachment 131491 [details] [review]
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser
Comment 5 Kyle M Hall 2022-03-31 14:57:01 UTC
Created attachment 132785 [details] [review]
Bug 30237: Replace ACCDETAILS notice with WELCOME notice

This patch drops the ACCDETAILS notice in preference to a new WELCOME
notice.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 6 Kyle M Hall 2022-03-31 14:57:17 UTC
Created attachment 132786 [details] [review]
Bug 30237: Reference new WELCOME notice

This patch updates all references to the former ACCTDETAILS notice to
use the new WELCOME email notice instead.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 7 Kyle M Hall 2022-03-31 14:57:22 UTC
Created attachment 132787 [details] [review]
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 8 Kyle M Hall 2022-03-31 14:58:56 UTC
Should there be a db update to rename the syspref AutoEmailOpacUser to AutoEmailNewUser?
Comment 9 Katrin Fischer 2022-03-31 20:39:53 UTC
(In reply to Kyle M Hall from comment #8)
> Should there be a db update to rename the syspref AutoEmailOpacUser to
> AutoEmailNewUser?

Definitely!

It looks like it's in the second patch:

+
+        # Update system preference
+        $dbh->do( q{
+            UPDATE systempreferences SET variable = 'AutoEmailNewUser', explanation = 'Send an email to newly created patrons.' WHERE variable = 'AutoEmailOpacUser'
+        });
     },
 };
Comment 10 Katrin Fischer 2022-04-03 10:10:58 UTC
*** Bug 30442 has been marked as a duplicate of this bug. ***
Comment 11 Katrin Fischer 2022-04-03 10:23:34 UTC
Hi all,

almost there!

1) This includes a database update to insert a new letter. I am not sure about this approach. I think it would be better if we changed the letter code on the existing ACCTDETAILS instead, because it will cause less surprising behaviour. The existing notice will kept to be sent for libraries using the feature instead of it suddently changing text and turning English. (blocker)

2) We could add a note to the system preference about the letter code, so people will be able to see the change a little better. (suggestion)

3) QA test tools:

 FAIL	installer/data/mysql/atomicupdate/bug_30237.pl
   FAIL	  file permissions
		File must have the exec flag

4) New letter

Thank you for doing this, I already had filed a separate bug before stumbling onto this here! Some small stuff and hopefully good suggestions:

a) Tiny typo: Thank you

+            - "Thankyou for joining [% Koha.Preference('LibraryName') %]"

b) Linking 'here'

Never link "here", it's a known accessibility issue with screen readers, but also because we are all used to scan for links now and it doesn't give an useful clue on where it leads.

"The library's catalog can be found <a href='[% Koha.Preference('OPACBaseURL') %]'>here</a>."

Better to say something like:
You can search for all our materials in our <a href='[% Koha.Preference('OPACBaseURL') %]'>catalog</a>."

And patron's won't know that this is Koha or who the administrator is, better to ask them to get in touch with the library staff :)

If you have any problems or questions regarding your account, please contact your Koha Administrator.

Better:
If you have any problems or questions regarding your account, please contact your library.
 
5) French installer

As we don't know yet if the French installer will be gone in time for release, we should update the installer with the new notice:

installer/data/mysql/fr-FR/1-Obligatoire/sample_notices.sql
Comment 12 Katrin Fischer 2022-04-03 10:52:27 UTC
6) While testing bug 9097 I noticed that the branch name is not resolved in the subject line:

Welcome to 

We might want to remove the name there for now and fix the subject replacement for TT on a separate bug?
Comment 13 Martin Renvoize 2022-04-11 14:02:33 UTC
Created attachment 133153 [details] [review]
Bug 30237: Replace ACCDETAILS notice with WELCOME notice

This patch drops the ACCDETAILS notice in preference to a new WELCOME
notice.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 14 Martin Renvoize 2022-04-11 14:02:37 UTC
Created attachment 133154 [details] [review]
Bug 30237: Reference new WELCOME notice

This patch updates all references to the former ACCTDETAILS notice to
use the new WELCOME email notice instead.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 15 Martin Renvoize 2022-04-11 14:02:41 UTC
Created attachment 133155 [details] [review]
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser

This patch replaces the AutoEmailOpacUser system preference with a new
AutoEmailNewUser preference. This makes the functionof the preference
clearer.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>
Comment 16 Martin Renvoize 2022-04-11 14:02:45 UTC
Created attachment 133156 [details] [review]
Bug 30237: (follow-up) Update Notice

This patch updates the sample notice as suggested by Katrin.
Comment 17 Martin Renvoize 2022-04-11 14:02:49 UTC
Created attachment 133157 [details] [review]
Bug 30237: (follow-up) Add french sample notice
Comment 18 Martin Renvoize 2022-04-11 14:02:53 UTC
Created attachment 133158 [details] [review]
Bug 30237: Add a note about WELCOME notice to system preference
Comment 19 Martin Renvoize 2022-04-11 14:05:44 UTC
(In reply to Katrin Fischer from comment #11)
> Hi all,
> 
> almost there!
> 
> 1) This includes a database update to insert a new letter. I am not sure
> about this approach. I think it would be better if we changed the letter
> code on the existing ACCTDETAILS instead, because it will cause less
> surprising behaviour. The existing notice will kept to be sent for libraries
> using the feature instead of it suddenly changing text and turning English.
> (blocker)

This was actually a deliberate choice. The notice text is all changed, as you see below. By leaving the old notice there but no longer referencing it I felt users could use it as a reference when updating the new notice.  With the password functionality having already been removed it makes a lot of sense to require users update this notice to reflect it's clarified use.  I was intending to add such a comment in the release notes too.

> 
> 2) We could add a note to the system preference about the letter code, so
> people will be able to see the change a little better. (suggestion)

Done in last follow-up.

> 3) QA test tools:
> 
>  FAIL	installer/data/mysql/atomicupdate/bug_30237.pl
>    FAIL	  file permissions
> 		File must have the exec flag

Done
 
> 4) New letter
> 
> Thank you for doing this, I already had filed a separate bug before
> stumbling onto this here! Some small stuff and hopefully good suggestions:
> 
> a) Tiny typo: Thank you
> 
> +            - "Thankyou for joining [% Koha.Preference('LibraryName') %]"
> 
> b) Linking 'here'
> 
> Never link "here", it's a known accessibility issue with screen readers, but
> also because we are all used to scan for links now and it doesn't give an
> useful clue on where it leads.
> 
> "The library's catalog can be found <a href='[%
> Koha.Preference('OPACBaseURL') %]'>here</a>."
> 
> Better to say something like:
> You can search for all our materials in our <a href='[%
> Koha.Preference('OPACBaseURL') %]'>catalog</a>."
> 
> And patron's won't know that this is Koha or who the administrator is,
> better to ask them to get in touch with the library staff :)
> 
> If you have any problems or questions regarding your account, please contact
> your Koha Administrator.
> 
> Better:
> If you have any problems or questions regarding your account, please contact
> your library.

Done
  
> 5) French installer
> 
> As we don't know yet if the French installer will be gone in time for
> release, we should update the installer with the new notice:
> 
> installer/data/mysql/fr-FR/1-Obligatoire/sample_notices.sql

Done
Comment 20 Martin Renvoize 2022-04-11 14:09:45 UTC
(In reply to Katrin Fischer from comment #12)
> 6) While testing bug 9097 I noticed that the branch name is not resolved in
> the subject line:
> 
> Welcome to 
> 
> We might want to remove the name there for now and fix the subject
> replacement for TT on a separate bug?

This actually works for me.. are you sure you have the relevant syspref set?

I did wonder where we should check the pref is filled.. would you like me to add that follow-up too?
Comment 21 Martin Renvoize 2022-04-11 14:14:46 UTC
Created attachment 133159 [details] [review]
Bug 30237: (follow-up) Make LibraryName conditional

It's easy to forget to set the LibraryName preference.. as such we can
make this a conditional and fall back to a default of 'the library'.
Comment 22 Katrin Fischer 2022-04-11 21:38:54 UTC
(In reply to Martin Renvoize from comment #21)
> Created attachment 133159 [details] [review] [review]
> Bug 30237: (follow-up) Make LibraryName conditional
> 
> It's easy to forget to set the LibraryName preference.. as such we can
> make this a conditional and fall back to a default of 'the library'.

Ah, I expected the name of the branch, should have read the notice template more carefully. It certainly was the missing pref then.
Comment 23 Marcel de Rooy 2022-04-15 09:30:35 UTC
Created attachment 133345 [details] [review]
Bug 30237: Replace ACCDETAILS notice with WELCOME notice

This patch drops the ACCDETAILS notice in preference to a new WELCOME
notice.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 24 Marcel de Rooy 2022-04-15 09:30:40 UTC
Created attachment 133346 [details] [review]
Bug 30237: Reference new WELCOME notice

This patch updates all references to the former ACCTDETAILS notice to
use the new WELCOME email notice instead.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 25 Marcel de Rooy 2022-04-15 09:30:44 UTC
Created attachment 133347 [details] [review]
Bug 30237: Replace AutoEmailOpacUser with AutoEmailNewUser

This patch replaces the AutoEmailOpacUser system preference with a new
AutoEmailNewUser preference. This makes the functionof the preference
clearer.

Signed-off-by: Kyle M Hall <kyle@bywatersolutions.com>

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 26 Marcel de Rooy 2022-04-15 09:30:48 UTC
Created attachment 133348 [details] [review]
Bug 30237: (follow-up) Update Notice

This patch updates the sample notice as suggested by Katrin.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 27 Marcel de Rooy 2022-04-15 09:30:52 UTC
Created attachment 133349 [details] [review]
Bug 30237: (follow-up) Add french sample notice

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 28 Marcel de Rooy 2022-04-15 09:30:57 UTC
Created attachment 133350 [details] [review]
Bug 30237: Add a note about WELCOME notice to system preference

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 29 Marcel de Rooy 2022-04-15 09:31:02 UTC
Created attachment 133351 [details] [review]
Bug 30237: (follow-up) Make LibraryName conditional

It's easy to forget to set the LibraryName preference.. as such we can
make this a conditional and fall back to a default of 'the library'.

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 30 Marcel de Rooy 2022-04-15 09:31:07 UTC
Created attachment 133352 [details] [review]
Bug 30237: (QA follow-up) Spelling

Thankyou => Thank you
No thanks ;)

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 31 Fridolin Somers 2022-04-20 19:04:53 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄