Bug 30446 - Add a test for GetTagsLabels
Summary: Add a test for GetTagsLabels
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Test Suite (show other bugs)
Version: unspecified
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Marcel de Rooy
QA Contact: Tomás Cohen Arazi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-04 11:46 UTC by Marcel de Rooy
Modified: 2022-04-29 17:33 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
22.05.00


Attachments
Bug 30446: Add a test for GetTagsLabels (3.07 KB, patch)
2022-04-04 11:54 UTC, Marcel de Rooy
Details | Diff | Splinter Review
Bug 30446: Add a test for GetTagsLabels (3.11 KB, patch)
2022-04-20 12:19 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 30446: (follow-up) Remove warning (1.01 KB, patch)
2022-04-20 12:19 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Marcel de Rooy 2022-04-04 11:46:26 UTC
Just a remainder from an experiment on bug 2222.
Comment 1 Marcel de Rooy 2022-04-04 11:54:10 UTC
Created attachment 132932 [details] [review]
Bug 30446: Add a test for GetTagsLabels

Moved from obsoleted bug 2222 on its own.

Test plan:
Run t/db_dependent/Authority/GetTagsLabels.t

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 2 Marcel de Rooy 2022-04-04 11:54:39 UTC
Adding self SO: only simple unit test.
Comment 3 Jonathan Druart 2022-04-06 14:32:04 UTC
Why not a subtest of t/db_dependent/AuthoritiesMarc.t?
Comment 4 Marcel de Rooy 2022-04-06 14:40:41 UTC
(In reply to Jonathan Druart from comment #3)
> Why not a subtest of t/db_dependent/AuthoritiesMarc.t?

Arbitrary choice. There are more subtests in this subdirectory. At some point it is easier to have separate files than one big one. Although that one is still small.
Comment 5 Tomás Cohen Arazi 2022-04-20 12:19:45 UTC
Created attachment 133460 [details] [review]
Bug 30446: Add a test for GetTagsLabels

Moved from obsoleted bug 2222 on its own.

Test plan:
Run t/db_dependent/AuthoritiesMarc_GetTagsLabels.t

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 6 Tomás Cohen Arazi 2022-04-20 12:19:51 UTC
Created attachment 133461 [details] [review]
Bug 30446: (follow-up) Remove warning

This patch removes a trivial warning caused by a parameter being
compared to a literal but not being defined. Doing a

$ git grep GetTagsLabels

shows the change is safe as the function is always called with a value
of either 0 or 1.

Signed-off-by: Tomas Cohen Arazi <tomascohen@theke.io>
Comment 7 Marcel de Rooy 2022-04-20 12:26:04 UTC
(In reply to Tomás Cohen Arazi from comment #6)

Thx
Comment 8 Fridolin Somers 2022-04-22 18:52:51 UTC
Pushed to master for 22.05, thanks to everybody involved 🦄