Bug 32603 - Suggester category in Suggestions management
Summary: Suggester category in Suggestions management
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: Main
Hardware: All All
: P5 - low trivial (vote)
Assignee: Frédéric Demians
QA Contact: Martin Renvoize
URL:
Keywords:
: 21700 32774 (view as bug list)
Depends on:
Blocks: 31127 34917
  Show dependency treegraph
 
Reported: 2023-01-10 08:31 UTC by Frédéric Demians
Modified: 2024-07-04 20:37 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:
23.05.00,22.11.03


Attachments
Bug 32603: Suggester category in Suggestions management (3.02 KB, patch)
2023-01-26 08:48 UTC, Frédéric Demians
Details | Diff | Splinter Review
Bug 32603: Suggester category in Suggestions management (3.08 KB, patch)
2023-01-27 13:59 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 32603: Suggester category in Suggestions management (3.15 KB, patch)
2023-02-07 13:27 UTC, Martin Renvoize
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Demians 2023-01-10 08:31:30 UTC
In Suggestions management, it would be intersting to know the suggester
category. This way, it would be possible for example for the librarian
managing suggestions rather to prioritize suggestions coming from
teachers than those coming from students.
Comment 1 Frédéric Demians 2023-01-26 08:48:17 UTC Comment hidden (obsolete)
Comment 2 Owen Leonard 2023-01-27 13:59:18 UTC
Created attachment 145746 [details] [review]
Bug 32603: Suggester category in Suggestions management

In Suggestions management, in the table displaying all suggestions, add
a column to display suggester category. This way, it is possible for
example for the librarian managing suggestions rather to prioritize
suggestions coming from teachers than those coming from students.

TEST :

1. Apply the patch.
2. Acquisition > Suggestions.
3. There is a new column 'Suggester category'. It can be
   displayed/hidden.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Comment 3 Owen Leonard 2023-01-27 13:59:57 UTC
I took the liberty of adding a missing "| html" filter during signoff.
Comment 4 Frédéric Demians 2023-01-27 14:22:13 UTC
The Owen for signing-off, and for your liberty.
Comment 5 Martin Renvoize 2023-02-07 13:27:24 UTC
Created attachment 146328 [details] [review]
Bug 32603: Suggester category in Suggestions management

In Suggestions management, in the table displaying all suggestions, add
a column to display suggester category. This way, it is possible for
example for the librarian managing suggestions rather to prioritize
suggestions coming from teachers than those coming from students.

TEST :

1. Apply the patch.
2. Acquisition > Suggestions.
3. There is a new column 'Suggester category'. It can be
   displayed/hidden.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 6 Martin Renvoize 2023-02-07 13:27:43 UTC
Working nicely, Passing QA
Comment 7 Tomás Cohen Arazi 2023-02-07 18:26:08 UTC
Happy to push a patch from you again, Frederic :-D
Comment 8 Tomás Cohen Arazi 2023-02-07 18:29:33 UTC
Pushed to master for 23.05.

Nice work everyone, thanks!
Comment 9 Lucas Gass 2023-02-07 18:50:54 UTC
*** Bug 32774 has been marked as a duplicate of this bug. ***
Comment 10 Jacob O'Mara 2023-02-08 16:53:20 UTC
Nice work, thanks everyone!

Pushed to 22.11.x for the next release.
Comment 11 Lucas Gass 2023-02-15 21:39:44 UTC
Enhancement will no be backported to 22.05.x.
Comment 12 Emily Lamancusa 2023-03-21 19:01:34 UTC
*** Bug 21700 has been marked as a duplicate of this bug. ***