Bug 3523 - Menu of existing lists limited to 10
Summary: Menu of existing lists limited to 10
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
: 5491 5554 5994 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-08-11 04:33 UTC by Sharon Moreland
Modified: 2012-10-25 23:04 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Add to List dropdown menu missing scrollbar (71.40 KB, image/png)
2009-08-11 16:33 UTC, Chris Cormack
Details
opac-search.pl Add To only shows 10 lists (127.38 KB, image/png)
2009-08-11 16:41 UTC, Chris Cormack
Details
Screenshot of proposed page display (19.59 KB, image/png)
2010-12-20 15:47 UTC, Owen Leonard
Details
Screenshot of proposed page display, list add popup (9.74 KB, image/png)
2010-12-20 16:01 UTC, Owen Leonard
Details
Proposed fix (10.00 KB, patch)
2011-03-30 12:56 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:11:43 UTC


---- Reported by smoreland@nekls.org 2009-08-11 16:33:45 ----

Created an attachment
Add to List dropdown menu missing scrollbar

Scenario:
A patron has logged into the OPAC.  They have searched for an item and want to add it to an existing list.  The opac-addbybiblionumber.pl form pops up and the patron opens the 'Add to List: dropdown menu.'  The selection shown is ONLY the 10 most recently added lists.  This should show ALL lists owned by the patron, with a scroll-bar for navigation, and it should appear in alphabetical order.

This appears the same in these browsers:

Firefox 3.0.13
IE 8



---- Additional Comments From smoreland@nekls.org 2009-08-11 16:41:21 ----

Created an attachment
opac-search.pl Add To only shows 10 lists

Another instance of this problem in the OPAC



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:11 UTC  ---

This bug was previously known as _bug_ 3523 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=3523
Imported an attachment (id=1383)
Imported an attachment (id=1384)

Actual time not defined. Setting to 0.0
The original submitter of attachment 1383 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.
The original submitter of attachment 1384 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-08-19 13:54:09 UTC
> The opac-addbybiblionumber.pl form pops up and the
> patron opens the 'Add to List: dropdown menu.'  The selection shown is ONLY the
> 10 most recently added lists.

In addition, the display on opac-addbybiblionumber.pl doesn't indicate which lists are public and which are private as the menu on opac-search.pl does. So it looks like it's showing you more than ten items, but really it's showing only up to ten for each shelf type (private, public, open).

The 10 item limit is hard-coded in the script. I'm assuming the motivation is to avoid showing a menu which has an unmanageable number of items in it. But that leaves us with the question of how else can we give patrons access to these lists?

If we decide the solution is to show *all* available lists on opac-addbybiblionumber.pl, I recommend we leave the menu on opac-search.pl the same (limited to 10 of each type) with one modification: an additional option of "more lists" so that the user has a hint that more are available. Choosing that option would open the opac-addbybiblionumber.pl popup offering the full list of options.

And: +1 on alphabetizing the lists.
Comment 2 Chris Nighswonger 2010-08-19 14:05:48 UTC
(In reply to comment #1)
> > The opac-addbybiblionumber.pl form pops up and the
> > patron opens the 'Add to List: dropdown menu.'  The selection shown is ONLY the
> > 10 most recently added lists.
> 

<snip>

> The 10 item limit is hard-coded in the script. I'm assuming the motivation is
> to avoid showing a menu which has an unmanageable number of items in it. But
> that leaves us with the question of how else can we give patrons access to
> these lists?
> 
> If we decide the solution is to show *all* available lists on
> opac-addbybiblionumber.pl, I recommend we leave the menu on opac-search.pl the
> same (limited to 10 of each type) with one modification: an additional option
> of "more lists" so that the user has a hint that more are available. Choosing
> that option would open the opac-addbybiblionumber.pl popup offering the full
> list of options.

The fear of an unmanageable number of lists was exactly the motivation for enforcing a limit.

Perhaps there may be some way of producing a list which displays 10 lists, but has scroll buttons to scroll up and down the entire list of lists?

The hard-coded limit could be moved to (yet) another syspref.... <duck>
Comment 3 Nicole C. Engard 2010-12-14 14:33:52 UTC
*** Bug 5491 has been marked as a duplicate of this bug. ***
Comment 4 Nicole C. Engard 2010-12-14 14:36:14 UTC
I recommend either a 'more' link or a scrolling pull down list that shows all lists the library offers.

This makes it hard to add items to lists from the staff client search results
for libraries with more than 10 lists available. to choose from - instead they
have to go to the lists module and page through the list of lists and add items
by barcode instead.
Comment 5 Owen Leonard 2010-12-14 21:03:42 UTC
I'm going to take a stab at this:

- adding "more" option to the search results dropdown
- offering a scrolling list on the add-to-list popup
Comment 6 Owen Leonard 2010-12-20 15:47:02 UTC
Created attachment 2893 [details]
Screenshot of proposed page display

In this screenshot you can see the addition of a "More lists" option under the "Your lists" group. Clicking "more lists" pops up the lists popup without any list preselected.
Comment 7 Owen Leonard 2010-12-20 16:01:31 UTC
Created attachment 2894 [details]
Screenshot of proposed page display, list add popup

This screenshot shows that the lists add popup would show the full list of all the patron's lists, divided into groups of private and public lists.
Comment 8 Nicole C. Engard 2010-12-22 21:49:32 UTC
So does this mean if you need to add a batch of items to the 15th list you choose [more lists] from the pull down and then on the pop up you choose the list and that batch is added? If so - that works A-OK!!
Comment 9 Owen Leonard 2010-12-29 20:12:11 UTC
*** Bug 5554 has been marked as a duplicate of this bug. ***
Comment 10 Owen Leonard 2011-03-30 12:56:18 UTC
Created attachment 3523 [details] [review]
Proposed fix
Comment 11 Julian Maurice 2011-03-30 13:38:01 UTC
It works well. Signed off.
Comment 12 Chris Cormack 2011-03-31 08:11:37 UTC
Pushed, please test
Comment 13 MJ Ray (software.coop) 2011-04-01 09:43:27 UTC
This bug is mentioned in:
Fix for Bug 3523 - Menu of existing lists	limited to 10 http://lists.koha-community.org/pipermail/koha-patches/2011-March/014350.html
Fix for Bug 3523 - Menu of	existing lists limited to 10 http://lists.koha-community.org/pipermail/koha-patches/2011-March/014353.html
Comment 14 Nicole C. Engard 2011-04-19 15:07:08 UTC
*** Bug 5994 has been marked as a duplicate of this bug. ***