Bug 4241 - Add lost/claims returned displays to patron record
Summary: Add lost/claims returned displays to patron record
Status: RESOLVED DUPLICATE of bug 14697
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Jane Wagner
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-22 08:12 UTC by Jane Wagner
Modified: 2016-06-19 22:13 UTC (History)
3 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
screen shot with claims returned examples (6.35 KB, image/jpeg)
2010-02-22 20:12 UTC, Chris Cormack
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:24:49 UTC


---- Reported by jwagner@ptfs.com 2010-02-22 20:12:17 ----

Created an attachment
screen shot with claims returned examples

Sponsored by Middletown Township Public Library, Middletown, NJ, USA.

Marking an item lost removes it from the patron checkout list.  The library wanted to be able to retain a list of lost (and claims returned -- see http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4246) items with the amount charged on the patron record.  This feature adds a list of barcodes and the replacement cost on the patron Details tab.



---- Additional Comments From jwagner@ptfs.com 2010-05-12 13:56:59 ----

The fix for this bug (in ptfs-harley) can be pulled from the public git repository at http://github.com/Koha-PTFS, branch http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4241




--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:24 UTC  ---

This bug was previously known as _bug_ 4241 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4241
Imported an attachment (id=1930)

Unknown operating system Windows 2000. Setting to default OS "All".
Actual time not defined. Setting to 0.0
The original reporter of this bug does not have
   an account here. Reassigning to the person who moved
   it here: chris@bigballofwax.co.nz.
   Previous reporter was jwagner@ptfs.com.
The original assignee of this bug does not have
   an account here. Reassigning to the default assignee
   for the component, gmcharlt@gmail.com.
   Previous assignee was kohaprogrammers@ptfs.com.
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.
Bug reassigned, setting status to "NEW".
   Previous status was "ASSIGNED".
CC member jwagner@ptfs.com does not have an account here
The original submitter of attachment 1930 [details] is unknown.
   Reassigning to the person who moved it here: chris@bigballofwax.co.nz.

Comment 1 Owen Leonard 2010-12-28 17:48:42 UTC
I've cherry-picked these changes into a branch, ip-bug-4241-lost-tab-2010-12-28, in my development repo at http://gitorious.org/koha-dev/koha-dev.

I made one change from the way it is in Harley: I put the display of lost items into a tab on the patron detail page alongside checkouts, fines, and holds. The new functionality seems to be working in that:

- marking something lost adds a fine to patron's record
- marking something lost does or does not check in the item following the 
  MarkLostItemsReturned system preference.

A couple of bugs/to-dos I see:

- The template has markup intended to handle deleted items when displaying the list of lost items. From this I assume it is supposed to show "deleted item" in the list if the lost item is deleted." However, when I delete one of the lost items it disappears from the list.

- There seems to have been no code added to Harley to properly handle the addition of the MarkLostItemsReturned preference to the database or the incrementation of the version number.
Comment 2 Jared Camins-Esakov 2013-01-02 01:40:34 UTC
These patches are no longer available anywhere. Resetting to ASSIGNED.
Comment 3 Katrin Fischer 2016-06-19 22:13:32 UTC
Opting for the new bug in this case, as it's active and has more CC entries.

*** This bug has been marked as a duplicate of bug 14697 ***