Bug 4313 - Language selected in staff client affects value of boolean sysprefs
Summary: Language selected in staff client affects value of boolean sysprefs
Status: CLOSED DUPLICATE of bug 4465
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-09 08:33 UTC by Magnus Enger
Modified: 2012-10-26 00:41 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:25:41 UTC


---- Reported by magnus@enger.priv.no 2010-03-09 20:33:44 ----

When I have selected English as the language in the staff client i get this HTML in the syspref-editor: 

<select name="pref_NoZebra" id="pref_NoZebra" class="preference preference-choice">
<option value="1">Don't use</option>
<option value="">Use</option>
</select>
the Zebra search engine...

When I switch to Norwegian i get this: 

<select name="pref_NoZebra" id="pref_NoZebra" class="preference preference-choice">
<option value="yes">Don't use</option>
<option value="no" selected="selected">Use</option>
</select>
the Zebra search engine...

And the value that is actually stored in the DB is a "yes" or a "no", not a numeric value.



---- Additional Comments From frederic@tamil.fr 2010-03-10 06:11:23 ----

I think it's solved by this patch:
 
http://lists.koha.org/pipermail/koha-patches/2010-March/005752.html



---- Additional Comments From magnus@enger.priv.no 2010-03-15 09:42:59 ----

Yes, that patch solves the problem. 



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:25 UTC  ---

This bug was previously known as _bug_ 4313 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4313

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Chris Cormack 2010-12-14 03:05:12 UTC
Am I solved, or am I not .. you be the judge.
Comment 2 Magnus Enger 2010-12-14 16:18:10 UTC
Yes, it would seem I'm solved - by the patch for bug 4465: http://lists.koha.org/pipermail/koha-patches/2010-May/006173.html

*** This bug has been marked as a duplicate of bug 4465 ***