Bug 4465 - Translated boolean syspref are inverted
Summary: Translated boolean syspref are inverted
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: translate.koha-community.org (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
: 4313 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-05-07 05:30 UTC by Frédéric Demians
Modified: 2012-10-25 22:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:27:30 UTC


---- Reported by frederic@tamil.fr 2010-05-07 05:30:54 ----

For example, for NoZebra syspref in French 'no' means 'yes' and 'yes'
mean 'no'. It applies to all boolean sysprefs.

The bugs comes from a tricky issue with how YAML parser interprets
yes/no value in hash's keys. Those values are surrounded automatically
with double quotes which causes translated syspref installation to fail.

A first proposed patch add a new and otherwise unnecessary dependency (YAML::XS):

http://lists.koha.org/pipermail/koha-patches/2010-March/005752.html



---- Additional Comments From frederic@tamil.fr 2010-05-07 05:39:18 ----

http://lists.koha.org/pipermail/koha-patches/2010-May/006173.html



---- Additional Comments From gmcharlt@gmail.com 2010-05-07 14:39:38 ----

Patch pushed.  Please test and close.



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:27 UTC  ---

This bug was previously known as _bug_ 4465 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4465

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Magnus Enger 2010-12-14 16:18:10 UTC
*** Bug 4313 has been marked as a duplicate of this bug. ***