Bug 4374 - Data entry form doesn't use hidden/mandatory flag as expected
Summary: Data entry form doesn't use hidden/mandatory flag as expected
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-04-07 05:25 UTC by Frédéric Demians
Modified: 2012-10-25 23:03 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (2.39 KB, patch)
2011-03-14 05:47 UTC, Frédéric Demians
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2010-05-21 01:26:25 UTC


---- Reported by frederic@tamil.fr 2010-04-07 05:25:19 ----

Biblio framework has 3 entry points controlling if input box are displayed by
default in data entry form:

  - 'mandatory' flag at field level
  - 'mandatory' flag at subfield level
  - 'hidden' flag at subfield level

It doesn't work as it should (?):

  - All subfields are expanded (shown) if their field is mandatory
  - A subfield containing anything is always expanded whatever it contains
  - A mandatory subfield is always expanded
  - An hidden subfield isn't expanded.

It's possible to have this. See coming patch. But default framework having 0 in
all marc_subfield_structure.hidde, by default all subfields will be expanded.



---- Additional Comments From frederic@tamil.fr 2010-04-07 05:47:06 ----

http://lists.koha.org/pipermail/koha-patches/2010-April/005984.html



--- Bug imported by chris@bigballofwax.co.nz 2010-05-21 01:26 UTC  ---

This bug was previously known as _bug_ 4374 at http://bugs.koha.org/cgi-bin/bugzilla3/show_bug.cgi?id=4374

Actual time not defined. Setting to 0.0
Setting qa contact to the default for this product.
   This bug either had no qa contact or an invalid one.

Comment 1 Frédéric Demians 2010-06-04 17:13:17 UTC
Link update:

http://lists.koha-community.org/pipermail/koha-patches/2010-April/011581.html

For RM: I can show you how it works.
Comment 2 Frédéric Demians 2010-12-14 07:14:28 UTC
Patch new version applied on HEAD:

http://lists.koha-community.org/pipermail/koha-patches/2010-December/013263.html
Comment 3 Katrin Fischer 2011-03-14 05:33:27 UTC
Hi Frederic, can you please attach your patch to the bug for testing?
Comment 4 Frédéric Demians 2011-03-14 05:47:55 UTC
Created attachment 3290 [details] [review]
Proposed patch
Comment 5 MJ Ray (software.coop) 2011-04-01 09:42:54 UTC
This bug is mentioned in:
Bug 4374 Improve biblio data entry form	regarding hidden/mandatory fields http://lists.koha-community.org/pipermail/koha-patches/2011-March/014039.html
Comment 6 Jonathan Druart 2011-04-05 15:21:46 UTC
Not working for me.
1) I must double clicked for hidden
2) By default, all is shown.
Comment 7 Frédéric Demians 2011-04-05 16:03:28 UTC
> Not working for me.
> 1) I must double clicked for hidden
> 2) By default, all is shown.

How to test in UNIMARC:

- On a UNIMARC Koha, go in Admin > MARC Frameworks > Framework Structure
- Go to 205 field
- Click on Subfields
- For b, d, f, g subfields, clic on Edit
  - Click 'display more constraints'
  - In 'hidden', enter -1.
- Go in Home > Add MARC Record
- Select tab 2
- In 205 field, only 'a' subfield is displayed. All other subfields are
  hidden. Click on 'Mention d'édition' : hidden subfields appear.

The 'hidden' functionnality is very usefull to construct data entry form
displaying first most used subfields. If you want to see more, you click
on field label.
Comment 8 Chris Cormack 2011-04-07 01:25:11 UTC
Pushed, please test
Comment 9 Frédéric Demians 2011-06-27 16:06:59 UTC
Default framework having 0 in all marc_subfield_structure.hidden, by
default all subfields will be expanded.
    
TO BE INTEGRATED IN RELEASE NOTES:
    
  Koha sysadmin should have to edit its frameworks to add hidden=1 in
  appropriate subfields.
Comment 10 Frédéric Demians 2011-06-27 16:08:29 UTC
*** Bug 6439 has been marked as a duplicate of this bug. ***