Bug 4892 - Make the accounts page page, so that the list of records doesn't end up being huge.
Summary: Make the accounts page page, so that the list of records doesn't end up being...
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Keywords:
: 2644 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-15 04:36 UTC by Robin Sheat
Modified: 2015-12-03 22:00 UTC (History)
7 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
proposed patch (4.70 KB, patch)
2010-06-15 04:58 UTC, Robin Sheat
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2010-06-15 04:36:12 UTC
The Patrons > Account for John Smith page has a list of every transaction ever involving that user. This can get pretty big, so this patch makes that list have 'Newer' and 'Older' links to make this less of an issue.
Comment 1 Robin Sheat 2010-06-15 04:58:27 UTC
Created attachment 2247 [details] [review]
proposed patch
Comment 2 Katrin Fischer 2010-06-15 08:53:36 UTC
*** Bug 2644 has been marked as a duplicate of this bug. ***
Comment 3 Owen Leonard 2010-12-14 18:27:01 UTC
Any reason why we shouldn't use the standard pagination_bar() from Output.pm?
Comment 4 Robin Sheat 2010-12-14 23:20:09 UTC
Probably not, I think that I wasn't aware of it when I wrote this.
Comment 5 Nicole C. Engard 2011-03-07 18:30:24 UTC
Does this mean that we're waiting for a new patch? or should I test and sign off on the patch as it stands now?
Comment 6 Nicole C. Engard 2011-04-19 15:11:40 UTC
A new patch is necessary here to edit the *.tt files.
Comment 7 Chris Cormack 2013-01-01 22:52:43 UTC
Still needs a Template Toolkit patch
Comment 8 Katrin Fischer 2015-01-06 17:55:05 UTC
The account tab now is a datatable with paging and filters.