Bug 4912 - After editing private list, user should be redirect to private lists
Summary: After editing private list, user should be redirect to private lists
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Lists (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact: Testopia
URL:
Keywords:
Depends on: 7310
Blocks: 15811
  Show dependency treegraph
 
Reported: 2010-06-25 17:03 UTC by Owen Leonard
Modified: 2017-06-14 22:11 UTC (History)
8 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (4.88 KB, patch)
2010-06-25 19:07 UTC, Owen Leonard
Details | Diff | Splinter Review
Additional fixes (3.07 KB, patch)
2010-11-18 18:04 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 4912 - After editing private list, user should be redirect to private lists (1.22 KB, patch)
2012-02-13 17:21 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 4912 - After editing private list, user should be redirect to private lists (1.25 KB, patch)
2012-02-14 20:17 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 4912 [REVISED] After editing private list, user should be redirect to private lists (5.43 KB, patch)
2012-02-28 15:04 UTC, Owen Leonard
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 4912 [REVISED] After editing private list, user should be redirect to private lists (5.47 KB, patch)
2012-02-28 19:05 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 4912: Redirect to the appropriate view after editing/deleting a list (4.67 KB, patch)
2016-01-06 14:32 UTC, Jonathan Druart
Details | Diff | Splinter Review
Bug 4912: Redirect to the appropriate view after editing/deleting a list (4.85 KB, patch)
2016-01-06 15:11 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 4912: Redirect to the appropriate view after editing/deleting a list (4.91 KB, patch)
2016-01-06 22:19 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-06-25 17:03:18 UTC
After editing a private list, the user is redirected back to the lists page but the tab on display is the one with public lists. The edit process should be made aware of which set of lists the users should be redirected to.
Comment 1 Owen Leonard 2010-06-25 19:07:01 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2010-11-15 02:22:52 UTC
Pushed and merged, please test and close
Comment 3 Chris Nighswonger 2010-11-18 03:15:24 UTC
This bug has a patch presently committed to HEAD and 3.2.x.

Please take the appropriate action to update the status of this bug.

Remember, bugs which have been resolved should be tested and marked closed, preferably by the original reporter.
Comment 4 Owen Leonard 2010-11-18 14:07:46 UTC
This is fixed if your path is:

View private lists -> Click Edit button.

It is still broken if your path is:

Click list to view -> Click Edit button.
Comment 5 Owen Leonard 2010-11-18 18:04:15 UTC Comment hidden (obsolete)
Comment 6 Chris Nighswonger 2010-11-30 13:49:31 UTC
This bug has a fix which was committed to the 3.2.x branch and released in 3.2.1.

Please take time to update the status of this bug and mark it RESOLVED FIXED so that it may be closed.
Comment 7 Chris Cormack 2010-12-01 20:05:53 UTC
A new patch has been sent for this, which is awaiting signoff (sent 18 November 2010)
Comment 8 MJ Ray (software.coop) 2010-12-14 10:22:44 UTC
This bug is mentioned in:
Fix for Bug 4912 - After	editing private list redirect to private lists http://lists.koha-community.org/pipermail/koha-patches/2010-November/012958.html
Follow-up fix for Bug 4912,	redirect user to correct lists http://lists.koha-community.org/pipermail/koha-patches/2010-November/013076.html
Comment 9 Nicole C. Engard 2011-03-01 18:08:55 UTC
Is this still needed, I was going to apply and test for sign off, but I wanted to test the way it used to work first - and it's taking me to the right place.
Comment 10 Owen Leonard 2011-03-03 15:46:45 UTC
(In reply to comment #9)
> Is this still needed

Yes, the additional fix is needed. To reproduce:

1. Click the "my lists" link in the OPAC
2. Click the title of one of your lists to view it.
3. Click the "edit list" link at the top of that view
4. Save your changes.

You will be redirected to the "public lists" view.
Comment 11 Nicole C. Engard 2011-03-04 00:10:03 UTC
Okay the additional fix works - but I got some errors when applying so I'm not sure if I should sign off:


Apply? [y]es/[n]o/[e]dit/[v]iew patch/[a]ccept all y
Applying: Follow-up fix for Bug 4912, redirect user to correct lists
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/opac-tmpl/prog/en/css/opac.css
Auto-merging koha-tmpl/opac-tmpl/prog/en/modules/opac-shelves.tmpl
nengard@debian:~/kohaclone$
Comment 12 Jonathan Druart 2011-04-07 08:07:15 UTC
Additional fixes works for me too.
I got the same warning but git merge success with the other way.
Comment 13 Chris Cormack 2011-04-08 01:03:30 UTC
Pushed, please test
Comment 14 Owen Leonard 2011-08-26 19:35:20 UTC
This seems to be broken again. After editing a list I'm redirected to a page which is blank except for a "new list" button.
Comment 15 Owen Leonard 2011-12-06 17:28:20 UTC
Specifically, broken in the staff client.
Comment 16 Owen Leonard 2012-02-13 17:21:32 UTC Comment hidden (obsolete)
Comment 17 Nicole C. Engard 2012-02-14 20:17:25 UTC Comment hidden (obsolete)
Comment 18 Jonathan Druart 2012-02-16 09:55:16 UTC
QA comment: Is it consistent to redirect to the list's contents and not to the public/private list table ?

If this behavior is intended, the proposed patch works as expected.

Need additionnal QA.
Comment 19 Marcel de Rooy 2012-02-16 10:18:51 UTC
I have a large patch for 7310 coming for lists which certainly will overlap..
Comment 20 Paul Poulain 2012-02-17 17:37:07 UTC
QA comment:
I agree with Jonathan that the proposed behaviour is strange, shouldn't we be redirected to /cgi-bin/koha/virtualshelves/shelves.pl?display=privateshelves ?

It's a 2 lines patches, so the overlapping with bug 7310 should not be a big deal

Marking failed QA, and adding a link to marcel's bug
Comment 21 Owen Leonard 2012-02-28 15:04:28 UTC Comment hidden (obsolete)
Comment 22 Nicole C. Engard 2012-02-28 19:05:03 UTC Comment hidden (obsolete)
Comment 23 Jonathan Druart 2012-03-01 15:01:36 UTC
Marking as Passed QA. This new patch takes in consideration previous remarks
Comment 24 Jared Camins-Esakov 2012-05-23 23:54:27 UTC
I am somewhat confused by this bug. Owen, are the patches from February appropriate for 3.6.x?
Comment 25 Owen Leonard 2012-11-20 19:51:50 UTC
This still doesn't work if you choose to edit a list from the toolbar button.
Comment 26 Marc Véron 2016-01-06 09:48:30 UTC
This is still an issue on current master:

- Log in to OPAC
- Go to 'your Lists'
- Click on "edit" near one of the lists
- Save

Result: The list contents display (you are not taken back to the page where you clicked the "edit" link.).
Comment 27 Jonathan Druart 2016-01-06 14:32:10 UTC Comment hidden (obsolete)
Comment 28 Marc Véron 2016-01-06 15:11:06 UTC Comment hidden (obsolete)
Comment 29 Katrin Fischer 2016-01-06 22:19:11 UTC
Created attachment 46370 [details] [review]
[PASSED QA] Bug 4912: Redirect to the appropriate view after editing/deleting a list

There are 2 places where a list can be edited/deleted: on the list view
and the list content view. After the edition, the user expect to be
redirect to the previous page.
This patch implements that.

Test plan:
At the OPAC, delete and edit a list from the 2 differents places.
Confirm that you are redirect to the page you come from.

With patch, redirects work as expected.
Signed-off-by: Marc Véron <veron@veron.ch>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 30 Brendan Gallagher 2016-01-27 02:42:17 UTC
Pushed to Master - Should be in the May 2016 Release.  Thanks!
Comment 31 Julian Maurice 2016-01-29 12:22:14 UTC
Patch pushed to 3.22.x, will be in 3.22.3