Bug 5013 - "New patron" menu button broken on circulation patron select screen
Summary: "New patron" menu button broken on circulation patron select screen
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: rel_3_2
Hardware: All All
: PATCH-Sent (DO NOT USE) major (vote)
Assignee: Owen Leonard
QA Contact: Bugs List
URL:
Keywords:
: 5188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-15 16:18 UTC by Owen Leonard
Modified: 2012-10-25 22:52 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (1.53 KB, patch)
2010-07-15 16:33 UTC, Owen Leonard
Details | Diff | Splinter Review
Additional change (671 bytes, patch)
2010-07-16 15:43 UTC, Owen Leonard
Details | Diff | Splinter Review
Proposed patch (2.65 KB, patch)
2010-08-10 23:24 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2010-07-15 16:18:55 UTC
If type a patron name into the "check out" form and come to the page where you can choose from a list of existing patrons, there is a "New" menu button which is supposed to offer a drop-down list of patron categories. This button is broken, displaying no menu at all.

The markup for the button comes from patron-toolbar.inc which is also used on members-home.pl. The button on members-home.pl works fine.

In the template is a loop for displaying the categories:

<!--TMPL_LOOP Name="categoryloop"-->
{ text: "<!--TMPL_VAR Name="description"-->",  url: "/cgi-bin/koha/members/memberentry.pl?op=add&amp;categorycode=<!--TMPL_VAR Name="categorycode"-->" },
<!--/TMPL_LOOP-->

members-home.pl contains code to build this loop variable:

my @categories=C4::Category->all;
$template->param(
    branchloop=>(defined $branch?GetBranchesLoop($branch):GetBranchesLoop()),
    categoryloop=>\@categories,
);

There is no mention of "categoryloop" in circulation.pl
Comment 1 Owen Leonard 2010-07-15 16:33:19 UTC
Created attachment 2368 [details] [review]
Proposed fix
Comment 2 Galen Charlton 2010-07-16 02:05:32 UTC
Patch pushed.  Please test and close.
Comment 3 Owen Leonard 2010-07-16 15:43:57 UTC
Created attachment 2382 [details] [review]
Additional change

Menu was working on members-home.pl but not on members.pl
Comment 4 Galen Charlton 2010-07-19 14:36:09 UTC
Pushed follow-up patch.
Comment 5 Katrin Fischer 2010-08-10 23:24:25 UTC
Created attachment 2501 [details] [review]
Proposed patch
Comment 6 Katrin Fischer 2010-08-10 23:25:15 UTC
Comment on attachment 2501 [details] [review]
Proposed patch

The pull down for category in patron's advanced search was only showing any and no patron categories.
Comment 7 Katrin Fischer 2010-08-31 16:35:16 UTC
*** Bug 5188 has been marked as a duplicate of this bug. ***
Comment 8 Frédéric Demians 2010-08-31 17:03:42 UTC
> *** Bug 5188 has been marked as a duplicate of this bug. ***

I agree that your patch should solved bug 5188. I'd have find it if it had been attached to a separate bug... Thanks Katrin.
Comment 9 Katrin Fischer 2010-10-06 22:23:46 UTC
Tested successfully on current head, closing bug. Plz reopen if you still see problems.