Bug 5217 - INSTALL.ubuntu Packages/CPAN notes out of date for Ubuntu 10.04 LTS (Lucid)
Summary: INSTALL.ubuntu Packages/CPAN notes out of date for Ubuntu 10.04 LTS (Lucid)
Status: RESOLVED DUPLICATE of bug 8478
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: master
Hardware: All Linux
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-12 03:30 UTC by Eric Olsen
Modified: 2012-09-18 02:52 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch Files (19.51 KB, patch)
2010-09-12 03:36 UTC, Eric Olsen
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Olsen 2010-09-12 03:30:13 UTC
A number of small issues turned up when installing Koha from trunk on a fresh install of Ubuntu 10.04 LTS (Lucid Lynx).  These include:

1 - install_misc/ubuntu.packages 

    : not all available and needed packages are listed in the file (including
      a number of the CPAN modules listed later for manual install)
    : at least one typo in package name "bmarc-record-perl" (should be
      libmarc-record-perl)
    : due to random order of file, hard to sort out what is there or not
    : some duplicated lines
    : also somewhat difficult to see what has been successfully installed
      as dselect appears to quietly ignore any problems it has with problems
      in this file (such as the "bmarc-" typo)

2 - INSTALL.ubuntu

    : Most of CPAN modules listed for manual install are now available
      as ubuntu packages (except Locale::Currency::Format)
    : Manual CPAN modules needed (but not listed) include:  HTTP::OAI,
      Memoize::Memcached, PDF::API2::Simple Storable Text::CSV::Encoded
    : Install of PDF::API2::Simple has a dependency on Module::Install
      which can be installed as a package (libmodule-install-perl).
    : Entire section on "DBD::mysql Install" (sect 2.4) can be removed
      for Lucid as the needed version (actually later) can be installed as
      a package (libdbd-mysql-perl).
Comment 1 Eric Olsen 2010-09-12 03:36:26 UTC Comment hidden (obsolete)
Comment 2 Eric Olsen 2010-09-12 03:48:42 UTC
What I have done in the three patch files:

(1) Created a separate "INSTALL.ubuntu.lucid" file based on the original 
    "INSTALL.ubuntu".  Decided it was best to simply create a new version
    of the file so that references to old needs did not have to be kept.
    Not entirely updated as yet -- just worked on packages and cpan.

(2) Updated the ubuntu.packages file with the various packages available
    for lucid and corrected the various issues I found with typos, duplicates,
    etc.  Decided not worth creating a separate version specifically
    for lucid as dselect appears to ignore stuff it cannot find/recognize.
    So, that shouldn't hurt installs on earlier versions.

(3) Added a script utility (install_misc/ubuntu-pkg-check.sh) mentioned
    in "INSTALL.ubuntu.lucid".  Basically what this does is read the file
    "ubuntu.packages" and use "apt-cache policy" to report the version of 
    each package that is found installed (if not installed, the version 
    will be "(none)" or "" depending on apt-cache's reaction to a given
    package name).

    This should make it a little easier to see what dselect was and was
    not able to install.
Comment 3 Ian Walls 2012-02-01 14:59:59 UTC
As of current master, the following CPAN modules are not installed by ubuntu.packages:

Business::ISBN  (exists)
CGI::Session::Driver::memcached (not packaged for 10.04)
Gravatar::URL (exists)
HTTP::OAI (not packaged for 10.04)
Locale::Currency::Format (not packaged for 10.04)
Memoize::Memcached (not packaged for 10.04)
Modern::Perl (exists)
PDF::API2::Simple (not packaged for 10.04).
Text::CSV::Encoded (not packaged for 10.04)
Comment 4 Tomás Cohen Arazi 2012-09-18 02:52:09 UTC

*** This bug has been marked as a duplicate of bug 8478 ***