Bug 8478 - Update Ubuntu related files
Summary: Update Ubuntu related files
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low minor (vote)
Target Milestone: ---
Assignee: Tomás Cohen Arazi
QA Contact:
URL:
Whiteboard:
Keywords:
: 5057 5217 8192 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-07-19 14:03 UTC by Tomás Cohen Arazi
Modified: 2013-12-05 19:59 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 8478 - Create an INSTALL file for 12.04 (28.74 KB, patch)
2012-07-23 15:06 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 8478 - Rename ubuntu.packages to ubuntu.precise.packages (846 bytes, patch)
2012-07-23 15:13 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
New file for installation instructions under Ubuntu 12.04 (18.64 KB, text/plain)
2012-07-24 11:57 UTC, M. Tompsett
Details
Alpha Version Script to find: things missing in repo, find matching in repo, find missing in {os}.{version}.packages files (15.66 KB, text/plain)
2012-07-26 23:15 UTC, M. Tompsett
Details
A patch to update ubuntu related files in master (41.58 KB, patch)
2012-07-30 16:41 UTC, M. Tompsett
Details | Diff | Splinter Review
A patch to update ubuntu related files in 3.8.x (40.81 KB, patch)
2012-07-30 16:44 UTC, M. Tompsett
Details | Diff | Splinter Review
Bug 8478 - Update Ubuntu related files Updated installation instructions, cleaned up ubuntu-pkg-check.sh, renamed ubuntu*.packages files more consistently, updated files to include missing libraries, corrected incorrect libraries (yaz3->yaz4, mysqlclient (33.98 KB, patch)
2012-07-30 17:44 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review
Bug 8478 - Update Ubuntu related files (3.8.x) (33.22 KB, patch)
2012-08-10 14:42 UTC, Tomás Cohen Arazi
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Tomás Cohen Arazi 2012-07-19 14:03:06 UTC
Create INSTALL.ubuntu.* files for the two most current LTS releases of Ubuntu (lucid and precise). Update the data on them so they can be actually followed to INSTALL/UPGRADe Koha.

Upgrade the install_misc/*.packages files so it is clear which file should be used in which case (remove maverick related file).
Comment 1 Tomás Cohen Arazi 2012-07-23 15:06:43 UTC Comment hidden (obsolete)
Comment 2 Tomás Cohen Arazi 2012-07-23 15:13:14 UTC Comment hidden (obsolete)
Comment 3 M. Tompsett 2012-07-24 01:36:27 UTC
You may wish to look at bug 8489. I already patched the ubuntu files including the various .packages and the ubuntu-pkg-check.sh script.

Download 3.6.7 and you will notice that the ubuntu_maverick.packages file had been renamed already, and there are "other" files.

This way the ubuntu-pkg-check.sh script could use `lsb_release -r` to determine which file to use:
- ubuntu.10.04.packages (from ubuntu.packages)
- ubuntu.10.10.packages (from ubuntu_maverick.packages)
- ubuntu.12.04.packages (tweaked from ubuntu.packages)
- ubuntu.packages (copy of ubuntu.12.04.packages, a 'default' for other versions)

This is how I see ubuntu file updates related to *.packages moving forward:
When Ubuntu 12.10 is released, ubuntu.packages will be updated.
When Ubuntu 13.04 is released, ubuntu.packages will be updated.
When Ubuntu 13.10 is released, ubuntu.packages will be updated.
HOWEVER, when Ubuntu 14.04 LTS is released
- ubuntu.packages will be updated
- ubuntu.packages will be copied to ubuntu.14.04.packages
- ubuntu.10.* will be deleted

And thus, there should always be three ubuntu.*packages files existing:
- current LTS
- previous LTS
- ubuntu.packages reflecting the current non-LTS release.
The fact that ubuntu.10.10.packages file exists is due to not wanting to delete files while trying to get my patches in under the wire (thanks for letting me get the patches in, jcamins). 

Similarly, I personally think we should version number the INSTALL.Ubuntu files, not use the names. The INSTALL.Ubuntu and related instructions still need updating. I'll look at the attachments later.
Comment 4 M. Tompsett 2012-07-24 11:57:17 UTC Comment hidden (obsolete)
Comment 5 Tomás Cohen Arazi 2012-07-26 18:08:48 UTC
The INSTALL.ubuntu.precise file should remain as a patch, not the file itself.
Comment 6 M. Tompsett 2012-07-26 23:15:28 UTC Comment hidden (obsolete)
Comment 7 M. Tompsett 2012-07-27 17:41:51 UTC
Comment on attachment 11152 [details]
Alpha Version Script to find: things missing in repo, find matching in repo, find missing in {os}.{version}.packages files

This attachment is more generic than just Ubuntu. Jared suggested it could go into release tools. So, I created a separate bug report (bug 8517) to handle just this script. This will not be part of this bug's necessary patches/files.
Comment 8 M. Tompsett 2012-07-30 16:41:46 UTC Comment hidden (obsolete)
Comment 9 M. Tompsett 2012-07-30 16:44:03 UTC Comment hidden (obsolete)
Comment 10 M. Tompsett 2012-07-30 16:48:42 UTC
Needs sign off, unless Tomás Cohen Arazi wants to patch the documentation portion of this further.
Comment 11 Tomás Cohen Arazi 2012-07-30 17:37:04 UTC
(In reply to comment #10)
> Needs sign off, unless Tomás Cohen Arazi wants to patch the documentation
> portion of this further.

My patch would depend on Bug 8519 so I'll sign on these patches and provide patches against master once it is pushed.
Comment 12 Tomás Cohen Arazi 2012-07-30 17:44:50 UTC
Created attachment 11207 [details] [review]
Bug 8478 - Update Ubuntu related files Updated installation instructions, cleaned up ubuntu-pkg-check.sh, renamed ubuntu*.packages files more consistently, updated files to include missing libraries, corrected incorrect libraries (yaz3->yaz4, mysqlclient 

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 13 M. Tompsett 2012-07-31 03:53:28 UTC
Oops! You didn't dump ubuntu_maverick.packages in your patch, tcohen. I was wondering why there was a 8K difference (41.58KB vs. 33.98KB).
Comment 14 M. Tompsett 2012-08-01 09:29:59 UTC
*** Bug 8192 has been marked as a duplicate of this bug. ***
Comment 15 Tomás Cohen Arazi 2012-08-10 13:57:22 UTC
I'm not sure about the naming Mark. For the 3.8.x patch I see we have:

INSTALL.ubuntu
INSTALL.ubuntu.12.04
INSTALL.ubuntu.lucid

I'd completely remove INSTALL.ubuntu (I don't think we need the user to make assumptions on what version is for) and I'd provide a more consistent naming schema (as you did for the packages files).

The same applies for the version against master, which I signed-off.
I also prefer this to be pushed so we can send patches against it.
Comment 16 Tomás Cohen Arazi 2012-08-10 14:00:40 UTC
*** Bug 5057 has been marked as a duplicate of this bug. ***
Comment 17 M. Tompsett 2012-08-10 14:23:09 UTC
Okay, let's step back...

The install_misc/ubuntu.{version}.packages files make sense as each version of ubuntu will have differing requirements (eg. yaz3 vs. yaz4).

However, I think you are correct regarding the INSTALL files. I'm not so sure we need more than one. However, the dselect statement is going to differ based on OS version, so it will need to be reflected in the documentation. My understanding was that you were planning on tweaking the documentation, which is why I attached a patch in the first place.

My plan was to get INSTALL.ubuntu.12.04 correct and in good order, and then hopefully that would mean removal of the other two. And then we wouldn't need to version it.

Unfortunately, I'm in the midst of other work, and can't dedicate time to clean up the patches.

The patch should include (M=modified, -=remove, +=add) compared to master or 3.8.X:
M INSTALL.ubuntu (which should be the INSTALL.ubuntu.12.04 git mv'd over INSTALL.ubuntu -- after confirming nothing extra would be lost)
- INSTALL.ubuntu.lucid (versioning of install instructions makes no sense)
M install_misc/ubuntu-pkg-check.sh (should reflect my changes)
- install_misc/ubuntu_maverick.packages (which really gets renamed)
+ install_misc/ubuntu.10.10.packages
+ install_misc/ubuntu.10.04.packages (which is really a copy of the original ubuntu.packages file)
+ install_misc/ubuntu.12.04.packages (which is a tweaked and corrected version for either 3.6.X, 3.8.X or master -- there may be differences)
M install_misc/ubuntu.packages (which is a copy of ubuntu.12.04.packages)

Removal of INSTALL files could be done as a follow up bug. After all this is about updating files, not removing files. Renaming does not remove anything.

And the master patch above continues to keep the install_misc/ubuntu_maverick.packages file.
Comment 18 Tomás Cohen Arazi 2012-08-10 14:42:05 UTC
Created attachment 11536 [details] [review]
Bug 8478 - Update Ubuntu related files (3.8.x)

Updated allation instructions, cleaned up ubuntu-pkg-check.sh,
renamed ubuntu*.packages files more consistently, updated files
to include missing libraries, corrected incorrect libraries
 (yaz3->yaz4, mysqlclient v16 to v18, dropped the dev version of the client).

Signed-off-by: Tomas Cohen Arazi <tomascohen@gmail.com>
Comment 19 Marcel de Rooy 2012-08-30 12:12:27 UTC
Note for RM:
I do not know if we have someone in QA team for such specific patches in the area of Ubuntu installation instructions and packaging.
Updating patch status to have RM decide on next step.
Comment 20 M. Tompsett 2012-08-30 13:01:38 UTC
I think this is why there is the koha-devel mailing list discussion of: documentation formats, making the wiki match the installation instructions, and perhaps giving the INSTALL.{OS} files their own git repository for documentation purposes. At this point in time, those discussions are still in process. I'd like to see these patches get to 3.8.x and master, so at least we have a better base installation instruction set.
Comment 21 Paul Poulain 2012-09-05 09:07:05 UTC
(In reply to comment #20)
> I think this is why there is the koha-devel mailing list discussion of:
> documentation formats, making the wiki match the installation instructions,
> and perhaps giving the INSTALL.{OS} files their own git repository for
> documentation purposes. At this point in time, those discussions are still
> in process. I'd like to see these patches get to 3.8.x and master, so at
> least we have a better base installation instruction set.

Agreed.

Patch pushed to master. (I think it's not an ENH, but a small bugfix)
Comment 22 Chris Cormack 2012-09-05 23:32:34 UTC
Pushed to 3.8.x, will be in 3.8.5
Comment 23 Tomás Cohen Arazi 2012-09-18 02:52:09 UTC
*** Bug 5217 has been marked as a duplicate of this bug. ***