Bug 5358 - keep track of cancelled orders
Summary: keep track of cancelled orders
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.8
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Deadline: 2011-05-01
Assignee: Julian Maurice
QA Contact: Bugs List
URL: http://wiki.koha-community.org/wiki/C...
Keywords:
Depends on:
Blocks: 7163 5361
  Show dependency treegraph
 
Reported: 2010-11-02 03:54 UTC by Paul Poulain
Modified: 2012-10-25 23:09 UTC (History)
5 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (7.02 KB, patch)
2011-11-05 09:38 UTC, Julian Maurice
Details | Diff | Splinter Review
Signed off patch (7.20 KB, patch)
2011-12-07 02:49 UTC, Duncan
Details | Diff | Splinter Review
Rebased patch (5.76 KB, patch)
2012-01-02 10:04 UTC, Julian Maurice
Details | Diff | Splinter Review
signed-off (5.85 KB, patch)
2012-01-06 10:49 UTC, Christophe Croullebois
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2010-11-02 03:54:36 UTC
We will add a table deletedaqorders that will keep track of all deleted orders. From a given basket, there will be a link to display deleted orders line
Comment 1 Julian Maurice 2011-11-05 07:39:33 UTC
In fact, no new tables will be created, aqorders.datecancellationprinted will be used.
I'm working on it.
Comment 2 Julian Maurice 2011-11-05 09:38:01 UTC Comment hidden (obsolete)
Comment 3 Duncan 2011-12-07 02:49:38 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2012-01-02 09:19:51 UTC
Applying: Bug 5358: Show cancelled orders in basket page
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basket.tt
CONFLICT (content): Merge conflict in koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basket.tt
Recorded preimage for 'koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basket.tt'
Failed to merge in the changes.
Patch failed at 0001 Bug 5358: Show cancelled orders in basket page
Comment 5 Julian Maurice 2012-01-02 10:04:43 UTC Comment hidden (obsolete)
Comment 6 Christophe Croullebois 2012-01-06 10:40:32 UTC
ok fine, easy and usefull.
Signed off
Comment 7 Christophe Croullebois 2012-01-06 10:49:55 UTC
Created attachment 7065 [details] [review]
signed-off
Comment 8 Ian Walls 2012-01-09 12:43:35 UTC
Adds new subroutine and template params to access it.  All in all, very clean and easy to read.  Existing unit tests passed.  Marking Passed QA.

Only part missing is a new unit test for the subroutine, but since t/db_dependent/Acquisition.t is a stub now anyway, this shouldn't block the addition of this feature.
Comment 9 Paul Poulain 2012-01-13 10:19:45 UTC
Steps to reproduce:
* open an acquisition basket, with some lines
* cancel one of the order line by hitting "Delete order" option
=> a new table appear, with the cancelled order, below the remaining order lines.

Patch pushed, please test
Comment 10 Julian Maurice 2012-02-22 16:34:38 UTC
Ok in master, marked as resolved