Bug 5410 - "Right truncation not supported" error when running link_bibs_to_authorities.pl
Summary: "Right truncation not supported" error when running link_bibs_to_authorities.pl
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Searching (show other bugs)
Version: rel_3_2
Hardware: PC Linux
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Frédérick Capovilla
QA Contact: Bugs List
URL:
Keywords:
: 5155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-15 19:27 UTC by Frédérick Capovilla
Modified: 2013-12-05 19:53 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Adds "do-not-truncate" in the search queries of Heading.pm (983 bytes, patch)
2010-11-16 19:14 UTC, Frédérick Capovilla
Details | Diff | Splinter Review
Adds "do-not-truncate" in the search queries of Heading.pm (Correct patch formatting) (1.27 KB, patch)
2011-02-07 14:43 UTC, Frédérick Capovilla
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Frédérick Capovilla 2010-11-15 19:27:10 UTC
This error can happen multiple times when running misc/link_bibs_to_authorities.pl with a large number of biblios : 

CCL parsing error (10014) Right truncation not supported ZOOM at ...


I did some tests and found that the error happens when the script try to search for an authority that ends with a "?". "?" seems to be a wildcard character for truncation in CCL.


Examples of CCL queries causing a "Right truncation not supported" error : 

Match-heading,ext="Qui, quand, quoi?" AND at='UNIF_TITLE' AND Heading-use-series-added-entry=a
Match-heading,ext="Lescarbot, Marc, 1570?-1630?" AND at='PERSO_NAME' AND Heading-use-subject-added-entry=a AND Subject-heading-thesaurus=rvm


A possible solution would be to find a way escape the "?"s so they aren't seen as truncations by the CCL parser.
Comment 1 Frédérick Capovilla 2010-11-16 19:14:20 UTC Comment hidden (obsolete)
Comment 2 Frédérick Capovilla 2011-02-07 14:43:10 UTC
Created attachment 3077 [details] [review]
Adds "do-not-truncate" in the search queries of Heading.pm (Correct patch formatting)

Corrected the patch formatting.
Sorry for the inconvenience.
Comment 3 Chris Cormack 2011-04-06 05:19:45 UTC
Patch pushed
Comment 4 Jared Camins-Esakov 2011-10-23 14:05:38 UTC
Seems to be working properly now. Closing.
Comment 5 Fridolin SOMERS 2012-09-11 13:59:57 UTC
*** Bug 5155 has been marked as a duplicate of this bug. ***