Bug 5438 - Holds managed in circ rules
Summary: Holds managed in circ rules
Status: RESOLVED DUPLICATE of bug 5609
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.4
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Bugs List
URL: http://wiki.koha-community.org/wiki/H...
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-24 16:13 UTC by Paul Poulain
Modified: 2013-01-09 17:21 UTC (History)
2 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2010-11-24 16:13:59 UTC
The main parameters for holds should be part of the circulation rules generally in the branch/patron/item type equation (smart-rules).
Number of Holds allowed: how many holds allowed for each branch/patron/item combination from 0 (no holds allowed) to x
ReservesMaxPickUpDelay: from 1 to x
A couple extra enhancements to circ/waitingreserves.pl too:
ability (filter) to see only those holds that are over
ability to “select all” and thus “cancel all” holds in the page (i.e. all “Holds Over”)
ability to “print” the page for a clean listing of holds over
Comment 1 Nicole C. Engard 2013-01-09 17:21:21 UTC
Many of these are being handled in the Holds Rewrite: http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5609  I think we should close this and then refer to that bug and break each preference moved to the matrix out to its own bug report.

*** This bug has been marked as a duplicate of bug 5609 ***