Bug 5609 - Holds Rewrite
Summary: Holds Rewrite
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: master
Hardware: All All
: P1 - high enhancement (vote)
Assignee: Bugs List
QA Contact: Bugs List
URL:
Keywords:
: 5438 (view as bug list)
Depends on: 3488 5669 5675 5786 5787 5788 5872 5912 7065 7641
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-12 00:53 UTC by Nicole C. Engard
Modified: 2016-12-05 21:23 UTC (History)
8 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-01-12 00:53:07 UTC
Holds in Koha needs some work - full RFC here: http://wiki.koha-community.org/wiki/Holds_Rewrite_RFC
Comment 1 Lori Ayre 2012-05-23 14:23:23 UTC
Changing the importance of this enhancement to high because if it was in place, we'd have several California libraries choosing Koha.  Instead they are moving to Evergreen (or at least thinking about it).  But I actually think Koha is a better choice for these libraries in many ways ....but only if they have more control over how holds are handled.  This is a big missing piece.
Comment 2 Owen Leonard 2012-05-23 14:28:42 UTC
I agree with the sentiment, but changing the priority doesn't do anything at all. The development is sponsored and work is being done. Short of throwing more money at it I don't know what else can be done.
Comment 3 Lori Ayre 2012-05-23 14:33:14 UTC
I have thrown money at it.  If lack of money is the reason this development isn't getting done, I'd like to know about it.
Comment 4 Chris Cormack 2012-05-23 20:26:03 UTC
Have you looked at all the attached bugs Lori, work is being done.
Comment 5 Katrin Fischer 2012-05-23 20:29:50 UTC
I would be inerested to hear what kind of problems they have? What are the missing pieces?
Comment 6 Lori Ayre 2012-05-23 22:23:07 UTC
Thanks, Chris.  I know that work is being done.  I didn't mean to create trouble.  Brendan said it would be fine for me to bump up the priority above the default setting so I was just wanting people to know that this is an important one for many of us here in California.

And if there are blockers that are going to prevent this enhancement from coming to fruition, I would like to know.  We did make an investment in it and I'd like to see it continuing to move forward....I'm just not sure of the best way to keep track of its progress and help move it forward if there is indeed something I could do to help.

Lori
Comment 7 Nicole C. Engard 2013-01-09 17:21:21 UTC
*** Bug 5438 has been marked as a duplicate of this bug. ***
Comment 8 scott kushner 2013-02-01 20:11:17 UTC
Currently, when a Suspended HOLD is un-suspended, it does not show up in the Holds to Pull report. 

Is this part of the Holds re-write development? 

If not, can it be?

It's kind of an important feature. 

Thanks.
Comment 9 Kyle M Hall 2013-02-05 14:06:49 UTC
Are you referring to view_holdsqueue.pl, or to pendingreserves.pl?

(In reply to comment #8)
> Currently, when a Suspended HOLD is un-suspended, it does not show up in the
> Holds to Pull report. 
> 
> Is this part of the Holds re-write development? 
> 
> If not, can it be?
> 
> It's kind of an important feature. 
> 
> Thanks.
Comment 10 Katrin Fischer 2016-01-06 17:57:08 UTC
Confirmed with Kyle that this can be closed.