Bug 5551 - The shelf browser should be able to ignore things like location
Summary: The shelf browser should be able to ignore things like location
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Keywords:
: 4367 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-12-29 02:10 UTC by Robin Sheat
Modified: 2012-10-25 23:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (24.25 KB, patch)
2011-01-14 02:27 UTC, Robin Sheat
Details | Diff | Splinter Review
Signed-off patch (24.61 KB, patch)
2011-01-20 21:39 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2010-12-29 02:10:25 UTC
For some libraries (e.g. that have items that are sent out from a couple of central locations, or where relevant things might be at another, still accessible, location) it is useful to be able to browse the entire collection in the shelf browser, not just looking at those physically nearby.
Comment 1 Robin Sheat 2010-12-29 04:35:14 UTC
The implementation of this will probably also allow Bug 4367 to be closed, it makes sense to do them both at the same time.
Comment 2 Nicole C. Engard 2010-12-29 12:19:28 UTC
What is the implementation of this? Will it still look at location if it's there? Is there a system preference? I know that we just recently got it looking at both call number and shelving location and I'd hate to lose that functionality.
Comment 3 Robin Sheat 2010-12-29 21:37:29 UTC
My thinking (suggested by jcamins) is that we'll have three sysprefs: Use homebranch (default: yes), use location (yes), use ccode (no). This will keep the current behaviour by default, but allow it to be changed fairly granularly.
Comment 4 Nicole C. Engard 2010-12-29 23:18:17 UTC
Sounds perfect :)
Comment 5 Robin Sheat 2011-01-14 02:27:27 UTC Comment hidden (obsolete)
Comment 6 Jared Camins-Esakov 2011-01-20 21:39:38 UTC
Created attachment 3014 [details] [review]
Signed-off patch

I have rebased to apply to current head, and signed off on this patch.
Comment 7 Chris Cormack 2011-01-23 18:24:47 UTC
Pushed, please test
Comment 8 MJ Ray (software.coop) 2011-02-04 09:14:09 UTC
This bug is mentioned in:
Bug 5551 - allow shelf browser filters to be	changed http://lists.koha-community.org/pipermail/koha-patches/2011-January/013602.html
Bug 5551 - allow shelf browser	filters to be changed http://lists.koha-community.org/pipermail/koha-patches/2011-January/013688.html
Comment 9 Robin Sheat 2011-02-07 01:12:32 UTC
*** Bug 4367 has been marked as a duplicate of this bug. ***