Bug 5733 - Empty cart in intranet when session is closed
Summary: Empty cart in intranet when session is closed
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Staff interface (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
: 5836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-02-10 01:58 UTC by Chris Cormack
Modified: 2012-10-25 23:04 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (1.14 KB, patch)
2011-02-10 02:06 UTC, Chris Cormack
Details | Diff | Splinter Review
Proposed follow-up fix (2.00 KB, patch)
2011-02-10 17:03 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-02-10 01:58:38 UTC

    
Comment 1 Chris Cormack 2011-02-10 02:06:38 UTC
Created attachment 3119 [details] [review]
Proposed Patch
Comment 2 Chris Cormack 2011-02-10 02:09:23 UTC
Pushed, please test
Comment 3 Owen Leonard 2011-02-10 16:27:53 UTC
Logging out now prompts the user "Are you sure you want to empty your card?" even if there isn't anything in the cart.
Comment 4 Owen Leonard 2011-02-10 17:03:32 UTC
Created attachment 3124 [details] [review]
Proposed follow-up fix

I suggest we eliminate the prompt altogether: assume that if the user is logging out that the cart should be emptied. This patch lets us pass a "true" parameter to the delBasket function to bypass the confirmation prompt.
Comment 5 Nicole C. Engard 2011-02-11 18:15:44 UTC
I tested the follow up but it's still prompting me to say okay when i log off and it's way way way way annoying.
Comment 6 Nicole C. Engard 2011-02-11 18:17:06 UTC
nevermind - shift refresh did the trick. signing off!
Comment 7 Chris Cormack 2011-02-13 20:56:57 UTC
Follow up patch pushed, please test and mark resolved
Comment 8 Chris Cormack 2011-03-07 01:17:42 UTC
*** Bug 5836 has been marked as a duplicate of this bug. ***