Bug 5754 - Enhancements to patron debarrment
Summary: Enhancements to patron debarrment
Status: CLOSED DUPLICATE of bug 6328
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5575
  Show dependency treegraph
 
Reported: 2011-02-14 02:44 UTC by Chris Cormack
Modified: 2012-10-26 00:41 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
follow-up patch to display debarrement date & comment on opac (2.47 KB, patch)
2011-04-29 17:55 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-02-14 02:44:09 UTC
Now when a user is debarred, you set a end date, and can put a comment.
This patch is the first, it need some improvement, but works globaly well.
If an overdue generate a debar, the debar date is set to 9999-12-31.

show debar date on member detail
This patch show debar date, if the member is debarred, and he have a valid date(not unlimited debar).

add debar date in circulation
This patch add the debar date if it's not unlimited, in circulation.pl

rework on member edition
This change the way to edit user debar date/comment, to follow nicolas' mockup.
Comment 1 Nicole C. Engard 2011-02-14 12:25:37 UTC
This may be a translation issue, but since you're working on this area, I'd like to suggest for US English that 'debar' be changed to 'restricted' or 'barred' - I had never heard the term 'debar' until I saw Koha and those I train also ask me what it means.
Comment 2 Paul Poulain 2011-04-29 17:54:17 UTC
chris, where's the patch for this one ?
(i've a small follow-up, i'll attach. the follow-up will work only if debarred is a date, and there is a borrowers.debarredcomment)
Comment 3 Paul Poulain 2011-04-29 17:55:13 UTC
Created attachment 4022 [details] [review]
follow-up patch to display debarrement date & comment on opac
Comment 4 Chris Cormack 2011-05-01 20:47:24 UTC
Hmm interesting it appears I never formatted a patch for this one.

It probably needs to be pulled out of the 5575 branch, fixed for TT (if needed) then attached
Comment 5 Chris Cormack 2011-05-01 20:47:56 UTC
Follow up patch needs to be reformatted for TT too, before it will apply
Comment 6 Paul Poulain 2011-05-11 14:57:04 UTC
solved by 6328

*** This bug has been marked as a duplicate of bug 6328 ***