Bug 5575 - 3.4 BibLibre circ & members omnibus
Summary: 3.4 BibLibre circ & members omnibus
Status: CLOSED WONTFIX
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: 3.4
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on: 5771 5432 5728 5730 5732 5734 5748 5749 5750 5751 5752 5753 5754 5758 5759 5760 5773 5835 5836 5869 5872 5873 5874 5876 5877 5878 5904 5905
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-04 21:57 UTC by Paul Poulain
Modified: 2014-11-02 12:32 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Markup corrections (9.51 KB, patch)
2011-01-20 17:20 UTC, Owen Leonard
Details | Diff | Splinter Review
Corrections for boraccount.tmpl (4.48 KB, patch)
2011-01-20 19:28 UTC, Owen Leonard
Details | Diff | Splinter Review
CSS correction (1.02 KB, patch)
2011-01-20 19:38 UTC, Owen Leonard
Details | Diff | Splinter Review
Moving guarantee checkouts to tab; Markup corrections (3.76 KB, patch)
2011-01-31 13:54 UTC, Owen Leonard
Details | Diff | Splinter Review
XSLT details layout correction (1.55 KB, patch)
2011-01-31 13:57 UTC, Owen Leonard
Details | Diff | Splinter Review
Confusing preference (6.09 KB, image/png)
2011-01-31 15:36 UTC, Owen Leonard
Details

Note You need to log in before you can comment on or make changes to this bug.
Comment 1 Chris Cormack 2011-01-05 20:08:17 UTC
These are in new/awaiting_qa/enh/bug_5575
Comment 2 Paul Poulain 2011-01-11 10:27:49 UTC
=> missing field in database

[Tue Jan 11 10:49:56 2011] [error] [client 213.41.255.216] [Tue Jan 11 10:49:56 2011] maninvoice.pl: DBD::mysql::st execute failed: Unknown column 'time' in 'field list' at /home/koha/versions/3.4/borrowers/C4/Accounts.pm line 446., referer: http://borrowers34.git.biblibre.com/cgi-bin/koha/members/maninvoice.pl?borrowernumber=51

=> BibLlibre mistake : the new fields are in updatedatabase, but not in kohastructure.sql (also in our master branch)
Comment 3 Paul Poulain 2011-01-11 15:21:50 UTC
ok, part payement fixed, with some other merge problems.
6a0f4c672461f2a1dc242b51933978e5329ca845 and 088dbd23a1681fcdcc031aab5b2bcfabb6108899
Comment 4 Owen Leonard 2011-01-11 20:45:04 UTC
There is a javascript error on circulation.pl. Looks like maybe a merge problem? This snippet at line 124 looks like an orphan:

   index = id.IndexOf("_");
   return id.substr(index+1);
}
Comment 5 Owen Leonard 2011-01-11 20:47:39 UTC
On moremember.pl under the "Suggestions" tab, authorized values for reasonACCEPTED are not appearing.
Comment 6 Owen Leonard 2011-01-11 20:52:38 UTC
On moremember.pl under the checkouts tab, barcode has been moved back into its own column. Is this intentional?

There is now a "Stock number" column, but with my data that column is empty. What is it for?

This display has diverged again from the one on circulation.pl, reopening Bug 3106.
Comment 7 Owen Leonard 2011-01-11 20:54:16 UTC
On members/boraccount.pl under the "Account" tab, "action" columns like "print" and "reverse" should be excluded from the js tablesorter.
Comment 8 Owen Leonard 2011-01-11 20:57:11 UTC
/tools/viewlog.pl would benefit from the addition of the tablesorter pager plugin.
Comment 9 Owen Leonard 2011-01-11 21:00:07 UTC
With XSLTDetailsDisplay, I get an error from catalogue/detail.pl: Can't call method "subfield" on an undefined value at /C4/XSLT.pm line 127.
Comment 10 Owen Leonard 2011-01-11 21:02:44 UTC
Clicking "Batch edit" from the staff client Cart results in a 404 error ("/cgi-bin/koha/tools/batchedit.pl?bib_list=XXX/XXX").
Comment 11 Owen Leonard 2011-01-12 15:36:03 UTC
On the circulation page, clicking the "Override renewal limit" checkbox doesn't display the renew checkboxes. Only after clicking it again (unchecking it) do the renew checkboxes appear.
Comment 12 Owen Leonard 2011-01-12 15:38:14 UTC
How new was the version of Koha these changes were built on? The circulation page shows a bug that was fixed in December 2010. Bug 5281
Comment 13 Owen Leonard 2011-01-12 15:49:21 UTC
On members/moremember.pl, a JavaScript error is generated if the patron has no "Additional attributes and identifiers" because the tablesorter plugin is trying to sort an empty table. The table should be hidden altogether if there is no data.
Comment 14 Paul Poulain 2011-01-19 09:29:00 UTC
(In reply to comment #12)
> How new was the version of Koha these changes were built on? The circulation
> page shows a bug that was fixed in December 2010. Bug 5281

I've rebased on dec, 14th. seems the patch should still be valid. Will double check & fix if needed
Comment 15 Paul Poulain 2011-01-19 19:50:13 UTC
comment 4: fixed in ceb470dcebcadeb32e458448211d4ecebaa3c8e4

comment 5: fixed in 9b8e63aa79abec5d6626243f46aebd35dfeb4dd9

comment 6: the stocknumber is the inventory number. it differs from the barcode as it's a "forever" number, the barcode can be changed. It's a legal requirement in France to have such a number for each book you buy. it has been added a while ago by us. Don't you use such an identifier in US ? About the "reordering" of the table, it was not intentional. Should be fixed.

comment 7 and 8: you're probably right, but it is en enhancement and should be in another bz entry

comment 9: fixed in 51e42cf14351c5a30d6b29ad9d998b3c1f9a136c Behaviour improved = XSLT are no more a boolean, but a full xslt path (with or without http) some things were lost in merging + updating sysprefs

comment 10: batchedit is in another branch. I suggest to let the link as is, it will work when BibLibre-cataloguing will be merged too.

comment 11: fixed in acf1cabd5ed3408e525a3958755ade545cb608e0

comment 12: fixed in a98f3f557acec7f11b15554509138f9e26bc682e

comment 13: can't reproduce the problem
Comment 16 Chris Cormack 2011-01-19 21:23:05 UTC
Pushed to

new/awaiting_qa/enh/bug_5575
Comment 17 Owen Leonard 2011-01-20 17:14:49 UTC
On moremember.pl when I switch to the suggestions tab I see a table of suggestions and then below that I see a big block of jumbled text, as if the suggestions data were being redisplayed without the table markup. It looks to me like there is a problem with nesting <!-- TMPL_LOOP Name="suggestions" --> inside <!-- TMPL_LOOP NAME="suggestions_loop" -->
Comment 18 Owen Leonard 2011-01-20 17:20:45 UTC
Created attachment 3011 [details] [review]
Markup corrections

    - Putting attributes and identifiers table inside TMPL_IF to avoid js error
    - Correcting sorting columns
    - Removing duplicate IDs
    - Styling error message with standard <div class="dialog alert">
    - Other minor markup corrections
Comment 19 Owen Leonard 2011-01-20 19:20:49 UTC
/cgi-bin/koha/members/pay.pl: Selecting an option in the first column results in a JS error in: payfinechange(this.value,). Neither <!-- TMPL_VAR name="i" --> or <!-- TMPL_VAR name="accountlineid" --> are reaching the template.

How is the "means of payment" option populated?
Comment 20 Owen Leonard 2011-01-20 19:28:44 UTC
Created attachment 3012 [details] [review]
Corrections for boraccount.tmpl

Correcting table sort columns, fixing markup
Comment 21 Owen Leonard 2011-01-20 19:38:09 UTC
Created attachment 3013 [details] [review]
CSS correction

Restoring "float left" on fieldset.rows label. Removing it breaks the layout of all entry forms. Was it removed because it conflicted with another CSS change?
Comment 22 Owen Leonard 2011-01-20 19:48:46 UTC
When using the patron duplicate function "initials" and "other name" are copied. I would think these, like first name, should be omitted from the fields copied.
Comment 23 Owen Leonard 2011-01-21 13:48:37 UTC
Comment 4: Confirmed fixed.
Comment 5: Confirmed fixed.
Comment 7: Fixed.
Comment 9: No error now, but layout is broken. I will investigate.
Comment 11: Confirmed fixed.
Comment 13: Fixed.
Comment 24 Owen Leonard 2011-01-28 21:03:54 UTC
I can see the guarantee's checkouts showing on the guarantor's checkout page, but why are the guarantor's checkouts showing on the guarantee's page?
Comment 25 Owen Leonard 2011-01-31 13:54:29 UTC
Created attachment 3037 [details] [review]
Moving guarantee checkouts to tab; Markup corrections
Comment 26 Owen Leonard 2011-01-31 13:57:06 UTC
Created attachment 3039 [details] [review]
XSLT details layout correction

The XSLTDetails template variable was changed, but only one of
three instances of that variable were updated in the template,
causing a broken layout (mentioned in comment 23).
Comment 27 Owen Leonard 2011-01-31 14:01:26 UTC
Checking in an item gives me this error:

Can't call method "any" without a package or object reference at /home/oleonard/kohaclone/circ/returns.pl line 225.
Comment 28 Owen Leonard 2011-01-31 14:11:49 UTC
I notice this branch includes the feature in circulation and fines rules which breaks the rules into tabs. It seems to be working, but the "filter" field at the top of the table doesn't.

JS Error: $.uiTableFilter is not a function
/cgi-bin/koha/admin/smart-rules.pl
Line 81
Comment 29 dev_patches 2011-01-31 14:18:25 UTC
Paul : It should load uitablefilter.
Comment 30 Owen Leonard 2011-01-31 15:16:50 UTC
The OPACPickupLocation preference is not being found by a system preference search and appears on the "Local Use" tab instead of the OPAC tab.
Comment 31 Owen Leonard 2011-01-31 15:22:38 UTC
OPAC detail page layout problem: http://screencast.com/t/9zXqFhIoUqkp

Is this feature documented somewhere?
Comment 32 Owen Leonard 2011-01-31 15:36:54 UTC
Created attachment 3041 [details]
Confusing preference

I find the revised XSLT preferences to be quite confusing. One option is controlling both *whether* XSLT is on and *where* the stylesheet is located. With the new system preferences editor those two things don't work well together. I would suggest one preference for XSLT on or off and another for where the stylesheet is.

In the meantime the upgrade process needs to handle these values properly. My "on" and "off" preferences were kept as 0 and 1 rather than being translated to "(empty)" and "(correct XSL path)"
Comment 33 Owen Leonard 2011-01-31 17:46:42 UTC
The checkouts tab on the circulation page now has a column "Material," which in my installation is empty. What is this intended to display? It seems to have replaced the "Price" column which is now absent. I no longer see "Stock number" on moremember.pl (see comment 6). Was it removed?
Comment 35 Chris Cormack 2011-02-09 21:40:40 UTC
I'm working on breaking this down into smaller bugs, ala 5574

I will build a dependency tree and hopefully we can get the bits signed off and merged.

Please hold off testing against this whole branch, instead when the patches for the individual bugs come through please test them instead.
Comment 36 Jared Camins-Esakov 2012-02-13 13:33:36 UTC
Marking RESOLVED-WONTFIX, per IRC conversation with hdl.