Bug 5943 - Merging Authorities
Summary: Merging Authorities
Status: RESOLVED DUPLICATE of bug 5202
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Authority data support (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Matthias Meusburger
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5581
  Show dependency treegraph
 
Reported: 2011-03-24 02:18 UTC by Chris Cormack
Modified: 2014-05-08 13:46 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed patch (6.34 KB, patch)
2011-03-24 02:23 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-03-24 02:18:02 UTC

    
Comment 1 Chris Cormack 2011-03-24 02:23:05 UTC
Created attachment 3419 [details] [review]
Proposed patch
Comment 2 stephane.delaune 2011-04-06 13:12:51 UTC
This patch conflicts with patch bugs 5572 and 5657. It just changes the sub merge C4::AuthoritiesMarc::merge which is only used by function C4::AuthoritiesMarc::ModAuthority if (C4::Context->preference('MergeAuthoritiesOnUpdate') ). This syspref does not exist by default. So it makes me doubt the relevance of this patch
Comment 3 Marcel de Rooy 2011-04-06 13:38:07 UTC
(In reply to comment #2)
> This patch conflicts with patch bugs 5572 and 5657. It just changes the sub
> merge C4::AuthoritiesMarc::merge which is only used by function
> C4::AuthoritiesMarc::ModAuthority if
> (C4::Context->preference('MergeAuthoritiesOnUpdate') ). This syspref does not
> exist by default. So it makes me doubt the relevance of this patch

This new pref was not introduced correctly. And should be based on value of the old pref dontmerge.
Comment 4 Nicole C. Engard 2011-04-18 18:06:54 UTC
This sounds like you're all saying this patch has failed QA and needs to be resubmitted so I'm updating the status.
Comment 5 Nicole C. Engard 2013-05-21 15:31:39 UTC
This is still desired - can we get a new patch?
Comment 6 Martin Renvoize 2014-05-08 13:46:50 UTC

*** This bug has been marked as a duplicate of bug 5202 ***