Bug 5952 - Shows member relatives in issues list
Summary: Shows member relatives in issues list
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Guillaume Hatt
QA Contact: Bugs List
URL:
Keywords:
: 5758 (view as bug list)
Depends on:
Blocks: 6568
  Show dependency treegraph
 
Reported: 2011-03-25 10:38 UTC by Julian Maurice
Modified: 2012-10-25 23:09 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Patch from BibLibre (31.62 KB, patch)
2011-03-25 10:43 UTC, Julian Maurice
Details | Diff | Splinter Review
checkouts (50.08 KB, image/png)
2011-03-28 00:23 UTC, Nicole C. Engard
Details
Add another tab (3.23 KB, patch)
2011-03-28 08:02 UTC, Julian Maurice
Details | Diff | Splinter Review
Follow-up fix (10.50 KB, patch)
2011-04-01 16:28 UTC, Owen Leonard
Details | Diff | Splinter Review
Reformatted patch (10.50 KB, patch)
2011-04-01 18:33 UTC, Owen Leonard
Details | Diff | Splinter Review
rebasing owen's patch : reformatted and some spellings update... (10.50 KB, patch)
2011-04-05 08:19 UTC, dev_patches
Details | Diff | Splinter Review
Revised for Template::Toolkit (11.65 KB, patch)
2011-04-13 18:39 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Julian Maurice 2011-03-25 10:38:18 UTC
It shows patron relatives issues in circulation.pl and moremember.pl
Comment 1 Julian Maurice 2011-03-25 10:43:36 UTC
Created attachment 3431 [details] [review]
Patch from BibLibre

This patch shows the member relatives' issues is circulation.pl and moremember.pl.
Relatives are parents, siblings and children.
Please test.
Comment 2 Nicole C. Engard 2011-03-28 00:23:35 UTC
Created attachment 3447 [details]
checkouts

This patch works, but I think it would be much better if we had another tab for the 'relative checkouts' instead of a whole other box - seems that we have those tabs there and it just makes sense to put those checkouts on that tab.
Comment 3 Nicole C. Engard 2011-03-28 00:26:22 UTC
I'm signing off on this because it does work and we're on a deadline - but I think a design follow up is in order.
Comment 4 Julian Maurice 2011-03-28 08:02:01 UTC
Created attachment 3460 [details] [review]
Add another tab

This follow-up patch adds another tab for the 'relatives issues'. When there is no relatives issues, the tab does not display.
Comment 5 Nicole C. Engard 2011-03-28 11:35:51 UTC
Awesome! Follow up signed off on.
Comment 6 Jane Wagner 2011-03-29 12:11:32 UTC
Does this give parents the option to see their children's checkouts in the OPAC? Or is it only for staff side?
Comment 7 Nicole C. Engard 2011-03-29 12:15:23 UTC
Only the staff side so far. I'd say if we want to add it to the opac we need a system preference and maybe something like the opac privacy options we have for reading history.
Comment 8 Jane Wagner 2011-03-29 12:27:09 UTC
I agree.  It would be worth extending to OPAC, so that parents can see if their kids have overdues/fines/etc., but there would need to be some options built in.
Comment 9 Chris Cormack 2011-04-01 08:22:49 UTC
Patch, please test
Comment 10 Chris Cormack 2011-04-01 08:25:03 UTC
Pushed even :)
Comment 11 Owen Leonard 2011-04-01 16:22:31 UTC
*** Bug 5758 has been marked as a duplicate of this bug. ***
Comment 12 Owen Leonard 2011-04-01 16:28:53 UTC Comment hidden (obsolete)
Comment 13 Owen Leonard 2011-04-01 18:33:30 UTC Comment hidden (obsolete)
Comment 14 dev_patches 2011-04-05 08:19:06 UTC Comment hidden (obsolete)
Comment 15 MJ Ray (software.coop) 2011-04-11 08:32:17 UTC
This bug is mentioned in:
Bug 5952: Shows member relatives in issues	lists http://lists.koha-community.org/pipermail/koha-patches/2011-March/014227.html
Bug 5952: Shows member	relatives in issues lists http://lists.koha-community.org/pipermail/koha-patches/2011-March/014243.html
Bug 5952: Add another tab	for relatives issues http://lists.koha-community.org/pipermail/koha-patches/2011-March/014262.html
Bug 5952: Add another tab for relatives	issues http://lists.koha-community.org/pipermail/koha-patches/2011-March/014256.html
Comment 16 Owen Leonard 2011-04-13 18:39:20 UTC
Created attachment 3914 [details] [review]
Revised for Template::Toolkit
Comment 17 Chris Cormack 2011-04-14 02:41:55 UTC
Follow up patch pushed, please test