Bug 5977 - opac advanced search Library always set to my library
Summary: opac advanced search Library always set to my library
Status: CLOSED DUPLICATE of bug 5390
Alias: None
Product: Koha
Classification: Unclassified
Component: OPAC (show other bugs)
Version: 3.4
Hardware: All All
: PATCH-Sent (DO NOT USE) normal (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks: 5584
  Show dependency treegraph
 
Reported: 2011-03-28 20:35 UTC by Chris Cormack
Modified: 2012-10-26 00:41 UTC (History)
2 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed Patch (1.81 KB, patch)
2011-03-28 20:40 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Cormack 2011-03-28 20:35:49 UTC
Without any consideration of the System preference SearchMyLibraryFirst,
When patron is logged in, the library set is set to the patron's library.
This is not the expected behaviour and is implied by GetBranchesLoop
and the fact that users library is selected by default.

Overwriting this behaviour in opac-search.pl when user not logged in
or SearchMyLibraryFirst not set i.e. mybranch not set
Comment 1 Chris Cormack 2011-03-28 20:40:57 UTC
Created attachment 3478 [details] [review]
Proposed Patch
Comment 2 Jared Camins-Esakov 2011-03-29 12:56:48 UTC
This may be fixed by patch for bug 5852. Regardless, I don't think that manually unsetting the selection is the way to do it. Better to correct GetBranchesLoop.
Comment 3 Matthias Meusburger 2011-04-06 08:22:07 UTC
For me, this issue has been fixed by patch for bug 5852 (for bug 5390 , in fact). 

Although it works well with the proposed patch applied, it also works well without it.

As patch for bug 5390 has already been applied to master, I mark this bug as duplicate for 5390, and thus, resolved.

*** This bug has been marked as a duplicate of bug 5390 ***
Comment 4 MJ Ray (software.coop) 2011-04-06 13:52:04 UTC
This bug is mentioned in:
Bug 5977 : MT3617 : opac search advanced	Library set to my library http://lists.koha-community.org/pipermail/koha-patches/2011-March/014293.html