Bug 6343 - Label Creator not working , Current Branch: NULL
Summary: Label Creator not working , Current Branch: NULL
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Label/patron card printing (show other bugs)
Version: 3.4
Hardware: All Linux
: PATCH-Sent (DO NOT USE) critical (vote)
Target Milestone: Oldversions
Assignee: Katrin Fischer
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
: 6272 6358 (view as bug list)
Depends on:
Blocks: 5653
  Show dependency treegraph
 
Reported: 2011-05-15 21:11 UTC by Ata ur Rehman
Modified: 2018-12-16 19:34 UTC (History)
9 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fixing 3 TT issues in label batches (3.26 KB, patch)
2011-05-20 19:20 UTC, Katrin Fischer
Details | Diff | Splinter Review
Signed off Patch (3.27 KB, patch)
2011-05-24 07:45 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Ata ur Rehman 2011-05-15 21:11:58 UTC
Lable Creator not working as mentioned:

1- http://lists.katipo.co.nz/pipermail/koha/2011-May/028983.html
2- http://lists.katipo.co.nz/pipermail/koha/2011-May/029032.html

Can not add barcodes in new batch or manage batch
Comment 1 Chris Nighswonger 2011-05-18 00:57:15 UTC
*** Bug 6358 has been marked as a duplicate of this bug. ***
Comment 2 Chris Nighswonger 2011-05-18 01:02:24 UTC
This is most likely due to the switch to TT.
Comment 3 Katrin Fischer 2011-05-20 16:21:59 UTC
I have stared at the files for 2 hours now and have no idea how to solve this. Plz can someone else take a look? 
It's an evil bug and blocking other bugs from sign-off.
Comment 4 Katrin Fischer 2011-05-20 19:20:06 UTC Comment hidden (obsolete)
Comment 5 Chris Cormack 2011-05-24 07:45:51 UTC
Created attachment 4243 [details] [review]
Signed off Patch
Comment 6 Chris Nighswonger 2011-05-24 22:26:05 UTC
*** Bug 6272 has been marked as a duplicate of this bug. ***
Comment 7 Ian Walls 2011-05-25 20:45:17 UTC
Tested with both normal database user as well as kohaadmin database user.  Works.  Marking as Passed QA.
Comment 8 Chris Cormack 2011-05-25 21:31:47 UTC
Patch pushed, please test
Comment 9 Nicole C. Engard 2011-06-03 13:14:53 UTC
Looks like it works to me!
Comment 10 Ata ur Rehman 2011-06-03 16:55:38 UTC
It works for me now
Comment 11 RAOSOMA 2011-06-03 18:59:27 UTC
Well, the fix solves the problem only for "Label Creator". It doesn't solve problem of "Patron Card Creator". Similar changes in code of label-manage.pl and label-edit-batch.pl are required for manage.pl and edit-batch.pl also respectively. Then only the Patron Card Creator also will be proper.
Comment 12 Liz Rea 2011-07-13 14:06:32 UTC
The card creator and the label creator are two separate things, you will need to file a bug for the card creator issue. Thanks!
Comment 13 Katrin Fischer 2011-07-13 14:19:43 UTC
Similar changes were made for patron card creator, bug 6415, and already pushed to master.
Comment 14 Liz Rea 2011-07-14 01:44:17 UTC
Awesome thanks Katrin!