Bug 6685 - circ rules by groups of items
Summary: circ rules by groups of items
Status: RESOLVED DUPLICATE of bug 21946
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Bugs List
URL:
Keywords:
: 8327 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-08-09 14:14 UTC by Nicole C. Engard
Modified: 2019-04-28 23:21 UTC (History)
12 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2011-08-09 14:14:35 UTC
I have had two libraries mention this recently so I thought I'd put it out there as possible enhancement to Koha.

"We have about 10 item types that are "media" (CDs, DVDs, records, etc.).  Our
circulation department would like to restrict checkouts to three media items
total, not three of each kind."

I'm thinking we would need a way to group item types together into a general 'type' so that we can set rules on groups of item types as well as on a per type level.
Comment 1 Paul Poulain 2011-08-09 14:31:55 UTC
Is it a needed enhancement ? couldn't you just use ccode and itype for that ?

ccode = CD / DVD / records / ...
itype = short checkout / long checkout / very long checkout (for example)

when you create items, you have 2 fields to fill = "CD / short checkout" or "book / long checkout"(for example

I'm sure you'll say "yes, but libraries don't want to enter 2 fields, they could do a mistake"
In this case, just develop a small plugin to fill valueB when valueA has been selected. I'm sure someone knowing how to do that would need one hour for such a plugin !
Comment 2 Nicole C. Engard 2011-08-09 15:31:49 UTC
Paul,

The reasoning was this: Patrons are allowed a total of 3 media items checked out but CDs can be checked out for 10 days and DVDs for 3 days and Records for 5 days ... understand why we'd need a group for a 'max checkouts'?
Comment 3 Paul Poulain 2011-08-09 15:36:28 UTC
does this library know the word "simplicity" ;-)

not sure this kind of rules is easy to understand for a patron... but I agree if it's needed it require some dev (and probably not a small&quick one !
Comment 4 Nicole C. Engard 2011-08-09 15:44:57 UTC
I agree that it's not easy but as for the patrons, the point is that they don't have to worry about the rules ;) Koha does the calculating for them.  Just an eye that was worth throwing out there.

Nicole
Comment 5 Margo Duncan 2011-08-10 02:30:14 UTC
I think that if CCODE was something we could limit on in the circ rules that
would fix our problem--we could put all those media item types in a CCODE of
"media" and set the rules for patrons in that way.

I understand Paul's suggestion of creating item types that reflect the length
of time something circulates, rather than reflecting the physical item type. However, most our items circulate for one semester,
three weeks or one week depending upon the patron type, not the itype.

That's my two cents on what would work for us.

Margo
Comment 6 Nicole C. Engard 2013-05-08 17:07:21 UTC
*** Bug 8327 has been marked as a duplicate of this bug. ***
Comment 7 Olli-Antti Kivilahti 2014-09-11 15:01:18 UTC
We normally use itype to calculate circulation rules, but needed a solution to set some items to shorter circulation duration (shortloan "SHLO") and some to even more shorter (quickloan "QILO").

So we made ccodes SHLO and QILO and set them in the C4-modules to their respective durations when circulation rules were checked.

Obviously this is not a very good solution and I am looking for a way to generalize that a bit so we could get that feature to master :)

Do you think giving items a new attribute, "loan duration", which would essentially give the normal circulation duration some variation, would work for others as well?

Loan duration could be for ex "short" , "quick" , "normal" , "long" , "epoch" , "forever".

Then in the cgi-bin/koha/admin/smart-rules.pl we could set the "Loan period" for each of the available "Loan duration"s.

So for DVD's with short duration period is 7days, normal is 14days , epoch is 28 days ...

Sounds fair?
Also should be some some flag about whether or not those durations can be renewed/reserved?

How does it sound like?
Comment 8 Olli-Antti Kivilahti 2014-09-11 15:04:23 UTC
Or we could allow setting circulation rules for itemtype and ccode, prefering ccode if it is available?

So no longer having to choose itype or ccode?

Maybe giving ability to syspref whether to prefer ccode or itype.
Comment 9 Sally Healey 2016-03-23 14:23:16 UTC
We'd also be really interested in an overall limit and category sublimits.

We loan books and multimedia, and our multimedia items have different loan lengths and charges per item type.  

For example, we'd like to see on a patron's account:

10 item hard limit - comprising of up to 10 items

Books (3 weeks, no charge):  10 or fewer
Multimedia (no loan period specified, no charge specified):  7 or fewer, in any combination with limits as defined below:

CDs (1 week, £1):  7 or fewer
DVDs (2 weeks, £2):  5 or fewer
Records (3 weeks, £3):  2 or fewer

If 10 books are taken, no multimedia can be taken.

If 7 CDs are taken, no more multimedia items can be taken (CDs, DVDs, Records) - but 3 books can be.

If 3 CDs and 4 DVDs are taken, no more multimedia items can be taken (CDs, DVDs, Records) - but 3 books can be.

If 5 DVDs are taken, no more DVDs can be taken, even if there are '3' multimedia slots left as the DVD limit has been reached.  2 Records, or 2 CDs, or one of each, or 5 books can be taken.
Comment 10 Chris Slone 2017-09-07 18:09:48 UTC
We'd also be interested in this enhancement as it would greatly help us in enforcing our policies. For example, we created two DVD item types in order to provide longer loan periods on DVD sets. Our policies have long dictated that our patrons may have 15 of any combination of DVDs checked-out, but with the current item limits in Koha the DVDs and DVD sets get counted separately.
Comment 11 Chris Slone 2017-09-07 18:27:04 UTC
Forgot to add: Maybe this can take advantage of the Itemtypecat authorized value?
Comment 12 Hugh Rundle 2017-12-29 02:33:46 UTC
Great idea, and would resolve a problem for us too. We have different itemtypes for games for adults vs games for children because we fine adults but not children, but we want to maintain a limit on the number of games you can borrow on a single card, regardless of item type. Definitely should use itemtypecat.
Comment 13 Sajidh 2018-10-14 12:46:05 UTC
Hi (In reply to Chris Slone from comment #11)
> Forgot to add: Maybe this can take advantage of the Itemtypecat authorized
> value?

Hi Chris,

I am a user of KOHA at a library. This is something I have been struggling where I would like to assign the circulation rule for any combination total of few itemtypes. 

I see that itemtypecat helps in categorising on OPAC search but not when assigning the circulation rule. 

My suggestion is to have the itemtypecat auth values as well along with the itemtypes when assigning a circulation rule.  

Regards,
Sajidh
Comment 14 Caroline Cyr La Rose 2019-02-07 16:02:57 UTC
I've also had a request for this.

My case is pretty much the same as what the others said. This particular library has several itemtypes that need to be limited as a group, but the rest of the parameters change. 

For example, they have adult DVD fiction, adult DVD non-fiction, children's DVD fiction and children's DVD non-fiction. Users can borrow 5 DVDs total. Fiction DVDs go out for 3 days and non-fiction DVDs go out for 21 days. Adult can borrow both adult and children's DVDs whereas children can only borrow children's DVDs.

Right now, there is no easy way to enter these rules and limit the loans correctly. Either I group fiction DVDs together and non-fiction DVDs together, but then I have to have another subterfuge for limiting children from borrowing adult DVDs plus there is no way of limiting the total number of loans to 5. Or I group children's DVDs together and adult DVDs together, but then I have no way of varying the loan period and no way to limit to 5 total loaned DVDs.

Anyway, it's a brain wrangling puzzle, no matter how you look at it.

Chris' idea of using itemtypecat is good. The other idea I had was to use something similar to Default checkout limit by patron category, but for itemtype categories.
Comment 15 Katrin Fischer 2019-04-28 23:21:06 UTC

*** This bug has been marked as a duplicate of bug 21946 ***