Bug 6811 - Send renewal notice
Summary: Send renewal notice
Status: RESOLVED DUPLICATE of bug 9151
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: unspecified
Hardware: All All
: PATCH-Sent (DO NOT USE) enhancement (vote)
Assignee: Amit Gupta
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-30 05:16 UTC by Savitra Sirohi
Modified: 2013-01-02 01:20 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Send Item renewal notice (38.79 KB, patch)
2011-09-08 07:29 UTC, Amit Gupta
Details | Diff | Splinter Review
With update DB version xxx (42.82 KB, patch)
2011-09-09 06:06 UTC, Amit Gupta
Details | Diff | Splinter Review
Signed-off patch (42.93 KB, patch)
2011-10-07 16:45 UTC, Owen Leonard
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Savitra Sirohi 2011-08-30 05:16:32 UTC
Similar to checkin, checkout notices already present. Renewal notices can be set in messaging preferences at borrower and membership category level. Contents will be picked up from a notice template.
Comment 1 Amit Gupta 2011-09-08 07:29:09 UTC Comment hidden (obsolete)
Comment 2 Nicole C. Engard 2011-09-08 13:29:37 UTC
Version numbers should only be assigned by the RM. 

The kohaversion file shouldn't be in this patch and the updatedatabase file
should not say:

+$DBversion = "3.05.00.011";

it should instead say:

+$DBversion = "3.05.00.XXX";
Comment 3 Amit Gupta 2011-09-09 06:06:52 UTC Comment hidden (obsolete)
Comment 4 Owen Leonard 2011-10-07 16:45:46 UTC
Created attachment 5781 [details] [review]
Signed-off patch

This works well for me. The notices were sent correctly upon renewal. I wish item and issue information could be included with the notice but it looks like that's an outstanding issue with other notices as well.
Comment 5 Ian Walls 2011-10-07 16:54:37 UTC
This patch uses GetMemberDetails() universally on every renewal, whether or not a notice will actually be generated.  The only bit of information used from this expensive call is the categorycode.  It would be better, therefore, to use GetMember() instead, which is a much lighter-weight subroutine and will result in less of a performance hit.

For example, GetMemberDetails() includes a call to patronflags(), which calls checkoverdues(), which pulls in all the biblio, biblioitems (minus marc), items and issues data for every overdue that patron has...
Comment 6 Jared Camins-Esakov 2013-01-02 01:20:45 UTC
This feature has been implemented by bug 9151.

*** This bug has been marked as a duplicate of bug 9151 ***