Bug 9151 - Renewal notice according to patron alert preferences
Summary: Renewal notice according to patron alert preferences
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P1 - high new feature (vote)
Target Milestone: ---
Assignee: Vitor Fernandes
QA Contact: Paul Poulain
URL:
Whiteboard:
Keywords:
: 6811 (view as bug list)
Depends on:
Blocks: 9413
  Show dependency treegraph
 
Reported: 2012-11-27 12:34 UTC by Vitor Fernandes
Modified: 2014-05-26 21:04 UTC (History)
7 users (show)

See Also:
Change sponsored?: Sponsored
Patch complexity: Medium patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
BUG 9151 - Renewal notice according to patron alert preferences (3.27 KB, patch)
2012-11-27 12:44 UTC, Vitor Fernandes
Details | Diff | Splinter Review
BUG 9151 - Renewal notice according to patron alert preferences (Patch 2) (19.27 KB, patch)
2012-11-27 15:20 UTC, Vitor Fernandes
Details | Diff | Splinter Review
[SIGNED-OFF] BUG 9151 - Renewal notice according to patron alert preferences (3.33 KB, patch)
2012-12-07 12:58 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] BUG 9151 - Renewal notice according to patron alert preferences (Patch 2) (19.25 KB, patch)
2012-12-07 12:59 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9151 - Renewal notice according to patron alert preferences - QA Followup - Fix DB Revs & Grammar (5.18 KB, patch)
2012-12-07 12:59 UTC, Kyle M Hall
Details | Diff | Splinter Review
BUG 9151 - Renewal notice according to patron alert preferences (3.30 KB, patch)
2012-12-20 17:39 UTC, Paul Poulain
Details | Diff | Splinter Review
BUG 9151 - Renewal notice according to patron alert preferences (Patch 2) (19.73 KB, patch)
2012-12-20 17:39 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 9151 - Renewal notice according to patron alert preferences - QA Followup - Fix DB Revs & Grammar (5.18 KB, patch)
2012-12-20 17:39 UTC, Paul Poulain
Details | Diff | Splinter Review
Bug 9151 follow-up: fr-FR translated to french (2.76 KB, patch)
2012-12-20 17:39 UTC, Paul Poulain
Details | Diff | Splinter Review
bug 9151 follow-up: fix sample notice SQL for en (3.47 KB, patch)
2013-01-09 00:55 UTC, Galen Charlton
Details | Diff | Splinter Review
bug 9151 follow-up: fix sample notice SQL for en (3.52 KB, patch)
2013-01-16 20:42 UTC, Hugh Davenport
Details | Diff | Splinter Review
bug 9151 follow-up: fix sample notice SQL for en (3.52 KB, patch)
2013-01-16 20:44 UTC, Hugh Davenport
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Vitor Fernandes 2012-11-27 12:34:38 UTC
Send to patron a renewal notice, which is almost a new checkout notice.
The alert preferences should be the same that the checkout preferences because a renewal is the same that a new checkout.
The template notice should be different.
Comment 1 Vitor Fernandes 2012-11-27 12:44:25 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2012-11-27 13:01:37 UTC
Hi Vitor, 

I like the idea of a renewal notice :)

Do you think you could maybe make it configurable? I can imagine not every library wants to use it and it would make it a bit easier to get it integrated in existing workflows. Ideally I would like to see it on the same level as checkout/return notices with a checkbox in the patron account, but I think a system preference would be ok for now too.

The updatedatabase adds the notice template, which is good, but can you maybe provide a follow-up addings it to the sample files for the different languages? They are used for new installations.
Comment 3 Vitor Fernandes 2012-11-27 14:19:52 UTC
Katrin when I done the patch I had doubts about adding a system preference for controlling the renewal notice.
Thinking better, it's perfectly natural to have a system preference.
Today I'll submit a new patch with that modification and with the translation.
Comment 4 Katrin Fischer 2012-11-27 14:24:41 UTC
Thanks, Vitor :)
Comment 5 Vitor Fernandes 2012-11-27 15:20:44 UTC Comment hidden (obsolete)
Comment 6 Kyle M Hall 2012-12-07 12:58:50 UTC Comment hidden (obsolete)
Comment 7 Kyle M Hall 2012-12-07 12:59:01 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2012-12-07 12:59:11 UTC Comment hidden (obsolete)
Comment 9 Paul Poulain 2012-12-20 17:38:58 UTC
QA comment:
 * passes koha-qa.pl (some tabs are still here instead of 4 spaces, but they were here before)
 * the feature itself is nice !
 * no side effect I can see


passed QA
Comment 10 Paul Poulain 2012-12-20 17:39:07 UTC Comment hidden (obsolete)
Comment 11 Paul Poulain 2012-12-20 17:39:12 UTC Comment hidden (obsolete)
Comment 12 Paul Poulain 2012-12-20 17:39:15 UTC Comment hidden (obsolete)
Comment 13 Paul Poulain 2012-12-20 17:39:19 UTC Comment hidden (obsolete)
Comment 14 Paul Poulain 2012-12-20 17:41:10 UTC
(Updated patch complexity)
Comment 15 Jared Camins-Esakov 2012-12-21 12:41:52 UTC
This patch has been pushed to master.
Comment 16 Jared Camins-Esakov 2013-01-02 01:20:45 UTC
*** Bug 6811 has been marked as a duplicate of this bug. ***
Comment 17 Galen Charlton 2013-01-09 00:55:16 UTC Comment hidden (obsolete)
Comment 18 Galen Charlton 2013-01-09 00:58:05 UTC
Follow-up patch attached that fixes installation breakage introduced by commit 97b05999.
Comment 19 Chris Cormack 2013-01-16 03:32:20 UTC
This feature broke installation in english, needs the follow tested and pushed.
Comment 20 Hugh Davenport 2013-01-16 20:42:06 UTC Comment hidden (obsolete)
Comment 21 Hugh Davenport 2013-01-16 20:44:55 UTC
Created attachment 14639 [details] [review]
bug 9151 follow-up: fix sample notice SQL for en

Fix two different errors that prevented sample notices
from being loaded into a fresh English Koha database.

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Hugh Davenport <hugh@davenport.net.nz>
Comment 22 Katrin Fischer 2013-01-17 07:19:31 UTC
Moving this follow-up to separate bug 9413 as the original feature has already been pushed.