Bug 6905 - Allow selecting a patron from circulation history to take you to their circ page
Summary: Allow selecting a patron from circulation history to take you to their circ page
Status: RESOLVED DUPLICATE of bug 7680
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Robin Sheat
QA Contact: Bugs List
URL:
Whiteboard:
Keywords:
Depends on: 7680
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-22 06:26 UTC by Robin Sheat
Modified: 2014-05-13 13:19 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 6905: [master] change which page clicking users in circ history takes you to (7.17 KB, patch)
2011-09-23 03:24 UTC, Robin Sheat
Details | Diff | Splinter Review
Bug 6905: [3.4.x] change which page clicking users in circ history takes you to (18.98 KB, patch)
2011-09-23 03:25 UTC, Robin Sheat
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Robin Sheat 2011-09-22 06:26:49 UTC
We have a patch that needs to be updated to do this. It adds a syspref so as to allow it not to be a surprise for people.
Comment 1 Robin Sheat 2011-09-23 03:24:56 UTC Comment hidden (obsolete)
Comment 2 Robin Sheat 2011-09-23 03:25:55 UTC Comment hidden (obsolete)
Comment 3 Owen Leonard 2011-10-07 12:47:02 UTC
In all other places in Koha the templates make an arbitrary decision about which page to link to--circ or detail page. I think it's way too specific to set a preference just for this page. 

I would say let's set up a preference which would be more or less global: a "PatronDefaultView" preference to match the BiblioDefaultView one.
Comment 4 Paul Poulain 2011-10-24 11:38:20 UTC
Updating Version : This ENH will be for Koha 3.8
Comment 5 Paul Poulain 2011-10-25 15:05:57 UTC
Bug versionned for master. entries will be made against rel_3_8 once the patch has been applied (see thread about that on koha-devel yesterday)
Comment 6 Chris Cormack 2011-11-07 03:33:20 UTC
Hmm status changed to Failed QA, with no explanation at all on the bug. Please if you change a status can you explain why.
Comment 7 Jonathan Druart 2014-05-13 13:19:39 UTC
The patch proposed on bug 7680 seems more complete than the one proposed here.

*** This bug has been marked as a duplicate of bug 7680 ***