Bug 6670 - Link patron name on returns screen to circulation page instead of patron detail page
Summary: Link patron name on returns screen to circulation page instead of patron deta...
Status: RESOLVED DUPLICATE of bug 7680
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Target Milestone: ---
Assignee: Owen Leonard
QA Contact:
URL:
Whiteboard:
Keywords:
: 9255 (view as bug list)
Depends on: 7680
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-04 17:25 UTC by Owen Leonard
Modified: 2014-05-13 13:18 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Proposed fix (1.42 KB, patch)
2011-08-04 17:29 UTC, Owen Leonard
Details | Diff | Splinter Review
Fix for Bug 6670, Link patron name on returns screen to circulation page instead of patron detail page (1.43 KB, patch)
2011-10-07 15:03 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-08-04 17:25:35 UTC
This minor change is being pulled from the batch of changes in Bug 5436 since it is unrelated to patron attributes.
Comment 1 Owen Leonard 2011-08-04 17:29:34 UTC Comment hidden (obsolete)
Comment 2 Ian Walls 2011-09-26 01:18:44 UTC
This seems to be a matter of preference or library workflow, rather than a bug... changing this universally seems likely to displease as many as it would satisfy.

Could some libraries weigh in on this issue? Is the usual intended patron destination from the returns page the checkout page, or the patron's details?
Comment 3 Paul Poulain 2011-10-07 15:03:40 UTC Comment hidden (obsolete)
Comment 4 Paul Poulain 2011-10-07 15:15:48 UTC
Francois, laurence, Stéphane, Nicole,

What do you think of Ian's comment: when you're in return screen, do you think we should always return to patron page when we click on patron's name, or we should reach check-out page ?

I agree with Ian it can be discussed. But not discussed forever : if we can't find an agreement, then we let things like they are today
Comment 5 Paul Poulain 2011-10-07 15:16:15 UTC
oups, sorry, I didn't wanted to set "passed QA", please answer question 1st !
Comment 6 Owen Leonard 2011-10-07 15:35:04 UTC
I'll copy here my comment on Bug 6905:

In all other places in Koha the templates make an arbitrary decision about
which page to link to--circ or detail page. 

I would say let's set up a preference which would be more or less global: a
"PatronDefaultView" preference to match the BiblioDefaultView one.
Comment 7 Ian Walls 2011-10-19 18:06:16 UTC
I endorse Owen's proposal; it will give us the more consistency across the system, and empower libraries to optimize their workflows.  Either this bug report will need to be altered to cover this new plan, or a new bug report will need to be filed for this feature.
Comment 8 Paul Poulain 2011-10-24 11:40:11 UTC
Updating version : This ENH could be in Koha 3.8
Comment 9 Paul Poulain 2011-10-25 15:05:37 UTC
Bug versionned for master. entries will be made against rel_3_8 once the patch has been applied (see thread about that on koha-devel yesterday)
Comment 10 Marcel de Rooy 2011-11-14 11:44:09 UTC
From the above discussion I conclude that we are waiting on a new patch introducing such a preference. In the meantime I change the status to Failed QA in order to keep the signoff queue clean.
Comment 11 Marcel de Rooy 2011-11-14 11:44:45 UTC
signoff -> signed off
Comment 12 Owen Leonard 2012-12-10 16:44:33 UTC
*** Bug 9255 has been marked as a duplicate of this bug. ***
Comment 13 Jonathan Druart 2014-05-13 13:18:26 UTC

*** This bug has been marked as a duplicate of bug 7680 ***