Bug 7109 - Error in en-GB and en-NZ templates causes JavaScript errors
Summary: Error in en-GB and en-NZ templates causes JavaScript errors
Status: CLOSED DUPLICATE of bug 6574
Alias: None
Product: Koha
Classification: Unclassified
Component: I18N/L10N (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Frédéric Demians
QA Contact: Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-27 19:04 UTC by Owen Leonard
Modified: 2012-10-26 00:40 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2011-10-27 19:04:58 UTC
Where the en-US template has a \ to escape a single quote:

_('Are you sure you want to renew this patron\'s registration?')

...the translated templates are double-escaped:

_('Are you sure you want to renew this user\\'s registration?')

This causes a JavaScript error which breaks further JavaScript processing on the page (like toolbars, menus, etc).
Comment 1 Owen Leonard 2011-12-07 17:02:10 UTC

*** This bug has been marked as a duplicate of bug 6574 ***