Bug 7179 - Removing YUI js library
Summary: Removing YUI js library
Status: CLOSED DUPLICATE of bug 5481
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P1 - high enhancement (vote)
Assignee: Paul Poulain
QA Contact: Ian Walls
URL:
Keywords:
Depends on: 5481
Blocks: 7119
  Show dependency treegraph
 
Reported: 2011-11-06 05:19 UTC by Paul Poulain
Modified: 2012-10-26 00:40 UTC (History)
1 user (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2011-11-06 05:19:04 UTC
We have some JS libraries coming from YUI.
They are in 
koha-tmpl/intranet-tmpl/prog/en/lib/yui and koha-tmpl/opac-tmpl/prog/en/lib
This directory mixes css and javacript. We want to get rid of javascript as possible, to keep only the CSS part of YUI

For example, opac doc-head-close.in open:
<script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
<script type="text/javascript" src="[% yuipath %]/container/container-min.js"></script> 
<script type="text/javascript" src="[% yuipath %]/menu/menu-min.js"></script> 

and staff doc-head-close.inc open:
<script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
<script type="text/javascript" src="[% yuipath %]/datasource/datasource-min.js"></script>
[% IF ( CircAutocompl ) %]
    <script type="text/javascript" src="[% yuipath %]/autocomplete/autocomplete-min.js"></script>
[% END %]
<script type="text/javascript" src="[% yuipath %]/button/button-min.js"></script> 
<script type="text/javascript" src="[% yuipath %]/container/container_core-min.js"></script> 
<script type="text/javascript" src="[% yuipath %]/menu/menu-min.js"></script> 

To find all dependancies, 
grep -R "\[% yuipath %\]" *|grep "\.js"
is a good start

koha-tmpl/intranet-tmpl/prog/en/includes/help-top.inc:<script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/help-top.inc:[% IF ( CircAutocompl ) %]<script type="text/javascript" src="[% yuipath %]/autocomplete/autocomplete-min.js"></script> [% END %]
koha-tmpl/intranet-tmpl/prog/en/includes/help-top.inc:<script type="text/javascript" src="[% yuipath %]/button/button-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/help-top.inc:<script type="text/javascript" src="[% yuipath %]/container/container_core-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/help-top.inc:<script type="text/javascript" src="[% yuipath %]/menu/menu-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/datasource/datasource-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:    <script type="text/javascript" src="[% yuipath %]/autocomplete/autocomplete-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/button/button-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/container/container_core-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/menu/menu-min.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basketgroup.tt:<script type="text/javascript" src="[% yuipath %]/yahoo-dom-event/yahoo-dom-event.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basketgroup.tt:<script type="text/javascript" src="[% yuipath %]/animation/animation-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basketgroup.tt:<script type="text/javascript" src="[% yuipath %]/dragdrop/dragdrop-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basketgroup.tt:<script type="text/javascript" src="[% yuipath %]/element/element-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/basketgroup.tt:<script type="text/javascript" src="[% yuipath %]/tabview/tabview-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/acqui/parcel.tt:<script type="text/javascript" src="[% yuipath %]/json/json-min.js"></script>
koha-tmpl/intranet-tmpl/prog/en/modules/cataloguing/value_builder/unimarc_field_210c_bis.tt:    <script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/modules/cataloguing/value_builder/unimarc_field_210c_bis.tt:    <script type="text/javascript" src="[% yuipath %]/datasource/datasource.js"></script> 
koha-tmpl/intranet-tmpl/prog/en/modules/cataloguing/value_builder/unimarc_field_210c_bis.tt:    <script type="text/javascript" src="[% yuipath %]/autocomplete/autocomplete-min.js"></script>
koha-tmpl/opac-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/utilities/utilities.js"></script> 
koha-tmpl/opac-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/container/container-min.js"></script> 
koha-tmpl/opac-tmpl/prog/en/includes/doc-head-close.inc:<script type="text/javascript" src="[% yuipath %]/menu/menu-min.js"></script>
Comment 1 Katrin Fischer 2011-11-06 09:44:53 UTC
Might be a duplicate or related to bug 5481
Comment 2 Owen Leonard 2011-11-06 12:26:41 UTC

*** This bug has been marked as a duplicate of bug 5481 ***