Bug 7119 - general code-cleaning, tidy/whitespace omnibus
Summary: general code-cleaning, tidy/whitespace omnibus
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Architecture, internals, and plumbing (show other bugs)
Version: master
Hardware: All All
: P5 - low critical (vote)
Assignee: Paul Poulain
QA Contact: Bugs List
URL:
Keywords:
: 9037 (view as bug list)
Depends on: 7170 7174 5481 5778 6000 6019 6020 6990 7076 7171 7172 7176 7177 7179 7181 7182 7183 7184 7846 7872 7879 7886
Blocks: 6015 6193 6679 6836 6875 6986 7167 9036
  Show dependency treegraph
 
Reported: 2011-10-31 09:48 UTC by Paul Poulain
Modified: 2019-06-27 09:24 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 7119 - general code-cleaning, tidy/whitespace omnibus (2.40 KB, patch)
2012-11-08 20:37 UTC, Chris Nighswonger
Details | Diff | Splinter Review
Bug 7119 - general code-cleaning, tidy/whitespace omnibus (2.40 KB, patch)
2012-11-08 20:39 UTC, Chris Nighswonger
Details | Diff | Splinter Review
Bug 7119 - general code-cleaning, tidy/whitespace omnibus (2.45 KB, patch)
2012-11-09 00:08 UTC, Chris Cormack
Details | Diff | Splinter Review
Bug 7119 - general code-cleaning, tidy/whitespace omnibus (2.50 KB, patch)
2012-11-12 16:41 UTC, Paul Poulain
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Poulain 2011-10-31 09:48:59 UTC
This omnibus is created to have a link to all patches related to code improvement and cleaning (perltidy, use Modern::Perl, clean templates,...)
Comment 1 Chris Nighswonger 2012-11-08 20:28:03 UTC
*** Bug 9037 has been marked as a duplicate of this bug. ***
Comment 2 Chris Nighswonger 2012-11-08 20:37:25 UTC Comment hidden (obsolete)
Comment 3 Chris Nighswonger 2012-11-08 20:38:55 UTC
Comment on attachment 13322 [details] [review]
Bug 7119 - general code-cleaning, tidy/whitespace omnibus

>From 65ce9336639acdf20110549c1216f8b084f27858 Mon Sep 17 00:00:00 2001
>From: Christopher Nighswonger <cnighswonger@cnighswonger-dt.(none)>
>Date: Thu, 8 Nov 2012 15:29:48 -0500
>Subject: [PATCH] Bug 7119 - general code-cleaning, tidy/whitespace omnibus
>
>---
> t/00-load.t |   34 +++++++++++++++++-----------------
> 1 file changed, 17 insertions(+), 17 deletions(-)
>
>diff --git a/t/00-load.t b/t/00-load.t
>index afff47d..3cf7a24 100644
>--- a/t/00-load.t
>+++ b/t/00-load.t
>@@ -12,23 +12,23 @@ find({
>     no_chdir => 1,
>     wanted => sub {
>         my $m = $_;
>-	    return unless $m =~ s/[.]pm$//;
>-	    $m =~ s{^.*/C4/}{C4/};	
>-	    $m =~ s{/}{::}g;
>-	    return if $m =~ /Auth_with_ldap/; # Dont test this, it will fail on use
>-	    return if $m =~ /Cache/; # Cache modules are a WIP, add the tests back when we are using them more
>-	    return if $m =~ /SIP/; # SIP modules will not load clean
>-	    return if $m =~ /C4::VirtualShelves$/; # Requires a DB
>-	    return if $m =~ /C4::Auth$/; # DB
>-	    return if $m =~ /C4::Tags$/; # DB
>-	    return if $m =~ /C4::Service/; # DB
>-	    return if $m =~ /C4::Auth_with_cas/; # DB
>-	    return if $m =~ /C4::BackgroundJob/; # DB
>-	    return if $m =~ /C4::UploadedFile/; # DB
>-	    return if $m =~ /C4::Record/; # DB
>-	    return if $m =~ /C4::Reports::Guided/; # DB
>-	    return if $m =~ /C4::Serials/; # DB
>-	    return if $m =~ /C4::VirtualShelves::Page/; # DB
>+        return unless $m =~ s/[.]pm$//;
>+        $m =~ s{^.*/C4/}{C4/};  
>+        $m =~ s{/}{::}g;
>+        return if $m =~ /Auth_with_ldap/; # Dont test this, it will fail on use
>+        return if $m =~ /Cache/; # Cache modules are a WIP, add the tests back when we are using them more
>+        return if $m =~ /SIP/; # SIP modules will not load clean
>+        return if $m =~ /C4::VirtualShelves$/; # Requires a DB
>+        return if $m =~ /C4::Auth$/; # DB
>+        return if $m =~ /C4::Tags$/; # DB
>+        return if $m =~ /C4::Service/; # DB
>+        return if $m =~ /C4::Auth_with_cas/; # DB
>+        return if $m =~ /C4::BackgroundJob/; # DB
>+        return if $m =~ /C4::UploadedFile/; # DB
>+        return if $m =~ /C4::Record/; # DB
>+        return if $m =~ /C4::Reports::Guided/; # DB
>+        return if $m =~ /C4::Serials/; # DB
>+        return if $m =~ /C4::VirtualShelves::Page/; # DB
>         return if $m =~ /C4::Members::Statistics/; # DB
>         use_ok($m) || BAIL_OUT("***** PROBLEMS LOADING FILE '$m'");
>     },
>-- 
>1.7.9.5
Comment 4 Chris Nighswonger 2012-11-08 20:39:21 UTC Comment hidden (obsolete)
Comment 5 Chris Cormack 2012-11-09 00:08:15 UTC Comment hidden (obsolete)
Comment 6 Jared Camins-Esakov 2012-11-12 14:47:33 UTC
Upping severity since the first patch is required for several critical fixes. After pushing I will downgrade this back to enhancement.
Comment 7 Paul Poulain 2012-11-12 16:41:07 UTC
QA comment for http://bugs.koha-community.org/bugzilla3/attachment.cgi?id=13333 :
 * passes koha-qa.pl
 * 17:40 ~/koha.dev/koha-community (new/bug_7119 $%)$ prove t/00-load.t
t/00-load.t .. ok     
All tests successful.
Files=1, Tests=142,  2 wallclock secs ( 0.08 usr  0.01 sys +  1.97 cusr  0.12 csys =  2.18 CPU)
Result: PASS


passed QA
Comment 8 Paul Poulain 2012-11-12 16:41:23 UTC Comment hidden (obsolete)
Comment 9 Jared Camins-Esakov 2012-11-12 23:50:49 UTC
This patch has been pushed to master.
Comment 10 Paul Poulain 2012-11-16 17:28:44 UTC
Patch pushed to branch 3.10.x
Comment 11 Chris Cormack 2013-04-22 10:03:17 UTC
Released in 3.10.0