Bug 7318 - Filtering Patron Card Creator by Category Code Does Nothing
Summary: Filtering Patron Card Creator by Category Code Does Nothing
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low major (vote)
Assignee: Liz Rea
QA Contact: Ian Walls
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-05 00:06 UTC by Larry Zuares
Modified: 2013-12-05 20:04 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Sample Search (618.24 KB, image/jpeg)
2011-12-05 00:06 UTC, Larry Zuares
Details
Patch to fix display (4.02 KB, patch)
2012-01-21 19:05 UTC, Garry Collum
Details | Diff | Splinter Review
Bug 7318 - filtering patron card creator by category code does nothing (1.39 KB, patch)
2012-02-16 02:24 UTC, Liz Rea
Details | Diff | Splinter Review
[Signed Off] Bug 7318: Fixes category display in patroncards Patron Search results. (4.53 KB, patch)
2012-02-16 02:27 UTC, Liz Rea
Details | Diff | Splinter Review
Bug 7318 - filtering patron card creator by category code does nothing (1.43 KB, patch)
2012-02-19 06:55 UTC, Chris Cormack
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Zuares 2011-12-05 00:06:24 UTC
Created attachment 6570 [details]
Sample Search

Please see attached:

Search by Category Codes shows all patrons in all categories. Displays "()" as category for all patrons.
Comment 1 Garry Collum 2012-01-21 19:05:00 UTC Comment hidden (obsolete)
Comment 2 Liz Rea 2012-02-16 02:24:15 UTC Comment hidden (obsolete)
Comment 3 Liz Rea 2012-02-16 02:27:21 UTC Comment hidden (obsolete)
Comment 4 Katrin Fischer 2012-02-16 08:42:26 UTC
Hm, why not have a pulldown with categories to choose one from? Perhaps a possible enhancemant for a follow up patch?
Comment 5 Liz Rea 2012-02-16 16:11:04 UTC
That would be fab, of course. I was kind of, erm, focused on getting the actual function working. I can work on that today. :)

<chants>Incremental improvement! Incremental improvement!</chants>
Comment 6 Katrin Fischer 2012-02-16 16:57:35 UTC
That's why I said "follow up patch"! :) 

<chants>Incremental improvement! Incremental improvement!</chants>
Comment 7 Chris Cormack 2012-02-19 06:55:02 UTC
Created attachment 7751 [details] [review]
Bug 7318 - filtering patron card creator by category code does nothing

This patch should fix the search issue - do note you have to use the *code* and not the *description*

To test:
* replicate the bug:
	* do a patron search in the patron card creator, with the sample data installed, for category code PT - you should get results from all category codes.
* Apply the patch
* do a patron search in the patron card creator, with the sample data installed, for category code PT
* you will get only results in patron category PT.

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

Fixes the search
Comment 8 Katrin Fischer 2012-02-22 06:24:29 UTC
I see 2 signed off patches here... changing status :)
Comment 9 Paul Poulain 2012-02-27 16:58:53 UTC
I must be silly but I can't reproduce the problem (I misundestand what means "search by categorycode" ?)
I was trying to search /cgi-bin/koha/members/member.pl, clicking +, selecting a given categorycode, it works without the patch.

where's my mistake ?
Comment 10 Paul Poulain 2012-02-27 17:00:30 UTC
(In reply to comment #9)
> I must be silly but I can't reproduce the problem (I misundestand what means
> "search by categorycode" ?)
> I was trying to search /cgi-bin/koha/members/member.pl, clicking +, selecting a
> given categorycode, it works without the patch.
> 
> where's my mistake ?

ok, forget me, it's in the title of the bug: Filtering *Patron Card Creator* by Category Code Does Nothing
Comment 11 Paul Poulain 2012-02-27 17:05:38 UTC
QA comment
* it seems that attachment 7751 [details] [review] has been merged into 7672, when I try to apply it, I get : "No changes -- Patch already applied."

* small patch, nothing specific to say, passes tests
Comment 12 Jared Camins-Esakov 2012-05-23 23:47:46 UTC
I believe the second patch has not been pushed. Could someone please test this and confirm whether the problem still exists, and, if it does not, clarify what it is that fixed it? Until the question is resolved, I will not be pushing this to 3.6.x.
Comment 13 Larry Zuares 2012-05-24 11:53:22 UTC
FWIW, I reported the bug and applied the second patch. After applying the patch, the Card Creator now works as designed. I will happily endorse this patch and hope it gets pushed to stable as soon as possible. Thanks.
Comment 14 Jared Camins-Esakov 2012-05-24 12:06:25 UTC
Paul,

Could you please push the patch still attached to this bug? It doesn't seem to be in master. It passed QA a while ago.
Comment 15 Paul Poulain 2012-05-24 13:55:14 UTC
(In reply to comment #14)
> Paul,
> 
> Could you please push the patch still attached to this bug? It doesn't seem
> to be in master. It passed QA a while ago.

When I try to apply this patch, I get:

Applying: Bug 7318 - filtering patron card creator by category code does nothing
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
No changes -- Patch already applied.
Moving to starting point


so it seems it has been applied !(In reply to comment #13)
> FWIW, I reported the bug and applied the second patch. After applying the
> patch, the Card Creator now works as designed. I will happily endorse this
> patch and hope it gets pushed to stable as soon as possible. Thanks.

lsuarez, which version are you running ? that's probably the explanation !
Comment 16 Paul Poulain 2012-06-20 07:38:44 UTC
bumping question for anyone = this patch seems to have been applied. Could someone confirm ?
Comment 17 Jared Camins-Esakov 2012-12-31 01:11:02 UTC
There have been no further reports of problems so I am marking this bug resolved.