Bug 7855 - Bug 7263 does not include maxlength field sets into a fresh install
Summary: Bug 7263 does not include maxlength field sets into a fresh install
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low major (vote)
Assignee: Juan Romay Sieira
QA Contact:
URL:
Keywords:
Depends on: 7263
Blocks: 8018
  Show dependency treegraph
 
Reported: 2012-03-30 08:31 UTC by Juan Romay Sieira
Modified: 2016-12-05 21:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
marcflavour and updatedatabase changed (16.13 KB, patch)
2012-03-30 08:41 UTC, Juan Romay Sieira
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Romay Sieira 2012-03-30 08:31:20 UTC
Bug 7263 does not include maxlength field sets into a fresh install.

NORMARC is not included into updatedatabase.pl too.
Comment 1 Juan Romay Sieira 2012-03-30 08:41:58 UTC
Created attachment 8711 [details] [review]
marcflavour and updatedatabase changed
Comment 2 Magnus Enger 2012-03-30 08:47:18 UTC
Related changes for the NORMARC frameworks are made on bug 7850.
Comment 3 Paul Poulain 2012-04-06 13:59:40 UTC
QA comment: why do you use an UPDATE instead of updating the the INSERT field ? Being inconsistent like that will undoubtfully have some side-effect on the long term, because we will forget that there is an UPDATE in the middle of the INSERT.

Switching to failed QA
Comment 4 Katrin Fischer 2012-04-06 14:44:59 UTC
I think the problem is, that the new column for field length is not part of the inserts yet. So this means updating all lines in all sample files to have the additional value.
Comment 5 Paul Poulain 2012-04-12 08:27:04 UTC
(In reply to comment #4)
> I think the problem is, that the new column for field length is not part of
> the inserts yet. So this means updating all lines in all sample files to
> have the additional value.

I agree, but I think I still let this patch "failed QA". The proper way to fix this problem is to:
* upload a framework file
* update the default value
* dump the tables again (with --extended-insert option, or something like that, not sure of the exact mysqldump parameter)
* create a patch from this update

That will fix the problem of maxlength not being set AND the problem of those dump not being correct
(PS: in UNIMARC, I just checked, and they are correct)
Comment 6 Paul Poulain 2012-04-19 15:16:26 UTC
Katrin, on the chat, promised to take care of a better version of this patch after 3.8
I agree it would be unfair to block it and release a 3.8 version with ppl needing to tune their MARC setup manually just after installing.

So I'll push this patch and set it back to "assigned" for a better fix for 3.10 !
Comment 7 Katrin Fischer 2012-04-19 15:20:32 UTC
I plan to work on some other things like missing tags in default frameworks - I think I can address this issue together with those problems then. Thanks Paul!
Comment 8 Paul Poulain 2012-04-19 15:22:14 UTC
Patch pushed.

Note that I had to remove the lines for:
U	installer/data/mysql/ru-RU/marcflavour/unimarc/mandatory/unimarc_bibliographic_[DEFAULT].sql
U	installer/data/mysql/uk-UA/marcflavour/unimarc/mandatory/unimarc_bibliographic_[DEFAULT].sql
because those patches are not here anymore

Switching back to "ASSIGNED" and waiting for a more proper bugfix
Comment 9 Katrin Fischer 2015-05-25 10:32:08 UTC
At least the translated frameworks can now be generated from the English templates, no problems have occurred since we pushed the initial fix. I am not sure that this still needs to be fixed in a different way (changing the INSERTS).
Maybe just keep it the way it is?