Bug 8415 - Link Serial with Acquisition
Summary: Link Serial with Acquisition
Status: RESOLVED DUPLICATE of bug 5343
Alias: None
Product: Koha
Classification: Unclassified
Component: Serials (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Amit Gupta
QA Contact:
URL:
Keywords:
Depends on: 5357
Blocks: 8456
  Show dependency treegraph
 
Reported: 2012-07-11 08:00 UTC by Amit Gupta
Modified: 2012-10-24 07:39 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Link Serial with Acquisition (22.93 KB, patch)
2012-07-12 05:06 UTC, Amit Gupta
Details | Diff | Splinter Review
Link Serial with Acquisition (23.22 KB, patch)
2012-07-12 07:28 UTC, Amit Gupta
Details | Diff | Splinter Review
Link Serial with Acquisition (22.99 KB, patch)
2012-07-18 08:58 UTC, Amit Gupta
Details | Diff | Splinter Review
Bug 8415 - Link Serial with Acquisition (23.89 KB, patch)
2012-08-25 22:32 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8415: Follow up - Fixing some smaller issues (4.32 KB, patch)
2012-08-25 22:32 UTC, Katrin Fischer
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 8415 - Link Serial with Acquisition (23.80 KB, patch)
2012-09-19 06:16 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8415: Follow up - Fixing some smaller issues (10.15 KB, patch)
2012-09-19 06:16 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8415: Follow up - Fixing some smaller issues (11.12 KB, patch)
2012-09-19 19:22 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 8415: Follow up - Fixing some smaller issues (13.54 KB, patch)
2012-09-19 21:37 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Gupta 2012-07-11 08:00:30 UTC

    
Comment 1 Katrin Fischer 2012-07-11 08:14:45 UTC
Hi Amit,
I know Biblibre has done work in this area - maybe you want to check with them.
Comment 2 Amit Gupta 2012-07-12 05:06:00 UTC Comment hidden (obsolete)
Comment 3 Chris Cormack 2012-07-12 05:49:03 UTC
Amit, 

Is this a patch you wrote, or is a biblibre patch? You have the changed the author of it to you if so.

If it was a patch from someone else (biblibre) which bug was it on, and you should leave the author as them.
Comment 4 Amit Gupta 2012-07-12 07:28:39 UTC Comment hidden (obsolete)
Comment 5 Amit Gupta 2012-07-18 08:58:43 UTC Comment hidden (obsolete)
Comment 6 claire.hernandez@biblibre.com 2012-07-18 11:48:32 UTC
Hello Amit,

Help is welcomed, thanks. I think we should have a look closer because you seem to add the same (but not the same) sub as another bz from us: Bug 5357 and there is maybe others overlaps with our work. More information soon...
Comment 7 Katrin Fischer 2012-08-22 06:14:43 UTC
Hi Amit and Claire,

I would really like to see this functionality in Koha soon - is there a chance we can get a patch that works on top of bug 5357? Or how do you think is the best way to make progress here?
Comment 8 Katrin Fischer 2012-08-25 22:29:06 UTC
I have started testing this patch on top of bug 5357 and have a few questions:

1) When I search for a subscription, there is a checkbox "show only renewed". I have one subscription that is not yet expired and no expired subscriptions. When I check the checkbox, my working subscription is gone. What is a "renewed" subscription? How are those selected from the subscriptions?

2) AcqCreateItem is set to "on order". When creating an order for a subscription, the form forces me to add an item - I am confused by that. I thought that part of the functionality of ordering from subscriptions would include that no items have to be created, because subscriptions can work without items or items should only be created when issues are received.

3) We currently have a functionality to create suggestions when a serial is renewed. will this functionality be integrated with the new ordering process?

What is the intended workflow here?

I have worked on some smaller issues I found while testing - attaching rebased patch and follow up.
Comment 9 Katrin Fischer 2012-08-25 22:32:17 UTC Comment hidden (obsolete)
Comment 10 Katrin Fischer 2012-08-25 22:32:25 UTC Comment hidden (obsolete)
Comment 11 Katrin Fischer 2012-09-19 05:36:18 UTC
Update: bug 5357 has been pushed now - retesting this.
Comment 12 Katrin Fischer 2012-09-19 06:16:17 UTC
Created attachment 12326 [details] [review]
[SIGNED-OFF] Bug 8415 - Link Serial with Acquisition

To Test:
1) Create a basket.
2) Click on From a Subscription link under Add order to basket section.
3) A filter box appear on the left hand side (Search by ISSN, Title, Publisher, Supplier)
4) Search a subscription and click on order to add the order on the basket.
5) If already subscription add to the basket it shows "only one order per subscription is allowed".

Signed-off-by: Amit Gupta <amit.gupta@osslabs.biz>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 13 Katrin Fischer 2012-09-19 06:16:29 UTC Comment hidden (obsolete)
Comment 14 Katrin Fischer 2012-09-19 06:21:11 UTC
These 2 patches can not stand alone - the functionality on neworderempty is missing to make it possible to create an order without being forced to create items. Looking into this now.
Comment 15 Katrin Fischer 2012-09-19 19:22:39 UTC Comment hidden (obsolete)
Comment 16 Katrin Fischer 2012-09-19 21:37:16 UTC
Created attachment 12368 [details] [review]
Bug 8415: Follow up - Fixing some smaller issues

1) Changes the updatedatabase to be a bit more precise and always add
   the new field after claimed_date, like it is in kohastructure.sql.

2) Fixes capitalization rules for the new link to create a serial order.

3) Hides EAN search field when marcflavour is not UNIMARC.

4) Adds documentation for the new column in kohastructure.sql

5) Fixes some terms
  * Branch to Library
  * Search for Serial Routing Lists to Search for serial subscriptions
  * Supplier to Vendor

6) Deletes doubled up SearchSubscriptions from Search.pm
  * Change call to sub to use new signature

7) Deletes "Show only renewed" checkbox and related code.
This feature requires a database field reneweddate in
subscription that is not available in master.
Comment 17 Katrin Fischer 2012-09-24 07:33:41 UTC
There are 2 known problems with those patches:

1) The functionality is incomplete as the part for the new order and item receive forms is still missing. I tried rebasing the patches from Biblibre, but the item management has changed so much I had problems to get it working.

The approach on bug 8456 to solve this is a bit different, I noted my concerns on this bug and also linked to the commit I tried to rebase.

2) While testing I noted a few things with these patches:

a) blocker: If you cancel a subscription order, you can't reorder it. The warning that is supposed to block double orders in a year will remain, there is no order link on the subscription search result list but only the warning.

b) minor: the branch code in the result list should be the branch name, as it is in the filters on the left side.

c) normal: the code should be using the date plugin.
Comment 18 Jonathan Druart 2012-10-24 07:39:11 UTC
Hi Amit,

I proposed the original patch of this feature in Bug 5343.
Given that it was easiest to me to recreate a new patch from scratch and the patch I proposed do the same thing as your one, I mark this bug as duplicate.

*** This bug has been marked as a duplicate of bug 5343 ***