Bug 8456 - Capture the invoice number, price, date of a subscription
Summary: Capture the invoice number, price, date of a subscription
Status: CLOSED DUPLICATE of bug 5343
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Amit Gupta
QA Contact:
URL:
Keywords:
Depends on: 8415
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-17 11:52 UTC by Amit Gupta
Modified: 2014-02-14 11:02 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Capture the invoice number, price, date of a subscription (4.93 KB, patch)
2012-07-18 12:01 UTC, Amit Gupta
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Amit Gupta 2012-07-17 11:52:09 UTC
Ability to capture the invoice number, price, date of a subscription without creating the items records.
This bug depends on bug 8415
Comment 1 Amit Gupta 2012-07-18 12:01:56 UTC
Created attachment 10932 [details] [review]
Capture the invoice number, price, date of a subscription

Create an order using a subscription. This order is different from regular orders in that it is for a serial subscription, not for a book.
When receiving, the item add function does not work as it does in the case of books. Here no item is added since items are added from serials module. But invoice, invoice date, actual cost is captured when receiving.

Two cases here:
1) Systempreferences "AcqCreateItem" is set to "receiving an order"
 When receiving this message is displayed instead of the usual add item fields --  "This order is for a serial subscription. Items are added in the serial module."
2) Systempreferences "AcqCreateItem" is set to "placing an order"
When ordering this message is displayed instead of the usual add item fields --  "This order is for a serial subscription. Items are added in the serial module."

this bug depends on 8415
Comment 2 Katrin Fischer 2012-09-19 06:42:17 UTC
Patch applies and I started testing it.

What irritates me is the fact that it allows to enter a quantity >1. 

At the moment for each copy of a serial we have to add 1 subscription in the serials module. So to me it seems like an order linked to a subscription should only allow to order 1 copy of the serial.

It's not ideal that we have this 1:1 relationship between copies and subscriptions at the moment, but while it's still the case it would probably be better to reflect it in acq?

Or is there a workflow I am missing?
Comment 4 Jonathan Druart 2012-10-24 07:38:51 UTC
Hi Amit,

I proposed the original patch of this feature in Bug 5343.
Given that it was easiest to me to recreate a new patch from scratch and the patch I proposed do the same thing as your one, I mark this bug as duplicate.

*** This bug has been marked as a duplicate of bug 5343 ***