Bug 8488 - Added ubuntu.precise.packages file to correct problems
Summary: Added ubuntu.precise.packages file to correct problems
Status: RESOLVED DUPLICATE of bug 8489
Alias: None
Product: Koha
Classification: Unclassified
Component: Installation and upgrade (command-line installer) (show other bugs)
Version: 3.6
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-21 11:30 UTC by Mark Tompsett
Modified: 2012-07-21 14:59 UTC (History)
0 users

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
Changed yaz versions and added missing perl libraries. (4.96 KB, patch)
2012-07-21 11:40 UTC, Mark Tompsett
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Tompsett 2012-07-21 11:30:19 UTC
libyaz3 and libyaz3-dev are libyaz4 and libyaz4-dev under ubuntu.
Additionally, I found that the following libraries which are listed by ./koha_perl_deps.pl -a (based on C4::Installer::PerlDependencies.pm) were missing in the older ubuntu.package file:
  libclass-accessor-perl
  libhttp-cookies-perl
  libhttp-message-perl
  libjson-perl
  libmodern-perl-perl
  libtext-csv-xs-perl
  liburi-perl
  libwww-perl
  libxml-sax-perl

A diff between install_misc/ubuntu.package and install_misc/ubuntu.precise.package should show only these changes.
Comment 1 Mark Tompsett 2012-07-21 11:40:37 UTC
Created attachment 11061 [details] [review]
Changed yaz versions and added missing perl libraries.

Added ubuntu.precise.packages file to correct problems.
1) Copied ubuntu.packages to ubuntu.precise.packages
2) Changed libyaz3 and libyaz3-dev to libyaz4 and libyaz4-dev.
3) Added the following missing perl libraries:
     libclass-accessor-perl
     libhttp-cookies-perl
     libhttp-message-perl
     libjson-perl
     libmodern-perl-perl
     libtext-csv-xs-perl
     liburi-perl
     libwww-perl
     libxml-sax-perl

A diff between ubuntu.packages and ubuntu.precise.packages should only have these differences.
Comment 2 Mark Tompsett 2012-07-21 14:59:24 UTC
There is no need to create an ubuntu.precise.packages, because the whole thing was restructured by bug 8489.

*** This bug has been marked as a duplicate of bug 8489 ***