Bug 8797 - can't delete quote of the day
Summary: can't delete quote of the day
Status: RESOLVED DUPLICATE of bug 27251
Alias: None
Product: Koha
Classification: Unclassified
Component: Tools (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Keywords:
: 9670 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-20 13:40 UTC by Nicole C. Engard
Modified: 2020-12-16 13:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: ---
Documentation contact:
Documentation submission:
Text to go in the release notes:
Version(s) released in:


Attachments
csv with quotes, for testing (991 bytes, text/csv)
2020-11-06 16:20 UTC, Caroline Cyr La Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2012-09-20 13:40:09 UTC
I am documenting the QOTD feature and trying to delete a quote, but it's not letting me do it. I click on the quote id number and nothing happens - the row isn't highlighted or anything and so I can't delete. I'm on FF on Mac. If I click to add a new quote and don't enter any data then I can click on the ID column of the new empty quote and delete it.
Comment 1 Nicole C. Engard 2012-09-20 14:03:04 UTC
By the way, it does work on the import quotes screen - if I want to delete quotes from there they highlight when I click on the ID with no problem.

Nicole
Comment 2 Marc Véron 2012-09-24 18:56:28 UTC
1)
Add a new quote using "Add quote" button.

2)
Try to select it for deleting (click on ID) -> the line should turn dark gray to indicate that it is selected, but it does not.

3)
Try to select an other, pre existing quote --> Line turns dark gray, quote is deletable.

4)
Reload page. Now, the new quote from step 1) is selectable/deletable as well.

Reproduced several times ond two Koha installations (3.09.00.030 and 3.09.00.056)

If this behaviour can not be fixed, documentation should state that a reload of the page is necessary to be able to delete a new quote.

Marc
Comment 3 Marc Véron 2014-04-13 11:03:04 UTC
Still valid with 3.15.00.028
Comment 4 Chris Nighswonger 2014-04-14 12:12:10 UTC
I cannot reproduce this bug on 3.14.03.000 running over our production DB which contains 86 quotes. Adding the 87th quote works as expected including deleting without a page refresh.

I would be interested to know if those who are experienceing this bug are adding quote number 1 to a DB containing no quotes.
Comment 5 Owen Leonard 2014-04-14 14:56:18 UTC
In my test with the sample quote data when I select a quote and click the delete button nothing happens. However, when I refresh the page the quote is no longer there. Tested with Firefox 28 on Windows using version 3.15.00.028.
Comment 6 Chris Nighswonger 2014-04-16 18:49:50 UTC
I'm running 3.15.00.030.

1. Drop/create database.
2. Run webinstaller, selecting sample quote data.
3. Log in to fresh install
4. Navigate to quote editor
5. Select quote #7
6. Click delete button
7. Table refreshes automatically and removes quote #7

So far so good.

8. Now the remaining quotes are unselectable.
9. Refreshing page makes remaining quote selectable again.
10. Select quote #6.
11. Click delete button
12. Table refreshes automatically and removes quote #6
13. Remaining quotes are once again unselectable

So it appears that the select function gets dropped when the table is redrawn.
Comment 7 Katrin Fischer 2014-07-12 13:30:25 UTC
*** Bug 9670 has been marked as a duplicate of this bug. ***
Comment 8 Joonas Kylmälä 2015-08-25 15:04:14 UTC
At the moment there comes only the following JS error if deleting an quote: TypeError: this.oApi._fnServerParams is not a function. Line 12 in /intranet-tmpl/lib/jquery/plugins/dataTables.fnReloadAjax.js.

I'm trying to figure out an fix for that and after that I'll also look into this bug.
Comment 9 Marc Véron 2016-09-29 15:55:46 UTC
Re-tested on current master.

New problem:
- Have > 30 quotes to make table paging
- On page 1, select a quote by clicking on Id
- Go to page 2
- Select an other quote
- Go to page 1, try to de-select qoute (by clicking on Id)
Result: You can not de-select.
- Try to select an other quote
Result: You can no longer select other quotes
Comment 10 Joonas Kylmälä 2018-08-16 12:02:01 UTC
I'm not working on this anymore so I removed myself from assigned person.
Comment 11 David Nind 2020-02-21 09:12:24 UTC
Still valid for master (February 2020)
Comment 12 Caroline Cyr La Rose 2020-11-06 15:48:38 UTC
Still valid on master (November 2020)
Comment 13 Caroline Cyr La Rose 2020-11-06 16:20:48 UTC
Created attachment 113259 [details]
csv with quotes, for testing
Comment 14 Caroline Cyr La Rose 2020-11-06 16:21:47 UTC
(In reply to Nicole C. Engard from comment #1)
> By the way, it does work on the import quotes screen - if I want to delete
> quotes from there they highlight when I click on the ID with no problem.


I also want to add that there is no more highlighting when trying to delete an imported quote, as there was before (see screenshot from the manual https://gitlab.com/koha-community/koha-manual/-/blob/master/source/images/tools/qotd/selectfordelete.png)

It is, however, possible to delete imported quotes, you just don't see which ones you are deleting.

To replicate :

1) Create a CSV with two columns first the name, then the quote (I've attached a CSV that I've done for testing purposes)
2) Go to Tools > Edit quotes for the QOTD feature
3) Click 'Import quotes'
4) Click 'Browse' and choose the CSV created earlier
5) Click on the id of a couple of quotes. Notice those quotes aren't highlighted
6) Click on the 'Delete quotes' button. Notice the pop up says 'Are you sure you want to delete quote(s) X, Y, Z?'
Comment 15 Jonathan Druart 2020-12-16 10:29:30 UTC
(In reply to Caroline Cyr La Rose from comment #14)
> (In reply to Nicole C. Engard from comment #1)
> > By the way, it does work on the import quotes screen - if I want to delete
> > quotes from there they highlight when I click on the ID with no problem.
> 
> 
> I also want to add that there is no more highlighting when trying to delete
> an imported quote, as there was before (see screenshot from the manual
> https://gitlab.com/koha-community/koha-manual/-/blob/master/source/images/
> tools/qotd/selectfordelete.png)
> 
> It is, however, possible to delete imported quotes, you just don't see which
> ones you are deleting.
> 
> To replicate :
> 
> 1) Create a CSV with two columns first the name, then the quote (I've
> attached a CSV that I've done for testing purposes)
> 2) Go to Tools > Edit quotes for the QOTD feature
> 3) Click 'Import quotes'
> 4) Click 'Browse' and choose the CSV created earlier
> 5) Click on the id of a couple of quotes. Notice those quotes aren't
> highlighted
> 6) Click on the 'Delete quotes' button. Notice the pop up says 'Are you sure
> you want to delete quote(s) X, Y, Z?'

Moved to its own bug report, see bug 27247.
Comment 16 Jonathan Druart 2020-12-16 13:02:56 UTC
I rewrote this page completely, see bug 27251.
That will fix the different issues.

*** This bug has been marked as a duplicate of bug 27251 ***