Bug 9348 - Format dates in HOLD notices consistently
Summary: Format dates in HOLD notices consistently
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Notices (show other bugs)
Version: master
Hardware: All All
: P3 minor (vote)
Target Milestone: ---
Assignee: Kyle M Hall
QA Contact: Jonathan Druart
URL:
Whiteboard:
Keywords:
: 6535 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-04 13:03 UTC by Kyle M Hall
Modified: 2014-05-26 21:04 UTC (History)
3 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9348 - Format dates in HOLD notices consistently (2.82 KB, patch)
2013-01-04 13:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 9348 - Format dates in HOLD notices consistently (2.95 KB, patch)
2013-01-04 17:23 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9348 - Format dates in HOLD notices consistently (2.89 KB, patch)
2013-01-14 15:56 UTC, Jonathan Druart
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-01-04 13:03:45 UTC
Right now notices for holds awaiting pickup read something like this:

You have a hold available for pickup as of 2011-02-12. This hold will expire if it is not picked up before: 02/22/2011. If you no longer need this item or have any questions please contact us

As you can see, we have two different formats for the waiting date and the expiration date. Both dates should be formatting based on the dateformat system preference.
Comment 1 Kyle M Hall 2013-01-04 13:08:13 UTC Comment hidden (obsolete)
Comment 2 Kyle M Hall 2013-01-04 13:10:07 UTC
*** Bug 6535 has been marked as a duplicate of this bug. ***
Comment 3 Owen Leonard 2013-01-04 17:23:15 UTC Comment hidden (obsolete)
Comment 4 Jonathan Druart 2013-01-14 15:56:43 UTC
QA Comment:

The patch makes consistent the date formats for some notices.

Marked as Passed QA.
Comment 5 Jonathan Druart 2013-01-14 15:56:57 UTC
Created attachment 14565 [details] [review]
Bug 9348 - Format dates in HOLD notices consistently

Right now notices for holds awaiting pickup read something like this:

You have a hold available for pickup as of 2011-02-12.
This hold will expire if it is not picked up before: 02/22/2011.
If you no longer need this item or have any questions please contact us

Both dates should be formatting based on the dateformat system preference.

Test Plan:
1) Apply patch
2) Set the HOLD notice to the following:
    <<reserves.waitingdate>> / <<reserves.expirationdate>>
3) Place a hold for a patron
4) Enable the HOLD notice via email for that patron ( requires EnhancedMessaging )
5) Check the item in
6) Go to the borrower's Notices tab, check the body of the new HOLD notice,
   it should have two dates separated by a '/' in the format set by the dateformat
   system preference.

Signed-off-by: Owen Leonard <oleonard@myacpl.org>

Patch works as advertised according to the test plan.
Comment 6 Jared Camins-Esakov 2013-01-18 18:47:29 UTC
This patch has been pushed to master.
Comment 7 Chris Cormack 2013-02-01 08:12:09 UTC
Pushed to 3.10.x and 3.8.x will be in 3.10.3 and 3.8.10