Bug 9742 - Confirm overlay prompt always appears on creating record from Z39.50
Summary: Confirm overlay prompt always appears on creating record from Z39.50
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Cataloging (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Jonathan Druart
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on: 8583
Blocks:
  Show dependency treegraph
 
Reported: 2013-03-04 07:38 UTC by Katrin Fischer
Modified: 2015-12-03 22:02 UTC (History)
6 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Bot Control: ---
When did the bot last check this:
Who signed the patch off:
Text to go in the release notes:


Attachments
Bug 9742: Does not display the popup on creating new record (1.62 KB, patch)
2015-02-23 16:11 UTC, Jonathan Druart
Details | Diff | Splinter Review
[Signed-off] Bug 9742: Does not display the popup on creating new record (1.80 KB, patch)
2015-02-24 12:48 UTC, Marc Véron
Details | Diff | Splinter Review
[PASSED QA] Bug 9742: Does not display the popup on creating new record (1.86 KB, patch)
2015-03-03 11:04 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-03-04 07:38:18 UTC
The new confirmation on starting a z39.50 serach in cataloguing always pops up, even when you are working on a new record that has not been saved yet (see bug 8583).

Steps to reproduce:
1) Go to cataloguing
2) Start a new record by picking a framework
3) Start z39.50 search
Comment 1 Tomás Cohen Arazi 2013-08-02 18:33:29 UTC
I think the confirm popup should remain as long as you are sitting on the MARC cataloguing form. Simply it costs less than checking every field for data.

This should be considered as a usability discussion. I have a proposal to avoid having to choose a framework and *then* doing the search. Please look at bug 10678 Katrin.

Regards
To+
Comment 2 Agnes Rivers-Moore 2014-01-23 00:08:06 UTC
As a cataloguer I agree this prompt should not come up for every blank (new) record. It is very annoying not to have an option to turn this off.

As others mentioned, let the button say "Overwrite with Z39.50"
That's my preference.
Otherwise, could we have a sys preference to have this prompt or not?
Could we have a box to "do not tell me again in this session"?
Comment 3 Tomás Cohen Arazi 2014-01-23 00:23:16 UTC
Agnes, in which workflow you'd end up in the cataloguind interface calling a Z39.50 search?

I asked my librarians the very same question and they answered that it was the way they chose the framework they wanted to use for the harvested record.

When I filled bug 10678 I belived that if you're creating a new record, you'd start at the previous page. When you go More > Catalog. And that's why we added the dropdown for the framework selection. And my librarians were delighted.

So leaving the warning there would be of no harm, as the action is actually going to delete anything you wrote there.

I just leave the comment to continue the discussion.
Comment 4 Agnes Rivers-Moore 2014-01-23 01:22:43 UTC
Hi 
Note that we are on 3.8. but finding this discussion still open I suppose this is still how it works in later versions.

We usually have a pile of items to catalogue, often using the same framework.
We only use More-Catalog to get to New record the first time.
Choose framework from the Add New drop down (which is nice, thanks).
Then in Add MARC record - we click Z39.50 from there.
The message pops up (we have a blank framework because we are adding NEW).
We have to click in response to the message to move on to the Z39.50 search.
After loading, editing and saving the record we use the breadcrumbs to get back to Add New, or the back button to get to the blank MARC with our framework selected.
Again when we click Z39.50, we have an extra click to confirm the message, before it will let us search.
We will be cataloguing 30-40 items at a time, it gets annoying to have the check every time we go to look for a record.

It would make sense if we had started with catalogue search - Edit existing record, but does not make sense when adding new records.

The issue is not with a warning - it is that we have to click OK to clear it every time we open the Z39.50 search form, even if we have seen it 39 times already today, and also even if there is nothing to overwrite because it is a new record.

One other option - maybe the warning could be added to the top of the Z39.50 Search form - so it would be seen but not need an extra click to acknowledge the pop-up message.
Comment 5 Jonathan Druart 2015-02-23 16:11:22 UTC Comment hidden (obsolete)
Comment 6 Marc Véron 2015-02-24 12:48:21 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2015-03-03 11:04:31 UTC
Created attachment 36388 [details] [review]
[PASSED QA] Bug 9742: Does not display the popup on creating new record

The new confirmation on starting a z39.50 serach in cataloguing always
pops up, even when you are working on a new record that has not been
saved yet.

Test plan:
1/ Edit an existing record, click on the Z3950 search button, confirm
the popup appears.
2/ Create a new record, click on the Z3950 search button, confirm
the popup does not appear.

Followed test plan. Works as expected.
Signed-off-by: Marc Véron <veron@veron.ch>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 8 Tomás Cohen Arazi 2015-03-30 16:53:16 UTC
I'm not happy to do this. But I don't agree with this. I'm marking as 'In discussion' for future consideration.
Comment 9 Tomás Cohen Arazi 2015-04-13 18:33:57 UTC
Patch pushed to master.

Thanks Jonathan!

PS. thank Gustavo from UNC that convinced me :-D
Comment 10 Chris Cormack 2015-04-21 23:04:57 UTC
String changes held for 3.18.7
Comment 11 Chris Cormack 2015-04-29 21:45:29 UTC
Applied to 3.18.x will be in 3.18.7
Comment 12 Chris Cormack 2015-04-29 21:48:35 UTC
Applied to 3.18.x will be in 3.18.7