Bug 9786 - [3.8.X] Holds to pull showing items not available
Summary: [3.8.X] Holds to pull showing items not available
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Hold requests (show other bugs)
Version: 3.8
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-11 13:12 UTC by Kyle M Hall
Modified: 2014-05-26 21:04 UTC (History)
5 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9786 - Holds to pull showing items not available (1.48 KB, patch)
2013-03-12 16:00 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9786 - Holds to pull showing items not available (1.44 KB, patch)
2013-03-13 11:46 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9786 - Holds to pull showing items not available (1.53 KB, patch)
2013-03-21 09:48 UTC, Marcel de Rooy
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-03-11 13:12:10 UTC
If an item is on hold and waiting for pickup, and another hold is placed on the record, a hold to pull will show in the Holds to pull report, even though there are no items that can fill that hold request!
Comment 1 Liz Rea 2013-03-12 03:24:13 UTC
I was unable to replicate this on master - perhaps you have something else going on?
Comment 2 Liz Rea 2013-03-12 03:26:00 UTC
To be clear - here is what I did

I had an bib with two items. I placed and filled two holds, both were marked waiting. I then placed a third hold, and ran the "holds to pull" report. The bib was not on the list.
Comment 3 Kyle M Hall 2013-03-12 14:16:49 UTC
Indeed, this appears to be working in master. I discovered it in 3.8.5 I believe.
Comment 4 Kyle M Hall 2013-03-12 15:59:56 UTC
I checked the version having this bug, it's 3.8.8.
Comment 5 Kyle M Hall 2013-03-12 16:00:13 UTC Comment hidden (obsolete)
Comment 6 Chris Cormack 2013-03-12 20:27:51 UTC
Have you checked the bug is still present in 3.8.x (3.8.11 is due to be released in 9 days .. 3.8.8 is nearly 3 months old)
Comment 7 Kyle M Hall 2013-03-13 11:46:01 UTC Comment hidden (obsolete)
Comment 8 Kyle M Hall 2013-03-13 11:46:57 UTC
Yes, this bug appears to be present in 3.8.x

(In reply to comment #6)
> Have you checked the bug is still present in 3.8.x (3.8.11 is due to be
> released in 9 days .. 3.8.8 is nearly 3 months old)
Comment 9 Owen Leonard 2013-03-14 13:03:39 UTC
I can't reproduce this bug in 3.8.x.
Comment 10 Liz Rea 2013-03-14 21:03:38 UTC
Out of curiosity - in the DB where you see this bug, is the item perhaps in transit instead of waiting?
Comment 11 Corinne BULAC 2013-03-21 09:39:23 UTC
Sandbox setup by corinne.hayet@bulac.fr with database 2 and bug 9786 on Thu Mar 21 09:44:59 2013
Something went wrong !
Applying: Bug 9786 - Holds to pull showing items not available
Using index info to reconstruct a base tree...
Falling back to patching base and 3-way merge...
Auto-merging circ/pendingreserves.pl
CONFLICT (content): Merge conflict in circ/pendingreserves.pl
Failed to merge in the changes.
Patch failed at 0001 Bug 9786 - Holds to pull showing items not available
When you have resolved this problem run "git am --resolved".
If you would prefer to skip this patch, instead run "git am --skip".
To restore the original branch and stop patching run "git am --abort".
Bug 9786 - Holds to pull showing items not available

Bug 9786 - Holds to pull showing items not available
Apply? [yn] 
Patch left in /tmp/Bug-9786---Holds-to-pull-showing-items-not-availab-HpPDSE.pat
Comment 12 Marcel de Rooy 2013-03-21 09:41:43 UTC
(In reply to comment #11)
> Sandbox setup by corinne.hayet@bulac.fr with database 2 and bug 9786 on Thu
> Mar 21 09:44:59 2013
> Something went wrong !
> Applying: Bug 9786 - Holds to pull showing items not available
> Using index info to reconstruct a base tree...
> Falling back to patching base and 3-way merge...
> Auto-merging circ/pendingreserves.pl
> CONFLICT (content): Merge conflict in circ/pendingreserves.pl
> Failed to merge in the changes.
> Patch failed at 0001 Bug 9786 - Holds to pull showing items not available
> When you have resolved this problem run "git am --resolved".
> If you would prefer to skip this patch, instead run "git am --skip".
> To restore the original branch and stop patching run "git am --abort".
> Bug 9786 - Holds to pull showing items not available
> 
> Bug 9786 - Holds to pull showing items not available
> Apply? [yn] 
> Patch left in
> /tmp/Bug-9786---Holds-to-pull-showing-items-not-availab-HpPDSE.pat

This seems to be for 3.8.
Comment 13 Marcel de Rooy 2013-03-21 09:48:15 UTC
Created attachment 16589 [details] [review]
Bug 9786 - Holds to pull showing items not available

If an item is on hold and waiting for pickup, and another
hold is placed on the record, a hold to pull will show in the
Holds to pull report, even though there are no items that can
fill that hold request.

Test Plan:
1) Create a record with 1 item
2) Create 2 holds on the record
3) Fill the first hold
4) Check the Holds to pull report, it should show this record
5) Apply patch
6) Reload the Holds to pull report, it should no longer show this record

Signed-off-by: Marcel de Rooy <m.de.rooy@rijksmuseum.nl>
Comment 14 Marcel de Rooy 2013-03-21 09:50:00 UTC
Setting this to Passed QA, but you will just have to attract the attention of the RMaint for 3.8.X to get this pushed.
Comment 15 Marcel de Rooy 2013-03-21 09:55:22 UTC
I stumbled over this in 3.8.3. The line for waiting items was missing there.
Seems hard to reproduce under the latest 3.8.X, but the test for found is not null will do no harm..
Comment 16 Chris Cormack 2013-03-31 01:47:45 UTC
Pushed to 3.8.x will be in 3.8.12