Bug 9820 - Missing space between 100/700 $a and $c (MARC21/XSLT)
Summary: Missing space between 100/700 $a and $c (MARC21/XSLT)
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: MARC Bibliographic data support (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Galen Charlton
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-14 21:27 UTC by Katrin Fischer
Modified: 2015-06-04 23:23 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
bug 9820: display titles in MARC21 name headings better in XSLT mode (8.48 KB, patch)
2013-03-15 21:26 UTC, Galen Charlton
Details | Diff | Splinter Review
bug 9820: display titles in MARC21 name headings better in XSLT mode (10.69 KB, patch)
2013-03-22 22:35 UTC, Galen Charlton
Details | Diff | Splinter Review
bug 9820: display titles in MARC21 name headings better in XSLT mode (10.76 KB, patch)
2013-08-06 00:39 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
Bug 9820 follow-up: fix a typo (1.18 KB, patch)
2013-08-06 00:39 UTC, Jared Camins-Esakov
Details | Diff | Splinter Review
[PASSED QA] Bug 9820: display titles in MARC21 name headings better in XSLT mode (10.86 KB, patch)
2013-08-25 17:15 UTC, Katrin Fischer
Details | Diff | Splinter Review
[PASSED QA] Bug 9820 follow-up: fix a typo (1.24 KB, patch)
2013-08-25 17:15 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-03-14 21:27:30 UTC
For names consisting of 100/700 $a and $c there is no space between $a and $c in OPAC MARC21 detail page and result list using XSLT.
Comment 1 Galen Charlton 2013-03-15 21:26:50 UTC Comment hidden (obsolete)
Comment 2 Katrin Fischer 2013-03-16 07:31:11 UTC
Hi Galen, thank you for your patch :)

I am a bit worried about showing the dates from $d. I suspect our libraries would not like the change and using data from the union catalog $d is probably filled in a lot of records.

Could we remove this field from display again or wrap it in a span with id so it can be hidden?
Comment 3 Magnus Enger 2013-03-20 14:27:07 UTC
Setting this to "in discussion" since bug reporter and patch writer do not seem to agree on the solution. :-)
Comment 4 Galen Charlton 2013-03-22 22:34:38 UTC
(In reply to comment #3)
> Setting this to "in discussion" since bug reporter and patch writer do not
> seem to agree on the solution. :-)

Copies of AACR2 at ten paces!

No, I'm fine with a more minimal change (and besides, that makes it more likely that Jared will accept it for 3.12), and will attach a patch accordingly.
Comment 5 Galen Charlton 2013-03-22 22:35:53 UTC Comment hidden (obsolete)
Comment 6 Owen Leonard 2013-03-25 13:35:49 UTC
I get this error when I do a search in the OPAC:

runtime error: file koha-tmpl/opac-tmpl/prog/en/xslt/MARC21slim2OPACResults.xsl element call-template
The called template 'nameABCDQ' was not found.
 at C4/XSLT.pm line 223
Comment 7 Jared Camins-Esakov 2013-08-06 00:39:43 UTC Comment hidden (obsolete)
Comment 8 Jared Camins-Esakov 2013-08-06 00:39:53 UTC Comment hidden (obsolete)
Comment 9 Bob Birchall 2013-08-06 01:34:48 UTC
Works for me.
Comment 10 Katrin Fischer 2013-08-25 17:15:28 UTC
Created attachment 20591 [details] [review]
[PASSED QA] Bug 9820: display titles in MARC21 name headings better in XSLT mode

Prior to this patch, if a 100/700 had a $c, it would be
displayed with no space between the contents of $a and $c in XSLT mode.

For example,

100 1#$aSeuss,$cDr.

would be displayed as

SeussDr

The problem was caused by the original version of the stylesheets
drawing a bit too much from the MARC21 to MODS transformation.

To test:

[1] In a MARC21 database, turn on XSLT display mode for
    staff and OPAC.
[2] Create or identify a bib that has a 100 or 700 field
    with both a $a and a $c.
[3] Before applying the patch, verify that the name is
    displayed in bib details and search results with the
    name and title squashed together.  For example, "SeussDr"
[3] After applying the patch, verify that the name displays
    in bib details and search results with a space and
    intervening punctuation between the name and the title.  For
    example, "Seuss, Dr."

Signed-off-by: Galen Charlton <gmc@esilibrary.com>
Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Passes test plan, works nicely.
Comment 11 Katrin Fischer 2013-08-25 17:15:43 UTC
Created attachment 20592 [details] [review]
[PASSED QA] Bug 9820 follow-up: fix a typo

Although the XSLT template was renamed to nameABCQ, one instance of
the old name (nameABCDQ) was not corrected. This patch corrects that.

To test: Follow test plan on previous patch

Signed-off-by: Jared Camins-Esakov <jcamins@cpbibliography.com>
Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Comment 12 Galen Charlton 2013-08-26 15:14:48 UTC
Pushed to master.
Comment 13 Tomás Cohen Arazi 2013-09-13 16:43:23 UTC
This patch has been pushed to 3.12.x, will be in 3.12.5.

Thanks Galen!
Comment 14 Bernardo Gonzalez Kriegel 2013-10-13 13:21:36 UTC
Pushed to 3.10.x, will be in 3.10.12