Bug 9917 - Routing list tab on patron account should depend on syspref/permission
Summary: Routing list tab on patron account should depend on syspref/permission
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
: 10279 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-24 19:53 UTC by Katrin Fischer
Modified: 2013-12-05 20:09 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9917 - Routing list tab on patron account should depend on syspref/permission (13.00 KB, patch)
2013-03-28 15:38 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 9917 - Routing list tab on patron account should depend on syspref/permission (13.22 KB, patch)
2013-03-31 05:25 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 9917 - Routing list tab on patron account should depend on syspref/permission (13.25 KB, patch)
2013-03-31 11:53 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Katrin Fischer 2013-03-24 19:53:39 UTC
At the moment the routing list tab on the patron account does always show. This is irritating for libraries not using routing lists or serials.

I see different possibilities, but I am not sure what is best:
- make display of tab dependent on routing permission
- make display of tab dpeendent on RoutingSerials system preference
- don't show tab when patron is not listed on any routing list

Any opinions on this?
Comment 1 Owen Leonard 2013-03-28 15:38:34 UTC Comment hidden (obsolete)
Comment 2 Chris Cormack 2013-03-31 05:25:42 UTC Comment hidden (obsolete)
Comment 3 Katrin Fischer 2013-03-31 11:53:13 UTC
Created attachment 17087 [details] [review]
[PASSED QA] Bug 9917 - Routing list tab on patron account should depend on syspref/permission

The routing list tab displays on patron pages even if the RoutingSerials
preference is OFF. Display of the tab should be conditional on that pref
being turned on.

This patch adds a check for the RoutingSerials preference to the menu
include files and amends the affected scripts to make the variable
available on the pages where those includes are used.

To test, view the following pages with RoutingSerials both on and off.
The routing list tab should be shown and hidden accordingly:

- Circulation
- Patron details
- Patron fines
- Pay fines
- Pay amount/selected (click from the Pay fines page)
- Create manual invoice
- Create manual credit
- Patron circulation history
- Patron modification log
- Patron notices
- Patron routing lists
- Patron statistics
- Patron files
- Patron permissions
- Set patron password
- "Can't delete patron" page (try to delete a patron with checkouts).

Signed-off-by: Chris Cormack <chrisc@catalyst.net.nz>

Touches a lot of files, but only a tiny change in each, works well.
Could perhaps be set in C4/Auth instead, but that's no reason not to
sign off

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
All tests and QA script pass.
Comment 4 Jared Camins-Esakov 2013-03-31 12:52:50 UTC
This patch has been pushed to master.
Comment 5 Owen Leonard 2013-05-17 16:35:39 UTC
*** Bug 10279 has been marked as a duplicate of this bug. ***