Bug 9928 - no way to see all purchase suggestions at all
Summary: no way to see all purchase suggestions at all
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Acquisitions (show other bugs)
Version: 3.10
Hardware: All All
: P5 - low blocker (vote)
Assignee: Bugs List
QA Contact:
URL:
Keywords:
: 9840 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-26 11:19 UTC by Nicole C. Engard
Modified: 2019-06-27 09:24 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:


Attachments
Bug 9928 - no way to see all purchase suggestions at all (3.38 KB, patch)
2013-03-26 14:00 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 9928 - no way to see all purchase suggestions at all (3.46 KB, patch)
2013-03-26 14:08 UTC, Nicole C. Engard
Details | Diff | Splinter Review
Bug 9928 - no way to see all purchase suggestions at all (3.58 KB, patch)
2013-03-29 08:52 UTC, Chris Cormack
Details | Diff | Splinter Review
[PASSED QA] Bug 9928 - no way to see all purchase suggestions at all (3.69 KB, patch)
2013-03-30 18:36 UTC, Katrin Fischer
Details | Diff | Splinter Review
Bug 9928 - no way to see all purchase suggestions at all [3.10.x] (3.74 KB, patch)
2013-04-01 11:58 UTC, Kyle M Hall
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2013-03-26 11:19:05 UTC
This is a huge issue for multi-library systems, and one that was missed obviously. 

When filtering suggestions to see them all if you select "Any" from the library drop down menu and click "Go" it reverts back to a single library (the library the staff member is from).  It is not showing all of the locations as expected - making it impossible for libraries that handle suggestions centrally to do so unless they give their acq staff superlibrarian permissions - which is not feasible.
Comment 1 Nicole C. Engard 2013-03-26 11:25:38 UTC
I lied - no one - not even superlibrarians can get to see all suggestions anymore. It bug 9840 and bug 7300 made it so that you couldn't see them without selecting 'any' from the pull down - but now you can't select any from the pull down regardless of your permission level.

Big blocker!
Comment 2 Kyle M Hall 2013-03-26 14:00:44 UTC Comment hidden (obsolete)
Comment 3 Nicole C. Engard 2013-03-26 14:08:51 UTC Comment hidden (obsolete)
Comment 4 Nicole C. Engard 2013-03-26 14:09:50 UTC
I tested this in Koha 3.10.x and master.  It's a bug in both versions and this patch fixes it.

Nicole
Comment 5 Chris Cormack 2013-03-29 08:47:58 UTC
*** Bug 9840 has been marked as a duplicate of this bug. ***
Comment 6 Chris Cormack 2013-03-29 08:52:45 UTC Comment hidden (obsolete)
Comment 7 Katrin Fischer 2013-03-30 18:36:34 UTC Comment hidden (obsolete)
Comment 8 Jared Camins-Esakov 2013-03-30 20:59:18 UTC
This patch has been pushed to master.
Comment 9 Chris Cormack 2013-03-31 01:58:10 UTC
Does not apply to 3.10.x please rebase and resubmit
Comment 10 Kyle M Hall 2013-04-01 11:58:39 UTC
Created attachment 17091 [details] [review]
Bug 9928 - no way to see all purchase suggestions at all [3.10.x]

Test Plan:
1) Apply patch
3) Create suggestions for multiple libraries
2) Select 'Any' for the 'For' field under 'Acquisition information'
3) Note you are seeing the suggestions for all branches

Signed-off-by: Nicole C. Engard <nengard@bywatersolutions.com>
Works as described

Signed-off-by: Chris Cormack <chris@bigballofwax.co.nz>

http://bugs.koha-community.org/show_bug.cgi?id=9927

Signed-off-by: Katrin Fischer <Katrin.Fischer.83@web.de>
Patch fixes wrong behaviour.
All tests and QA script pass.
Comment 11 Katrin Fischer 2013-04-01 13:09:07 UTC
Not sure, but should this be "pushed to master" to gain Chris' attention?
Comment 12 Marcel de Rooy 2013-04-01 13:50:42 UTC
(In reply to comment #11)
> Not sure, but should this be "pushed to master" to gain Chris' attention?

I would put 3.10.X in the report name and leave it Passed QA.
Pushed to master would not be the right status..
Chris will see it probably soon enough.
Comment 13 Chris Cormack 2013-04-02 06:22:33 UTC
Actually Katrin was right (she usually is), pushed to master is the queue I watch, but Jared alerted me on IRC.

When its something like this, that has been pushed to master, and we have a rebased patch for a maintenance branch it's better to leave it pushed to master.
Comment 14 Chris Cormack 2013-04-02 06:24:34 UTC
Pushed to 3.10.x will be in 3.10.5