Bug 10300 - Allow transferring of items to be have separate IndependentBranches syspref
Summary: Allow transferring of items to be have separate IndependentBranches syspref
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Circulation (show other bugs)
Version: master
Hardware: All All
: P5 - low enhancement (vote)
Assignee: Kyle M Hall
QA Contact: Josef Moravec
URL:
Keywords:
: 8450 (view as bug list)
Depends on: 15758
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-21 16:14 UTC by Kyle M Hall
Modified: 2019-05-29 13:08 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
This enhancement allows libraries to transfer items between themselves when they have IndependentBranches enabled. It adds a new system preference IndependentBranchesTransfers. Setting this to 'No' allows staff to transfer items, setting this to 'Yes' disables it.
Version(s) released in:
19.05.00


Attachments
Bug 10300 - Revert Bug 8781 - Access to Transfer page while "independent branches" is on (3.41 KB, patch)
2013-05-21 16:21 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10300 - Allow transferring of items to be have separate IndependentBranches syspref (4.98 KB, patch)
2016-08-25 15:08 UTC, Kyle M Hall
Details | Diff | Splinter Review
[SIGNED-OFF] Bug 10300 - Allow transferring of items to be have separate IndependentBranches syspref (5.04 KB, patch)
2016-08-26 18:11 UTC, Kyle M Hall
Details | Diff | Splinter Review
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref (3.32 KB, patch)
2019-02-28 15:35 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 10300: (follow-up) add controls on transfers page (4.25 KB, patch)
2019-02-28 15:36 UTC, Fridolin SOMERS
Details | Diff | Splinter Review
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref (3.38 KB, patch)
2019-03-12 12:41 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 10300: (follow-up) add controls on transfers page (4.32 KB, patch)
2019-03-12 12:41 UTC, Martin Renvoize
Details | Diff | Splinter Review
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref (3.44 KB, patch)
2019-04-24 21:57 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 10300: (follow-up) add controls on transfers page (4.37 KB, patch)
2019-04-24 21:57 UTC, Josef Moravec
Details | Diff | Splinter Review
Bug 10300: (QA follow-up) Make database update idempotent (1.97 KB, patch)
2019-04-24 21:57 UTC, Josef Moravec
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kyle M Hall 2013-05-21 16:14:48 UTC
This bug needs reverted, this explanation was given to me by a librarian:

For our group it is useful in order to allow the library to "fix" items that they receive from other libraries for holds requests that have either not been transferred properly by the lending library, so the item was never processed through check in to be placed "in transit," -- there are frequent enough occasions when a library is filling hold requests from their queue and the transfer is not completely placed into effect -- the status will be changed to "in transit" but the "Current Location" is not updated to the borrowing library.  In these instances, the item arrives at the borrowing location, they scan it at check in and get the message "Item must be checked in at home library."

In both of these cases, without the "Transfer" ability, I have to make the transfer for them.  This is not a workable situation.  It is far too manual a system if I have to personally transfer items to libraries myself to correct both of these situations.
Comment 1 Kyle M Hall 2013-05-21 16:21:59 UTC Comment hidden (obsolete)
Comment 2 Srdjan Jankovic 2013-05-31 05:55:40 UTC
I'm not trying to dispute, just want a confirmation - the problem you describe would occur only with independent branches. Is that a legitimate scenario to transfer between independent branches on daily bases?
Comment 3 Galen Charlton 2013-05-31 19:16:46 UTC
(In reply to comment #0)
> This bug needs reverted, this explanation was given to me by a librarian:

I don't think a revert is the way to do it, particularly since we're talking about a patch that's been pushed to several stable branches.  Simply reverting would create a regression for the folks who filed bug 8781 in the first place.

I think the key words in your customer's statement is "for our group".  I suspect it is not every user of IndependentBranches who needs to "fix" items on a regular basis, but I certainly understand and appreciate that some do.  To me, this situation calls for either a new user permission or YASP.

Setting to "in discussion".
Comment 4 Kyle M Hall 2016-08-25 15:08:02 UTC Comment hidden (obsolete)
Comment 5 Kyle M Hall 2016-08-26 18:11:46 UTC
Created attachment 54939 [details] [review]
[SIGNED-OFF] Bug 10300 - Allow transferring of items to be have separate IndependentBranches syspref

Some libraries want to have IndependentBranches enabled, but still be
able to transfer items between themselves.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable IndpendentBranches and IndependentBranchesTransfers
4) Log in as a super librarian
5) Note you can transfer items
6) Log in as a non-super librarian
7) Note you cannot transfer items
8) Disable IndependentBranchesTransfers
9) Note you can now transfer items

Signed-off-by: Maribeth Shafer <mshafer@ckls.org>
Comment 6 Jonathan Druart 2016-08-29 08:04:07 UTC
As bug 15758 is going to pass QA soon, it would be good to rebase this patch on top of it.
Comment 7 Jonathan Druart 2016-09-13 08:28:20 UTC
CONFLICT (content): Merge conflict in circ/branchtransfers.pl
Comment 8 Fridolin SOMERS 2019-02-28 15:35:50 UTC
Created attachment 85880 [details] [review]
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref

Some libraries want to have IndependentBranches enabled, but still be
able to transfer items between themselves.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable IndpendentBranches and IndependentBranchesTransfers
4) Log in as a super librarian
5) Note you can transfer items
6) Log in as a non-super librarian
7) Note you cannot transfer items
8) Disable IndependentBranchesTransfers
9) Note you can now transfer items

Signed-off-by: Maribeth Shafer <mshafer@ckls.org>
Comment 9 Fridolin SOMERS 2019-02-28 15:36:16 UTC
Created attachment 85881 [details] [review]
Bug 10300: (follow-up) add controls on transfers page

This patch moves the check of IndependentBranchesTransfers pref to templates and adds permission test inside branchtransfers.pl.
It also corrects the libraries combobox in branchtransfers.tt, this list can contain all libraries, it is the access to the page that may be protected.

Additions to test plan :
1)
1.1) Enable CircSidebar
1.2) In circulation home page check the effect of IndependentBranchesTransfers on "Transfer" link
1.3) Go to return page and check then effect of IndependentBranchesTransfers on "Transfer" link

2)
2.1) In circ/branchtransfers.pl, with and without IndependentBranches you see all libraries are in combobox

3)
3.1) Set IndependentBranchesTransfers to no and go to circ/branchtransfers.pl
3.2) You are redirected to page 403 unless you are superlibarian
Comment 10 Katrin Fischer 2019-03-11 06:45:38 UTC
I wonder if this can still be considered a major bug after 6 years? Maybe it could be seen as an enh at this point?
Comment 11 Martin Renvoize 2019-03-12 12:39:29 UTC
I agree, this is an enhancement at this point in reality.  It does appear to work so I'm going to SO too.
Comment 12 Martin Renvoize 2019-03-12 12:41:07 UTC
Created attachment 86521 [details] [review]
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref

Some libraries want to have IndependentBranches enabled, but still be
able to transfer items between themselves.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable IndpendentBranches and IndependentBranchesTransfers
4) Log in as a super librarian
5) Note you can transfer items
6) Log in as a non-super librarian
7) Note you cannot transfer items
8) Disable IndependentBranchesTransfers
9) Note you can now transfer items

Signed-off-by: Maribeth Shafer <mshafer@ckls.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 13 Martin Renvoize 2019-03-12 12:41:10 UTC
Created attachment 86522 [details] [review]
Bug 10300: (follow-up) add controls on transfers page

This patch moves the check of IndependentBranchesTransfers pref to templates and adds permission test inside branchtransfers.pl.
It also corrects the libraries combobox in branchtransfers.tt, this list can contain all libraries, it is the access to the page that may be protected.

Additions to test plan :
1)
1.1) Enable CircSidebar
1.2) In circulation home page check the effect of IndependentBranchesTransfers on "Transfer" link
1.3) Go to return page and check then effect of IndependentBranchesTransfers on "Transfer" link

2)
2.1) In circ/branchtransfers.pl, with and without IndependentBranches you see all libraries are in combobox

3)
3.1) Set IndependentBranchesTransfers to no and go to circ/branchtransfers.pl
3.2) You are redirected to page 403 unless you are superlibarian

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>
Comment 14 Josef Moravec 2019-04-24 21:57:02 UTC
Created attachment 88661 [details] [review]
Bug 10300: Allow transferring of items to be have separate IndependentBranches syspref

Some libraries want to have IndependentBranches enabled, but still be
able to transfer items between themselves.

Test Plan:
1) Apply this patch
2) Run updatedatabase.pl
3) Enable IndpendentBranches and IndependentBranchesTransfers
4) Log in as a super librarian
5) Note you can transfer items
6) Log in as a non-super librarian
7) Note you cannot transfer items
8) Disable IndependentBranchesTransfers
9) Note you can now transfer items

Signed-off-by: Maribeth Shafer <mshafer@ckls.org>
Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 15 Josef Moravec 2019-04-24 21:57:07 UTC
Created attachment 88662 [details] [review]
Bug 10300: (follow-up) add controls on transfers page

This patch moves the check of IndependentBranchesTransfers pref to templates and adds permission test inside branchtransfers.pl.
It also corrects the libraries combobox in branchtransfers.tt, this list can contain all libraries, it is the access to the page that may be protected.

Additions to test plan :
1)
1.1) Enable CircSidebar
1.2) In circulation home page check the effect of IndependentBranchesTransfers on "Transfer" link
1.3) Go to return page and check then effect of IndependentBranchesTransfers on "Transfer" link

2)
2.1) In circ/branchtransfers.pl, with and without IndependentBranches you see all libraries are in combobox

3)
3.1) Set IndependentBranchesTransfers to no and go to circ/branchtransfers.pl
3.2) You are redirected to page 403 unless you are superlibarian

Signed-off-by: Martin Renvoize <martin.renvoize@ptfs-europe.com>

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 16 Josef Moravec 2019-04-24 21:57:11 UTC
Created attachment 88663 [details] [review]
Bug 10300: (QA follow-up) Make database update idempotent

Signed-off-by: Josef Moravec <josef.moravec@gmail.com>
Comment 17 Nick Clemens 2019-04-26 12:40:23 UTC
Awesome work all!

Pushed to master for 19.05
Comment 18 Martin Renvoize 2019-04-26 15:59:36 UTC
Enhancement will not be backported at this time.
Comment 19 Katrin Fischer 2019-04-28 13:50:57 UTC
*** Bug 8450 has been marked as a duplicate of this bug. ***