Bug 16810 - Fines note not showing on checkout
Summary: Fines note not showing on checkout
Status: CLOSED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Patrons (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Marc Véron
QA Contact: Testopia
URL:
Keywords:
: 16957 17442 (view as bug list)
Depends on:
Blocks: 16861
  Show dependency treegraph
 
Reported: 2016-06-24 19:47 UTC by Nicole C. Engard
Modified: 2017-06-14 22:13 UTC (History)
11 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Trivial patch
Text to go in the release notes:
Version(s) released in:


Attachments
no fines warning (71.26 KB, image/png)
2016-06-24 19:47 UTC, Nicole C. Engard
Details
Bug 16810 - Fines note not showing on checkout (2.62 KB, patch)
2016-07-06 11:41 UTC, Marc Véron
Details | Diff | Splinter Review
[SIGNED-OFF]Bug 16810: Fines note not showing on checkout (2.70 KB, patch)
2016-07-06 15:19 UTC, Héctor Eduardo Castro Avalos
Details | Diff | Splinter Review
[PASSED QA] Bug 16810: Fines note not showing on checkout (2.76 KB, patch)
2016-07-12 05:48 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Nicole C. Engard 2016-06-24 19:47:41 UTC
Created attachment 52865 [details]
no fines warning

This screenshot from an earlier manual : http://manual.koha-community.org/3.22/en/images/circ/patronnotes.png shows the fines note to the right of the checkout box, but I don't see it anymore in master.  

My patron owes over $10 but I'm not seeing the note.
Comment 1 Nick Clemens 2016-06-24 20:11:55 UTC
Appears to be a regression from bug 14497 - the entire block is inside this if:
[% IF NoIssuesCharge && fines > NoIssuesCharge %]

So you don't get the warning about having any fines unless you have fines over the NoIssuesCharge
Comment 2 Marc Véron 2016-07-06 11:40:05 UTC
Same issue on master.
Comment 3 Marc Véron 2016-07-06 11:41:11 UTC Comment hidden (obsolete)
Comment 4 Héctor Eduardo Castro Avalos 2016-07-06 15:19:15 UTC Comment hidden (obsolete)
Comment 5 Katrin Fischer 2016-07-12 05:44:40 UTC
Hm, a fine not exceeding noissuecharge isn't showing for me, but it should.
Comment 6 Katrin Fischer 2016-07-12 05:47:47 UTC
Sorry... didn't test this right (you should actually apply the patch... right?). But good news is, that this works fine.
Comment 7 Katrin Fischer 2016-07-12 05:48:57 UTC
Created attachment 53301 [details] [review]
[PASSED QA] Bug 16810: Fines note not showing on checkout

Fines did not show on patron checkout and detail pages unless amout
was greater than syspref NoIssueCharges.

This patch fixes the logic in
koha-tmpl/intranet-tmpl/prog/en/includes/blocked-fines.inc

Additionally, it changes links to buttons and makes some small
text changes to ease translation.

To test:
- Apply patch
- Display checkout or detail page and verify proper display for
   a patron who has
   - no fines (no message)
   - fines not exceeding syspref NoissueCharges (message)
   - fines exceeding syspref NoIssueCharges (message)

Signed-off-by: Hector Castro <hector.hecaxmmx@gmail.com>
Works as advertised

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>
Comment 8 Kyle M Hall 2016-07-15 14:13:55 UTC
Pushed to master for 16.11, thanks Marc!
Comment 9 Frédéric Demians 2016-08-01 13:38:36 UTC
Pushed in 16.05. Will be in 16.05.02.
Comment 10 Katrin Fischer 2016-08-01 22:13:58 UTC
*** Bug 16957 has been marked as a duplicate of this bug. ***
Comment 11 Julian Maurice 2016-08-17 10:30:58 UTC
Not needed in 3.22.x
Comment 12 Francois Charbonnier 2016-10-14 13:23:52 UTC
*** Bug 17442 has been marked as a duplicate of this bug. ***