Bug 24433 - OPAC account page no longer asks for confirmation before deleting hold
Summary: OPAC account page no longer asks for confirmation before deleting hold
Status: RESOLVED FIXED
Alias: None
Product: Koha
Classification: Unclassified
Component: Templates (show other bugs)
Version: master
Hardware: All All
: P5 - low normal (vote)
Assignee: Owen Leonard
QA Contact: Testopia
URL:
Keywords:
: 24095 (view as bug list)
Depends on: 21772 24341
Blocks:
  Show dependency treegraph
 
Reported: 2020-01-16 14:15 UTC by Owen Leonard
Modified: 2020-01-31 23:36 UTC (History)
4 users (show)

See Also:
Change sponsored?: ---
Patch complexity: Small patch
Who signed the patch off:
Text to go in the release notes:
Version(s) released in:
20.05.00


Attachments
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold (2.44 KB, patch)
2020-01-16 14:58 UTC, Owen Leonard
Details | Diff | Splinter Review
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold (2.50 KB, patch)
2020-01-17 20:22 UTC, Maryse Simard
Details | Diff | Splinter Review
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold (2.61 KB, patch)
2020-01-19 21:50 UTC, Katrin Fischer
Details | Diff | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Owen Leonard 2020-01-16 14:15:15 UTC
Bug 21772, when adding holds-table.inc, used an older version of opac-detail.tt to create the include. This broke the hold confirmation modal.
Comment 1 Owen Leonard 2020-01-16 14:58:22 UTC
Created attachment 97445 [details] [review]
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold

This patch restores markup added by Bug 21870 and subsequently removed
accidentally by Bug 21772. This allows the OPAC user summary page to
display a confirmation dialog before deleting a hold.

To test, apply the patch and  log in to the OPAC as a user with holds.

 - On the "Your summary" page, click the "Holds" tab.
 - Click the "Cancel" button next to any hold.
 - You should see a modal dialog asking for confirmation, showing the
   correct title.
 - Test both the "Yes" and "No" actions.
Comment 2 Maryse Simard 2020-01-17 20:22:42 UTC
Created attachment 97570 [details] [review]
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold

This patch restores markup added by Bug 21870 and subsequently removed
accidentally by Bug 21772. This allows the OPAC user summary page to
display a confirmation dialog before deleting a hold.

To test, apply the patch and  log in to the OPAC as a user with holds.

 - On the "Your summary" page, click the "Holds" tab.
 - Click the "Cancel" button next to any hold.
 - You should see a modal dialog asking for confirmation, showing the
   correct title.
 - Test both the "Yes" and "No" actions.

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>
Comment 3 Katrin Fischer 2020-01-19 21:50:30 UTC
Created attachment 97592 [details] [review]
Bug 24433: OPAC account page no longer asks for confirmation before deleting hold

This patch restores markup added by Bug 21870 and subsequently removed
accidentally by Bug 21772. This allows the OPAC user summary page to
display a confirmation dialog before deleting a hold.

To test, apply the patch and  log in to the OPAC as a user with holds.

 - On the "Your summary" page, click the "Holds" tab.
 - Click the "Cancel" button next to any hold.
 - You should see a modal dialog asking for confirmation, showing the
   correct title.
 - Test both the "Yes" and "No" actions.

Signed-off-by: Maryse Simard <maryse.simard@inlibro.com>

Signed-off-by: Katrin Fischer <katrin.fischer.83@web.de>

https://bugs.koha-community.org/show_bug.cgi?id=24341
Comment 4 Martin Renvoize 2020-01-20 14:05:07 UTC
Nice work everyone!

Pushed to master for 20.05
Comment 5 Owen Leonard 2020-01-21 13:23:34 UTC
*** Bug 24095 has been marked as a duplicate of this bug. ***
Comment 6 Joy Nelson 2020-01-31 23:36:45 UTC
Not backported to 19.11.x due to dependencies